18 posts
Page 1 of 1
I seem to have two parameters to lower latency during recording: (1) ASIO buffer size and Audiobox USB; and (2) internal block size on Studio One, Options, Audio Setup.

As a rule of thumb, what should these be set to when I am tracking guitars and vocals?

Also, once I've recorded the parts and start mixing, is it okay/preferable to lower one, the other, or both of these parameters? If so, which one(s) and by how much?

For ASIO buffer size, I have: 2048, 1024, 512, 256, 128, 64. For internal block size, I have: 512, 256, 128, 64, and 32 samples.

Thanks!

Studio One Artist 2.6.5.30360, Audiobox USB (two channels), Vox ToneLab

ErisE4.5 monitors, Presonus HD7 2x32 Ohms headphones, PreSonus M7 mic

Dell XPS 8700, Windows 8.1 (64-bit) OS, 16.0 GB RAM

Intel(R)Core(TM)i7-4790 @3.6 GHz, 1.8 TB storage (1.74 free)

Ibanez RGT 42 electric guitar, Ibanez GSR 200 bass guitar
User avatar
by Lokeyfly on Mon Jun 29, 2020 8:49 pm
For the ASIO buffer size, typically choose as short a delay as you can when recording. That amount might vary depending on your track count. For example, early on, you could try 64, and enjoy short latency times of only a few milliseconds. However, it you had perhaps 30 to 40 tracks, you'd best use 128. There is no best prescribed number because of different systems, access read/write times, how many plugins are being used, etc. You have to go with the best minimum latency.

As for playback, things are much more forgiving. You can probably stay at around 256, to 512 for general needs. If you experience dropouts, lags, pops, or just see the CPU meter is too high, try 1024, or the maximum 2048 block size.

Recording will yield the most demands, as your playback and moment you strike a note, finger pick, or sing will require near instant access. If you have an audio interface that has built in mixing, along with effects such as an Audiobox VSL, you can take advantage of near zero latency (about 2 miliseconds). Thunderbolt audio interfaces really eliminate any latency altogethwr, which is always a better choice, but you'll have to weigh that in if such needs arise, where you had clients, or stringent deadlines.

Bottom line is always test, or be aware of what your latency is when recording. Playback mixing is a non issue.

With internal block sizes, I like to keep the maximum when processing audio for mixdown, stemming, and audio rendering because there's lass chance for a glitch, or notice that there was an error during that process. There's no change in the time it takes, but I've simply found a higher buffer just works there with less chance for an issue.

S1 Pro 4.6.x, Laptop: VAIO i7, 8 core, Win 7 64x. Audio Interface: Audiobox 22 VSL, Audiophile 192 Controllers: Arturia Keylab 49 MkII, Novation SL25 MKII, Faderport 8, Roland JV-90, Roland GR-50, Roland Octapad, Akai MPD-18. MIDI Patchbay: MOTU 8x8, Monitoring: Mackie HR824, Yamaha HS-7, Mixer: Yamaha Promix 01, Rane HC-6, Other hardware/Plugins and Libraries, contact me.

My latest release from: Studio One

My last prior release from: Studio One

Latest Album: Amber & Blue

 My music

On YouTube
User avatar
by garybowling on Tue Jun 30, 2020 5:45 am
Yes, it highly depends on your situation.

If you're like me, and basically use a DAW as a "fancy tape machine" and you have an interface with good routing capabilities, you can set everything high and not worry about it. I keep mine at 1024 and 256 respectively all the time.

But I record almost exclusively just audio tracks. Most of my project have no virtual instruments or midi. So I can use my audio interface to route monitor tracks back to the artists when we're recording for virtually zero latency recording. Playback/mixing is not a problem.

However, if you're using virtual instruments, now you have to get the vst sounds back to the artist in a timely fashion, and that all comes from S1.

In that case, as noted above, for recording you need to get it as loaded as possible. That can only be done by testing things and lowering it and testing again.

I will say there are a few tricks to get it lower. If you're on a laptop, putting it in "airplane mode" is a good way to turn off things to reduce latency. If you're on a desktop, turn off your network adapter, bluetooth (if you have it), and any other non-essential hardware during recording. Especially the wireless hardware, wifi/bluetooth/etc.

good luck, gabo

Sager laptop, 32G, 1TB SSD, Win10-64, RME UFX, Studio One Pro 4, Addictive Drums, Izotope O9, Melodyne Studio, all versions updated frequently

The Moderns,
https://open.spotify.com/artist/1x6Fd133GftlRyRYl0xgjf
User avatar
by johnsaxon on Tue Jun 30, 2020 7:13 am
Thank you!

Studio One Artist 2.6.5.30360, Audiobox USB (two channels), Vox ToneLab

ErisE4.5 monitors, Presonus HD7 2x32 Ohms headphones, PreSonus M7 mic

Dell XPS 8700, Windows 8.1 (64-bit) OS, 16.0 GB RAM

Intel(R)Core(TM)i7-4790 @3.6 GHz, 1.8 TB storage (1.74 free)

Ibanez RGT 42 electric guitar, Ibanez GSR 200 bass guitar
User avatar
by Tacman7 on Tue Jun 30, 2020 7:23 am
I'm a music hobbyist, don't work in a studio.

I never use dropout protection so that processing number is always 128. (dropout disables things)

I also use 128 for buffer. I usually have 10 tracks or so and I never need to change it.

If I started using 20 tracks I might raise the buffer if it started having artifacts.

That's the traditional method to set your buffer, keep lowering the latency until you have problems then raise it up to the next setting.

Forum Moderator.
Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Studio Computer
Studio OnePro 4 64bit Melodyne Studio
Win10 i7 7700k 16gb ram 1TB SSD AsusH270M-PLUS interface:StudioKonnekt 48
Nectar Impact LX25+

Kitchen Computer
Win10 Ryzen 5 3600 - Radeon RX 590 - 16GB DDR4 3000MHz - 512GB SSD interface:Komplete Audio 6
User avatar
by johnsaxon on Tue Jun 30, 2020 8:31 pm
garybowling wroteI will say there are a few tricks to get it lower. If you're on a laptop, putting it in "airplane mode" is a good way to turn off things to reduce latency. If you're on a desktop, turn off your network adapter, bluetooth (if you have it), and any other non-essential hardware during recording. Especially the wireless hardware, wifi/bluetooth/etc.


I could use some guidance on this step. I'm using Windows 8.1. I went Control Panel, Network and Internet, Network connections. I see (see attached image): (1) Bluetooth Network Connection; (2) Ethernet; and (3) Wi-Fi.

Ethernet is my standard internet connection. Should I write click that connection and disable it before recording?

I have Bluetooth on this computer but no Bluetooth devices are connected to it. Do I still need to right click that connection and disable it?

I have a wireless router. The ethernet cable that runs from the wall goes to a wireless router. An ethernet cable runs from the router to the back of my computer. Then, I have another desktop with an antenna that connections to the Internet wirelessly through the router. Will I need to right click the Wi-Fi connection and disable it before recording?

If yes to any of these questions, I don't want reconnecting to the Internet and making everything go back to normal a hassle.

Again, please see the attached image. It will help you understand my questions. Thank you.

Attachments
Network Settings.jpg

Studio One Artist 2.6.5.30360, Audiobox USB (two channels), Vox ToneLab

ErisE4.5 monitors, Presonus HD7 2x32 Ohms headphones, PreSonus M7 mic

Dell XPS 8700, Windows 8.1 (64-bit) OS, 16.0 GB RAM

Intel(R)Core(TM)i7-4790 @3.6 GHz, 1.8 TB storage (1.74 free)

Ibanez RGT 42 electric guitar, Ibanez GSR 200 bass guitar
User avatar
by IanM5 on Tue Jun 30, 2020 10:41 pm
johnsaxon wrote
garybowling wroteI will say there are a few tricks to get it lower. If you're on a laptop, putting it in "airplane mode" is a good way to turn off things to reduce latency. If you're on a desktop, turn off your network adapter, bluetooth (if you have it), and any other non-essential hardware during recording. Especially the wireless hardware, wifi/bluetooth/etc.


I could use some guidance on this step. I'm using Windows 8.1. I went Control Panel, Network and Internet, Network connections. I see (see attached image): (1) Bluetooth Network Connection; (2) Ethernet; and (3) Wi-Fi.

Ethernet is my standard internet connection. Should I write click that connection and disable it before recording?

I have Bluetooth on this computer but no Bluetooth devices are connected to it. Do I still need to right click that connection and disable it?

I have a wireless router. The ethernet cable that runs from the wall goes to a wireless router. An ethernet cable runs from the router to the back of my computer. Then, I have another desktop with an antenna that connections to the Internet wirelessly through the router. Will I need to right click the Wi-Fi connection and disable it before recording?

If yes to any of these questions, I don't want reconnecting to the Internet and making everything go back to normal a hassle.

Again, please see the attached image. It will help you understand my questions. Thank you.


John, frankly, unless you think those things are causing you a problem I'd say don't mess with them. Set your buffer to 128 and turn off dropout protection and see how it goes.

If you have too much latency during recording/monitoring lower the buffer to 64. If you get dropouts, crackles etc turn on dropout protection and/or raise the ASIO buffer to 256.

I used to change the buffer size between recording and writing/mixing but I've found that 128 with "no dropout" works for everything I do. I'll typically record one or two tracks at a time with around a dozen tracks playing from S1, a mix of audio tracks and VST instruments. On my previous PC I did used to disconnect from the Internet for the duration of a session but with modern licencing apps and authorisations it becomes a PITA and would not gain me very much at all.

Keep it simple unless it causes a problem! :thumbup:

Studio One Pro 4.5, Intel i5-8400 @ 2.8GHz, 32GB RAM, Windows 10 Pro 64-bit
Focusrite Scarlett 8i6 (3rd Gen), Novation Launchkey Mini Mk3, Akai MPK Mini MKII, Novation Remote 25 (ancient, but not as ancient as I am)
Guitars, Mics, Synths, Upright Piano (tuned circa 2005), £50 drum kit, Wife (with Cello and Cello skills)
User avatar
by Lokeyfly on Wed Jul 01, 2020 3:08 am
Turning off a WIFI device when trying to be efficient with your DAW is good advice.

I do notice a reasonable difference in performance with my Sony laptop when I turn off WIFI. They thankfully have an exterior switch to turn it off. Granted, it's an old computer now, but still very capable. Point being, you should be turning off your WIFI for any serious use when working with your DAW as a simple form of good practices. Hopefully, that is just a switch for you to access.

FWIW, no need for others to chime in on how they don't need to turn WIFI off, or haven't seen a change in performance when doing so. There is a difference, and it will be high track counts and general need of getting the best edge you can will prove beneficial.
Not to mention, keeping out the inter-web Rif-Raf. ;)

S1 Pro 4.6.x, Laptop: VAIO i7, 8 core, Win 7 64x. Audio Interface: Audiobox 22 VSL, Audiophile 192 Controllers: Arturia Keylab 49 MkII, Novation SL25 MKII, Faderport 8, Roland JV-90, Roland GR-50, Roland Octapad, Akai MPD-18. MIDI Patchbay: MOTU 8x8, Monitoring: Mackie HR824, Yamaha HS-7, Mixer: Yamaha Promix 01, Rane HC-6, Other hardware/Plugins and Libraries, contact me.

My latest release from: Studio One

My last prior release from: Studio One

Latest Album: Amber & Blue

 My music

On YouTube
User avatar
by johnsaxon on Wed Jul 01, 2020 7:33 am
Lokeyfly wroteTurning off a WIFI device when trying to be efficient with your DAW is good advice.


So just right-click and disable the Wi-Fi connection?

Studio One Artist 2.6.5.30360, Audiobox USB (two channels), Vox ToneLab

ErisE4.5 monitors, Presonus HD7 2x32 Ohms headphones, PreSonus M7 mic

Dell XPS 8700, Windows 8.1 (64-bit) OS, 16.0 GB RAM

Intel(R)Core(TM)i7-4790 @3.6 GHz, 1.8 TB storage (1.74 free)

Ibanez RGT 42 electric guitar, Ibanez GSR 200 bass guitar
User avatar
by johnsaxon on Wed Jul 01, 2020 7:35 am
[/quote]John, frankly, unless you think those things are causing you a problem I'd say don't mess with them. Set your buffer to 128 and turn off dropout protection and see how it goes.[/quote]

How do I check to see if dropout protection is on?

Studio One Artist 2.6.5.30360, Audiobox USB (two channels), Vox ToneLab

ErisE4.5 monitors, Presonus HD7 2x32 Ohms headphones, PreSonus M7 mic

Dell XPS 8700, Windows 8.1 (64-bit) OS, 16.0 GB RAM

Intel(R)Core(TM)i7-4790 @3.6 GHz, 1.8 TB storage (1.74 free)

Ibanez RGT 42 electric guitar, Ibanez GSR 200 bass guitar
User avatar
by Tacman7 on Wed Jul 01, 2020 8:02 am
That internal buffer can't be changed by itself, you have to change the settings on dropout protection.

The lowest is what you get with the least amount of dropout protection.

Can't turn it off completely.

Forum Moderator.
Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Studio Computer
Studio OnePro 4 64bit Melodyne Studio
Win10 i7 7700k 16gb ram 1TB SSD AsusH270M-PLUS interface:StudioKonnekt 48
Nectar Impact LX25+

Kitchen Computer
Win10 Ryzen 5 3600 - Radeon RX 590 - 16GB DDR4 3000MHz - 512GB SSD interface:Komplete Audio 6
User avatar
by IanM5 on Wed Jul 01, 2020 9:07 am
johnsaxon wrote
How do I check to see if dropout protection is on?


Audio Setup -> Processing. Just set dropout protection to minimum.

And if turning the WiiFi off makes the difference between overload and not you are sailing too close to the wind anyway. It's like taking a pee before getting in your car and expecting it to go faster because it has a lighter load.. :D

Studio One Pro 4.5, Intel i5-8400 @ 2.8GHz, 32GB RAM, Windows 10 Pro 64-bit
Focusrite Scarlett 8i6 (3rd Gen), Novation Launchkey Mini Mk3, Akai MPK Mini MKII, Novation Remote 25 (ancient, but not as ancient as I am)
Guitars, Mics, Synths, Upright Piano (tuned circa 2005), £50 drum kit, Wife (with Cello and Cello skills)
User avatar
by Lokeyfly on Wed Jul 01, 2020 11:20 am
IanM5 wrote: "....And if turning the WiiFi off makes the difference between overload and not you are sailing too close to the wind anyway. It's like taking a pee before getting in your car and expecting it to go faster because it has a lighter load.."



Turning off the wifi hasn't been discusses as the difference between overload, or not. It's in too many lists as best optimising a DAW, so let's avoid the unessesary comments.

From my other PC which uses a UA Apollo, "Wi-Fi network adapter activity can interrupt audio data streams. For optimum performance when using a DAW, disable the Wi-Fi network adapter."

Certainly just a bit more noticeable in lesser or older systems.

S1 Pro 4.6.x, Laptop: VAIO i7, 8 core, Win 7 64x. Audio Interface: Audiobox 22 VSL, Audiophile 192 Controllers: Arturia Keylab 49 MkII, Novation SL25 MKII, Faderport 8, Roland JV-90, Roland GR-50, Roland Octapad, Akai MPD-18. MIDI Patchbay: MOTU 8x8, Monitoring: Mackie HR824, Yamaha HS-7, Mixer: Yamaha Promix 01, Rane HC-6, Other hardware/Plugins and Libraries, contact me.

My latest release from: Studio One

My last prior release from: Studio One

Latest Album: Amber & Blue

 My music

On YouTube
User avatar
by IanM5 on Wed Jul 01, 2020 1:03 pm
Lokeyfly wroteFWIW, no need for others to chime in on how they don't need to turn WIFI off


Lokeyfly wrote so let's avoid the unessesary comments.


FWIW, this is a discussion forum and, last time I looked, you don't get to decide whether views and opinions of others are valid. But nice try, if a little patronising. :roll: .

Can you think of a possible downside to turning off network/WiFi on a modern PC with a DAW and a plethora of plugins? Because I can. :thumbup:

Studio One Pro 4.5, Intel i5-8400 @ 2.8GHz, 32GB RAM, Windows 10 Pro 64-bit
Focusrite Scarlett 8i6 (3rd Gen), Novation Launchkey Mini Mk3, Akai MPK Mini MKII, Novation Remote 25 (ancient, but not as ancient as I am)
Guitars, Mics, Synths, Upright Piano (tuned circa 2005), £50 drum kit, Wife (with Cello and Cello skills)
User avatar
by Lokeyfly on Wed Jul 01, 2020 3:07 pm
johnsaxon wrote
Lokeyfly wroteTurning off a WIFI device when trying to be efficient with your DAW is good advice.


So just right-click and disable the Wi-Fi connection?

Should be my friend. You could try shutting WIFI off, and check the results. Again, it's going to amount to what changes you see in performance. Might be negligible, might be quite noticeable, depending also on your latency tolorence. Turning off WIFI comes up at times for varied snags such as performance or even when rendering to audio to minimize sound artifacts.

@ianm5 - It is a forum, and a discussion. Always has been. Far longer than you've been here. So lets stick to necessary commentary towards the posters very polite questions.

No one is taking a position of what views are and are not valid. Aside from your comment "It's like taking a pee before getting in your car and expecting it to go faster because it has a lighter load". Your words, not mine.

S1 Pro 4.6.x, Laptop: VAIO i7, 8 core, Win 7 64x. Audio Interface: Audiobox 22 VSL, Audiophile 192 Controllers: Arturia Keylab 49 MkII, Novation SL25 MKII, Faderport 8, Roland JV-90, Roland GR-50, Roland Octapad, Akai MPD-18. MIDI Patchbay: MOTU 8x8, Monitoring: Mackie HR824, Yamaha HS-7, Mixer: Yamaha Promix 01, Rane HC-6, Other hardware/Plugins and Libraries, contact me.

My latest release from: Studio One

My last prior release from: Studio One

Latest Album: Amber & Blue

 My music

On YouTube
User avatar
by johnsaxon on Wed Jul 01, 2020 8:29 pm
IanM5 wrote
johnsaxon wrote
How do I check to see if dropout protection is on?


Audio Setup -> Processing. Just set dropout protection to minimum.

And if turning the WiiFi off makes the difference between overload and not you are sailing too close to the wind anyway. It's like taking a pee before getting in your car and expecting it to go faster because it has a lighter load.. :D


Don't see any option for dropout protection on my old version of S12. Went S1, Options, Audio Setup. Have dropdown menus for Audio Device and Internal Block Size and that Appears to be it.

Studio One Artist 2.6.5.30360, Audiobox USB (two channels), Vox ToneLab

ErisE4.5 monitors, Presonus HD7 2x32 Ohms headphones, PreSonus M7 mic

Dell XPS 8700, Windows 8.1 (64-bit) OS, 16.0 GB RAM

Intel(R)Core(TM)i7-4790 @3.6 GHz, 1.8 TB storage (1.74 free)

Ibanez RGT 42 electric guitar, Ibanez GSR 200 bass guitar
User avatar
by Lokeyfly on Thu Jul 02, 2020 3:46 am
Version 2 did not have the option for drop out protection as I recall (I can check that later). Have you tried disabling WIFI from your computer by any means?

As noted, the WiFi suggestion is not a show stopper for this subject at hand, though given S1, v2.6 is what you're using, you may want to think about that next step in updating. You're computer is up to the task, and Presonus have also in recent updates improved CPU performance with plugins, etc. There is no ideal buffer, settings than altering, as the needs arise. For some, resetting buffers or block size won't arise. As also a drummer, I need less than 2 milliseconds of latency due to eternal MIDI controllers & Patchbay, Many can get by with 15 milliseconds or more (when recording).

Btw, some announcement for a new Studio One is occurring on July 7, so stay tuned.

https://www.youtube.com/watch?v=iGAeZ_8Jh84

Cheers.

S1 Pro 4.6.x, Laptop: VAIO i7, 8 core, Win 7 64x. Audio Interface: Audiobox 22 VSL, Audiophile 192 Controllers: Arturia Keylab 49 MkII, Novation SL25 MKII, Faderport 8, Roland JV-90, Roland GR-50, Roland Octapad, Akai MPD-18. MIDI Patchbay: MOTU 8x8, Monitoring: Mackie HR824, Yamaha HS-7, Mixer: Yamaha Promix 01, Rane HC-6, Other hardware/Plugins and Libraries, contact me.

My latest release from: Studio One

My last prior release from: Studio One

Latest Album: Amber & Blue

 My music

On YouTube
User avatar
by johnsaxon on Thu Jul 02, 2020 7:26 am
Lokeyfly wroteVersion 2 did not have the option for drop out protection as I recall (I can check that later). Have you tried disabling WIFI from your computer by any means?

As noted, the WiFi suggestion is not a show stopper for this subject at hand, though given S1, v2.6 is what you're using, you may want to think about that next step in updating. You're computer is up to the task, and Presonus have also in recent updates improved CPU performance with plugins, etc. There is no ideal buffer, settings than altering, as the needs arise. For some, resetting buffers or block size won't arise. As also a drummer, I need less than 2 milliseconds of latency due to eternal MIDI controllers & Patchbay, Many can get by with 15 milliseconds or more (when recording).

Btw, some announcement for a new Studio One is occurring on July 7, so stay tuned.

https://www.youtube.com/watch?v=iGAeZ_8Jh84

Cheers.


I haven't disabled wifi yet because I've yet to have very many problems. If I have problems when I start recording my next song, that's the first think I'll consider.

Studio One Artist 2.6.5.30360, Audiobox USB (two channels), Vox ToneLab

ErisE4.5 monitors, Presonus HD7 2x32 Ohms headphones, PreSonus M7 mic

Dell XPS 8700, Windows 8.1 (64-bit) OS, 16.0 GB RAM

Intel(R)Core(TM)i7-4790 @3.6 GHz, 1.8 TB storage (1.74 free)

Ibanez RGT 42 electric guitar, Ibanez GSR 200 bass guitar

18 posts
Page 1 of 1

Who is online

Users browsing this forum: benbowen3, JohHuisman, romanaverkin, shanfg-hungwu and 35 guests