15 posts
Page 1 of 1
I am not able to use my midi keyboard right away when I load an instrument. I need to setup the midi input for that instrument and set it up again for a new instrument and deselect it on the first one and so on.
for example -
I load Mojito, I need to setup the midi input as Keystation 61 first.
Then when I open an instance of say Maitai, and the Mai Tai track is selected, I still hear Mojito, and when I select midi input on MaiTai as Keystation 61, I hear sounds from both Mojito and MaiTai together
Now I have to deselect Keystation 61 on Mojito and use MaiTai to hear it separately and its the same with every other instrument.
I have attached a video explaining the issue.
Thanks for the help.
phpBB [video]
User avatar
by Tacman7 on Mon Jun 29, 2020 11:18 pm
You're setting the direct midi input on a plugin.

You need to set the input parameter for the track.

It's to the left of the track list, you're not showing it on your vid.

Hit the i button at the top to show that panel.

Input.jpg

Forum Moderator.
Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Studio Computer
Studio OnePro 4 64bit Melodyne Studio
Win10 i7 7700k 16gb ram 1TB SSD AsusH270M-PLUS interface:StudioKonnekt 48
Nectar Impact LX25+

Kitchen Computer
Win10 Ryzen 5 3600 - Radeon RX 590 - 16GB DDR4 3000MHz - 512GB SSD interface:Komplete Audio 6
User avatar
by puneethshenoy on Tue Jun 30, 2020 3:36 am
direct input setting.png
direct input setting.png

I have tried setting it to both the options 'Keystation 61mk3' and 'all inputs'.
but the problem persists.
I just got studio one 4 professional 2 weeks back and it worked fine for a week, and suddenly this problem starting bugging me.

Attachments
direct input setting 2.png
User avatar
by Tacman7 on Tue Jun 30, 2020 7:08 am
All inputs doesn't usually work, sporadic.

You setup your midi devices first right?
https://www.presonus.com/learn/technica ... Studio-One


Also a track won't send midi to the instrument live until you hit the monitor button(to the right of the record button).

So leave the direct midi input to none then set the input to the track and hit monitor button.
Good to learn these settings:
https://www.youtube.com/watch?v=hcUem3U8_LE

Forum Moderator.
Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Studio Computer
Studio OnePro 4 64bit Melodyne Studio
Win10 i7 7700k 16gb ram 1TB SSD AsusH270M-PLUS interface:StudioKonnekt 48
Nectar Impact LX25+

Kitchen Computer
Win10 Ryzen 5 3600 - Radeon RX 590 - 16GB DDR4 3000MHz - 512GB SSD interface:Komplete Audio 6
User avatar
by puneethshenoy on Tue Jun 30, 2020 11:33 am
yes sir, My MIDI device is properly setup.
I do hear the instrument play the patch when the monitor button is turned on, but when I load a new instrument on a different track, I hear both the instruments at the same time.
This issue did not exist initially, it started a week ago.
Would you advice me to delete the settings file so that all my settings are reset or uninstall and reinstall s1 without losing any of my data ?
User avatar
by Tacman7 on Tue Jun 30, 2020 12:19 pm
Sorry, I'm not up on that, maybe somebody jump in.

If you don't want to hear the instrument unclicking the monitor button should do it.

It will play any midi on its track though.

You have to arm the track then hit record to put midi on the track.

Forum Moderator.
Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Studio Computer
Studio OnePro 4 64bit Melodyne Studio
Win10 i7 7700k 16gb ram 1TB SSD AsusH270M-PLUS interface:StudioKonnekt 48
Nectar Impact LX25+

Kitchen Computer
Win10 Ryzen 5 3600 - Radeon RX 590 - 16GB DDR4 3000MHz - 512GB SSD interface:Komplete Audio 6
User avatar
by patrickviens on Tue Jun 30, 2020 1:55 pm
I think you have to go to your External Devices Set up settings for your Keystation 61mk3, then make sure that "Split Midi Channels" is enabled. This will allow you to assign an exclusive midi channel to every instrument / midi track. Otherwise your keyboard will trigger every track that is monitor enabled.Then change the channels on your midi keyboard to trigger every instrument exclusively.
User avatar
by puneethshenoy on Tue Jun 30, 2020 7:59 pm
Midi keyboard config .png

My midi/ext device config is set as the screenshot I have attached below.
selecting and deselecting the monitor button every time is uncomfortable. Isn't there an option which will just enable the monitor button but not record arm the track every time I select it? "instrument input follows selection" record arms the selected track but does not enable monitor. And just record arming the track had another issue which was that I could not hear the sidechaining on a particular track if it was record armed, and some kind person in this forum solved it for me and suggested to deselect the 'instrument input follows selection' & 'audio input follows selection' option and it worked fine after that but the problem with midi came up.
Is there a way that when I select a track, it is not record armed but only monitor enabled?
User avatar
by puneethshenoy on Tue Jun 30, 2020 8:15 pm
I have attached a video explaining my sidechaining isusue. If the sidechain issue is solved, the midi monitor issue comes up. Please suggest me a way around these two problems. It is really hindering my work from the last week.
thanks
phpBB [video]
User avatar
by Tacman7 on Tue Jun 30, 2020 9:50 pm
Can't see the info panel so not sure what you've done so far, you created a send and set the gain?

SetSend.gif


I've not had problems with monitoring my midi input.

Guess I don't know what sort of workflow you're trying to do.

You want to change what instrument the midi is going to while your playing?

Forum Moderator.
Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Studio Computer
Studio OnePro 4 64bit Melodyne Studio
Win10 i7 7700k 16gb ram 1TB SSD AsusH270M-PLUS interface:StudioKonnekt 48
Nectar Impact LX25+

Kitchen Computer
Win10 Ryzen 5 3600 - Radeon RX 590 - 16GB DDR4 3000MHz - 512GB SSD interface:Komplete Audio 6
User avatar
by scottyo7 on Tue Jun 30, 2020 11:44 pm
To the OP... puneethshenoy

-It seems you haven't enabled "Monitor" on a track?
-The "Monitor" allows that track to be heard when you're creating 'input' midi.
-It is the 'speaker' like icon/button to the right of the "Record" icon/button (which reside on each midi/instrument track).

If you've haven't already... Please add your Signature & Gear Info to your Profile Create yours here .
-ASUS i7 Laptop; 16GB; 2 Samsung SSD's; NVIDIA 670MX; Win 10 Home x64.
-S1 Pro 4.6.1; EZD2 2.1.8. Behringer UMC404HD USB A/I.
Synths: Camel Audio Alchemy, Air Tech Music Suite, UVI Digital Synsations.
-Melodyne Studio 4.2.4. Ozone 5, Scuffham S-Gear 2.95, Eleven Rack (all 64bit).
-Akai MPK249. 6 guitars, two Line 6 POD's & an E-bow.
-Fluid Audio FX8 monitors; Dual 28" Displays. Rode NT1; SM58. Faderport;

-My Band: "2GUYZINABASEMENT"
-Just Me
User avatar
by puneethshenoy on Wed Jul 01, 2020 10:51 am
I do understand now that I need to enable monitor to listen to my instrument when I hit a key on my midi keyboard. But my problem now is that, is there a way the monitor is automatically enabled when I select/click on a track and record arm is unaffected at the same time; because as in the last video I have attached, you can see that when a track is record armed, my sidechain does not work and it is really frustrating to un-arm record on a track every time I select it so that I can listen to my sidechain.
Thank You
User avatar
by puneethshenoy on Wed Jul 01, 2020 11:34 am
Okay, the problem is solved.
I have to record arm a track for it to be able to play it and i can do it automatically with "instrument input follows selection" option; but that caused my side-chain to stop working and the solution to that is that I have to turn off "Low Latency Monitoring" .
Thank you so much tacman7, patrickviens and scottyo7 for taking out your time and helping me out with these issues. I really appreciate it.
Thanks Again. :D
User avatar
by scottyo7 on Wed Jul 01, 2020 1:55 pm
Great,
Although not usually fun to track down, you do learn more and it's a joy when things get working. ;)

If you've haven't already... Please add your Signature & Gear Info to your Profile Create yours here .
-ASUS i7 Laptop; 16GB; 2 Samsung SSD's; NVIDIA 670MX; Win 10 Home x64.
-S1 Pro 4.6.1; EZD2 2.1.8. Behringer UMC404HD USB A/I.
Synths: Camel Audio Alchemy, Air Tech Music Suite, UVI Digital Synsations.
-Melodyne Studio 4.2.4. Ozone 5, Scuffham S-Gear 2.95, Eleven Rack (all 64bit).
-Akai MPK249. 6 guitars, two Line 6 POD's & an E-bow.
-Fluid Audio FX8 monitors; Dual 28" Displays. Rode NT1; SM58. Faderport;

-My Band: "2GUYZINABASEMENT"
-Just Me
User avatar
by puneethshenoy on Thu Jul 02, 2020 4:07 am
Couldn't agree more...
Cheers

15 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 25 guests