5 posts
Page 1 of 1
I am a complete newbie to computer based DAWS so please be patient with me ...

I am connecting an Ensoniq SD-1 keyboard (with a sequencer) via an EMU Xmidi 1x1 interface to the usb port of my computer. I finally got the keyboard to be recognized by Studio One (S1). I got the keyboard to slave by midi clock to S1. I added 16 tracks to S1 giving each one a different MIDI channel (1-16). Of course, I set up each track in the keyboard sequencer to have a different MIDI channel. I was using 6 tracks, MIDI channels 2, 3, 4, 5, 6, 16. I muted all tracks that were not being recorded to and armed the appropriate tracks. I hit record and recorded the sequence. Each track in S1 recorded all 6 MIDI tracks.

1 - is there a way to separate the MIDI channels into separate tracks?

2 - How do I record a separate MIDI channel onto a separate track?

I have looked at YouTube until I am blue in the face and Googled, which is how I got here.

Thank you in advance for reading and responding. I'm really at a loss here.

Tal
User avatar
by Bbd on Sat Oct 12, 2019 4:22 pm
When you setup your MIDI Input instrument, you can assign the input channels to use.
See Studio One Reference Manual under MIDI Setup.
Select "Split Channel" to be able to filter your MIDI input by channel.

Then, on an Instrument track you want to received MIDI input for, you select the channel in the In field.

Here's basic setup:
https://www.youtube.com/watch?v=itWM3iY4sfw

Bbd

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


OS: Win 10 x64 Home, Studio One Pro 4.x, Notion 6, Series III 24, Studio 192, Haswell CPU: i7 4790k @ 4.4GHz, RAM: 16GB, Faderport 8/16, Central Station +, PreSonus Sceptre S6, Eris 3.5, ELAC Sub, ATOM
User avatar
by talrodriguez on Sat Oct 12, 2019 5:26 pm
Hello Bbd,

Thank you for the reply.
I watched the video and did what he said.

I did set up the keyboard listing all 16 channels as active and checked the "split channel" box. I assigned each track a MIDI channel number. But still, each track recorded all MIDI channels.

I'm really stumped.
User avatar
by talrodriguez on Sun Oct 13, 2019 12:59 pm
I'm not exactly sure what I did, but I got it to work correctly!

I'm psyched!

The only thing I can think of that I did differently is that instead of "add instrument" tracks I did the "T" with ascending MIDI channels and I did not change any settings.

Anyway, it is working now. Let's just hope I can keep it working!

Thank you, Bbd, for the help!
User avatar
by Bbd on Sun Oct 13, 2019 3:23 pm
:thumbup:

Bbd

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


OS: Win 10 x64 Home, Studio One Pro 4.x, Notion 6, Series III 24, Studio 192, Haswell CPU: i7 4790k @ 4.4GHz, RAM: 16GB, Faderport 8/16, Central Station +, PreSonus Sceptre S6, Eris 3.5, ELAC Sub, ATOM

5 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest