Studiolive 32Ai, 24Ai and 16Ai Consoles with Universal Control Ai, SL Remote Ai, and QMix Ai
1 post
Page 1 of 1
Hey all! Sorry if this has already been asked but I'm checking.

I just got a new laptop windows 10 PC. I specifically got one with a true Thunderbolt 3 port for use with an OWC brand dock with a firewire 800 port to use a stepdown cable to connect to my venerable old Studiolive 16.4.2. So far, although I've gotten my computer to see the studio live as a 2-channel i/o stereo device in windows, I have yet to get Universal Control to recognize it. I've tried both Universal Control AI v 1.7.6 and Universal control 3.0.0. Firmware is v 1.50a, build 190. When I tried Universal Control AI, when I looked in device manager it said that there was an error with the studiolive driver where it was listed in the "sound, video, and game controllers section." Something about a driver accidentally being unsigned. I've tried uninstalling and reinstalling both versions multiple times with all of the requisite restarts in between. I'm officially at my wits' end and I'm not sure what else to do. I feel like I'm so close! I shopped and researched for the right computer and hardware to support my legacy hardware but now I'm stuck. My computer sees the mixer! But Universal Control does not. If anybody has tips for what else to do, I'd be eternally grateful. <3

Here's the error message I get from using universal control AI: Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)

Also of note, the driver version displayed in universal control AI does not match the version number in device manager.

Update: I looked up code 52 and found the documents saying to update to at least version 1.8.3. So I updated to 1.8.3 and it gave me a different error code. I don't remember. 29? 39? 38? Something like that.

Note: Installing Universal Control 3 shows all studiolive devices as installed correctly in device manager.

So what? Should I just start trying every version of universal control in the hope that I find one that works?

1 post
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests