145 postsPage 7 of 8
1 ... 4, 5, 6, 7, 8
Sostene wrote: "How do i make my own set of color to import into the script?


Just load the script as is. You can then colorize it differently, rename it, and save that. Put it in the same scripts folder for easy access. Save and Load any that you've named, right from the toolbar.

Nothing else to bother with.

S1 Pro 4.5.x, Laptop: VAIO i7, 8 core, Win 7 64x. Audio Interface: Audiobox 22 VSL, Audiophile 192 Controllers: Arturia Keylab 49 MkII, Novation SL25 MKII, Faderport 8, Roland JV-90, Roland GR-50, Roland Octapad, Akai MPD-18. MIDI Patchbay: MOTU 8x8, Monitors: Mackie HR824, Yamaha HS-7, Mixer: Yamaha Promix 01. Other hardware/Plugins and Libraries, contact me.

Latest Album: Amber & Blue

 My music

On Bandcamp

On YouTube
User avatar
by THECELTANDIR1 on Fri Jan 10, 2020 5:23 pm
I can get the color bar to come up and as long as I hi-lite the "E", I can change colors on the track segments with no problem. But when I disengage and try to color the channel, I get a script error.

Attachments
Screen Shot 2020-01-10 at 6.16.46 PM.png
User avatar
by Lokeyfly on Fri Jan 10, 2020 6:04 pm
Read the very first comment from the user who was nice enough to create the Track color script.

Lawrence wrote: "Here's a toolbar add-on that allows you to create, store, import and export custom color sets of 40 colors using any RGB colors to color tracks or events."


The name of the post is Track Colors. Now I can't say for sure because I haven't tried to color channels which isn't a part of the script. Says nothing about that.

Feel free to color tracks, or events though.

S1 Pro 4.5.x, Laptop: VAIO i7, 8 core, Win 7 64x. Audio Interface: Audiobox 22 VSL, Audiophile 192 Controllers: Arturia Keylab 49 MkII, Novation SL25 MKII, Faderport 8, Roland JV-90, Roland GR-50, Roland Octapad, Akai MPD-18. MIDI Patchbay: MOTU 8x8, Monitors: Mackie HR824, Yamaha HS-7, Mixer: Yamaha Promix 01. Other hardware/Plugins and Libraries, contact me.

Latest Album: Amber & Blue

 My music

On Bandcamp

On YouTube
User avatar
by THECELTANDIR1 on Fri Jan 10, 2020 6:42 pm
Perhaps I wasn't clear, but it will ONLY color the events.... but not the track. When I attempt to change the track color is when I get the error.
User avatar
by Trucky on Sat Jan 11, 2020 1:43 pm
THECELTANDIR1 wrotePerhaps I wasn't clear, but it will ONLY color the events.... but not the track. When I attempt to change the track color is when I get the error.

What OS and Studio One versions are you on?

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 10 Pro 64-bit (1909), Studio One 4.6.1 Pro | Notion 6.5 | Universal Control v.3.1.2.54970
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
StudioLive Series III 32 v2.1.16522
User avatar
by THECELTANDIR1 on Tue Jan 14, 2020 10:25 am
Studio One Pro 3.5.6 Mac OS High Sierra 10.13.6
User avatar
by Trucky on Tue Jan 14, 2020 11:19 am
Thanks! That explains it.
I tried it on my 3.5.6 version (works on my 4.6 version) and saw the same errors.

The developer for the Color toolbar designed it to work in Studio One 4 so features may or may not work in earlier versions of Studio One.

Please note that there are no plans for backwards compatibility.

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 10 Pro 64-bit (1909), Studio One 4.6.1 Pro | Notion 6.5 | Universal Control v.3.1.2.54970
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
StudioLive Series III 32 v2.1.16522
User avatar
by THECELTANDIR1 on Tue Jan 14, 2020 12:35 pm
Thanks Trucky!
User avatar
by kozmyk on Sun Jan 19, 2020 10:15 am
I really like this toolbar package. Well done Lawrence.
Do you know if there is a way to Lock colours ?
I'm forever changing them by accident as I scroll wheel back anf forth; on the Mix page particularly.
My Ctrl+Z gets used more for Undiong unwanted colour changes than anything else ...

PC-i7 4.3GHz 32GB, Win10Home64, StudioOnePro4.6, Melodyne4Studio, PresonusFirepod(FP10 firmware). Mixers-various(Soundcraft,Behringer,Studiomaster), Remotes- Android Tablets,Instruments-Basses,Guitars,Keyboards
User avatar
by Lokeyfly on Sun Jan 19, 2020 11:47 am
It's the gift that keeps on giving!
No way to lock colors as it is, unless you modify the script yourself. I wouldn't know those possibilities, due to time constraints. Lawrence has had numerous questions, requests, and thoughts for such color medications, but I like how he's kept it simple. What you see is what you get.

Suggestion. If you like how you set up some colors, just simply rename the file, and save it. You'd be locking the whole group, but it's still a way to keep what is there.

You could store and retrieve color names as necessary for the type of song, i.e. Rock, Soft, Trio Band, Orchestral, etc.....
Hope that helps.

Hey, the fact that you can control Z back, is a good thing. Now just hold tame that scroll wheel. ;)

S1 Pro 4.5.x, Laptop: VAIO i7, 8 core, Win 7 64x. Audio Interface: Audiobox 22 VSL, Audiophile 192 Controllers: Arturia Keylab 49 MkII, Novation SL25 MKII, Faderport 8, Roland JV-90, Roland GR-50, Roland Octapad, Akai MPD-18. MIDI Patchbay: MOTU 8x8, Monitors: Mackie HR824, Yamaha HS-7, Mixer: Yamaha Promix 01. Other hardware/Plugins and Libraries, contact me.

Latest Album: Amber & Blue

 My music

On Bandcamp

On YouTube
User avatar
by kozmyk on Mon Jan 20, 2020 5:06 am
The lock colour facility wouldn't strictly have to be part of Lawrence's toolbar.
I posted the question here as it might be something that Lawrence might Know about.
Being a related function then, a small s[ace on Lawrence's toolbar might be a suitable place for a Colour Lock Button.
Perhaps I'll also post in Feature Requests and see who salutes it ...

PC-i7 4.3GHz 32GB, Win10Home64, StudioOnePro4.6, Melodyne4Studio, PresonusFirepod(FP10 firmware). Mixers-various(Soundcraft,Behringer,Studiomaster), Remotes- Android Tablets,Instruments-Basses,Guitars,Keyboards
User avatar
by Lokeyfly on Mon Jan 20, 2020 7:08 am
Yeah, others do modify scripts, so it's out there. Little has changed with this, but nothing ventured, nothing gained, I guess. Good luck, as it sounds like it will be a good feature for you and some others.

S1 Pro 4.5.x, Laptop: VAIO i7, 8 core, Win 7 64x. Audio Interface: Audiobox 22 VSL, Audiophile 192 Controllers: Arturia Keylab 49 MkII, Novation SL25 MKII, Faderport 8, Roland JV-90, Roland GR-50, Roland Octapad, Akai MPD-18. MIDI Patchbay: MOTU 8x8, Monitors: Mackie HR824, Yamaha HS-7, Mixer: Yamaha Promix 01. Other hardware/Plugins and Libraries, contact me.

Latest Album: Amber & Blue

 My music

On Bandcamp

On YouTube
User avatar
by kalebgebremedhin on Tue Feb 04, 2020 5:52 am
thanks for this color scheme it helps a lot
User avatar
by BezowinZ on Tue Feb 04, 2020 3:21 pm
THECELTANDIR1 wrotePerhaps I wasn't clear, but it will ONLY color the events.... but not the track. When I attempt to change the track color is when I get the error.
To spin off this, can someone (re)confirm if these colors are available for console channels? I currently have tracks, events and channels colored with the sub par options available and would like to keep with that theme.

I believe the answer when I asked a while back as no. But this script was mentioned in a Facebook group, so I asked there in case something had changed, and I was told yes.

Can someone confirm, please?

Studio One 4.6.1 Pro, Mac OS 10.14, 3.6GHz 8-Core i9, 64GB RAM, Clarett 8Pre Thunderbolt, MOTU MIDI ExpressXT

Presonus, I’m still human! Please find a better security method, please. Or at least take me back where I was after.

And where the hell is my avatar?!? I get a little jelly seeing everyone else's.
User avatar
by Trucky on Tue Feb 04, 2020 3:51 pm
BezowinZ wroteI currently have tracks, events and channels colored with the sub par options available and would like to keep with that theme.

There's multiple color setting options in Studio One 4.6.1 that can impact the Color Tracks add-on. For me, when I click on a channel or track it updates both with my color choice. With the Event button enabled it only colors the event.

Can you post a screenshot describing your request regarding "track, event, channels colored with sub par options" and what color setting options you have enabled?

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 10 Pro 64-bit (1909), Studio One 4.6.1 Pro | Notion 6.5 | Universal Control v.3.1.2.54970
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
StudioLive Series III 32 v2.1.16522
User avatar
by BezowinZ on Tue Feb 04, 2020 5:45 pm
Trucky wrote
BezowinZ wroteI currently have tracks, events and channels colored with the sub par options available and would like to keep with that theme.

There's multiple color setting options in Studio One 4.6.1 that can impact the Color Tracks add-on. For me, when I click on a channel or track it updates both with my color choice. With the Event button enabled it only colors the event.

Can you post a screenshot describing your request regarding "track, event, channels colored with sub par options" and what color setting options you have enabled?
I think that answers my question. I was only saying I'm set up like you, so that changing colors for a track/channel changes it for the other. My events are also the color of the relative track/channel.

I thought someone said earlier in the thread that this script only applied to track colors. I must've misunderstood. I'll be downloading.

One more question. Is the color "strip" hide-able or is it permanently shown in the toolbar?

Thanks!

Studio One 4.6.1 Pro, Mac OS 10.14, 3.6GHz 8-Core i9, 64GB RAM, Clarett 8Pre Thunderbolt, MOTU MIDI ExpressXT

Presonus, I’m still human! Please find a better security method, please. Or at least take me back where I was after.

And where the hell is my avatar?!? I get a little jelly seeing everyone else's.
User avatar
by Trucky on Tue Feb 04, 2020 11:24 pm
The icon is always there (once added to Scripts folder) in the menu but the color selection bar only shows when you click on the icon.

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 10 Pro 64-bit (1909), Studio One 4.6.1 Pro | Notion 6.5 | Universal Control v.3.1.2.54970
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
StudioLive Series III 32 v2.1.16522
User avatar
by kerryvance on Fri Feb 07, 2020 1:01 pm
I downloaded the file and placed it in the scripts folder. When I open Studio One (4.6 Professional), I have the colors icon and the dialog box opens but there are no colors in the small rectangles where the colors should be. Any help would be appreciated. Thanks.
Studio One colors package.jpg
User avatar
by Trucky on Fri Feb 07, 2020 3:27 pm
What's your screen resolution? I'm not sure if the screenshot you posted is cropped but not all 8 groups of colors (5 per group) are being displayed.

Image

If it's not a screen resolution issue, try loading the "Default Set" from the dropdown menu:

Image

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 10 Pro 64-bit (1909), Studio One 4.6.1 Pro | Notion 6.5 | Universal Control v.3.1.2.54970
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
StudioLive Series III 32 v2.1.16522
User avatar
by kerryvance on Fri Feb 07, 2020 6:27 pm
My resolution is set for 1920 x 1200 (recommended) and yes, all 8 of the color groups are displayed. When I try loading the Default Set, nothing happens. (I tried uploading a larger jpg and got a dialog box telling me the maximum size had to be no more than 800 pixels wide and 600 pixels high). Thanks for such a quick response, Trucky.

Windows 10 (Home) - Dell XPS8930
Intel(R) Core i7-8700 CPU @ 3.20GHz / 6 cores / 16.0 GB ram
NVIDIA GeForce GTX1050 Ti
Presonus Studio One Professional 4.6.1
Focusrite Clarett 4PRE USB

145 postsPage 7 of 8
1 ... 4, 5, 6, 7, 8

Who is online

Users browsing this forum: No registered users and 16 guests