1 post
Page 1 of 1
Sup y'all!

I just wanted to share my experience with my Faderport and possibly help someone out.

So, long story short, I picked up a faderport classic 2nd hand and it didn't include a power adapter.

Unfortunately I had no real way to know if the motorized fader worked (aside from the seller saying "it works great!" :roll: ) but i took a chance anyway!

When I finally acquired a power adapter the faderport's motorized fader worked. :thumbup:

Then, out of the blue one day it stopped working. :thumbdown:

So I tried updating the firmware ( I had to use another (older) computer to get it to update ~ so when I finally found a computer with a USB 2.0 connection that worked for the updating process)- I updated it to the latest version v1.45. -

(For those of you trying to update your faderport: You'll know the updating process has *finally* started when the faderport's button lights on the bottom (eg:rewind, fast fwd,stop,play,record) all start moving in a sequence from left to right)

Still no motorized fader.

I tried switching ports (USB 2.0, 3.0 ~ I went through all of the ones on my computer) ~ still no luck..

Finally I stumbled across a video where a user had used a USB 2.0 hub and had success, so remembering that I had one somewhere I dug around and eventually found my old logitech USB 2.0 hub.

From there I plugged it in and *Boom* its now working!

:punk:

Cubase users: Don't forget to download this file to set up native mode in Cubase.

This was on a 2018 Windows 10 Lenovo PC.

I hope this helps somebody.

:+1


1 post
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests