Requests or concerns about the forum itself.
Technical Support requests should be logged directly at http://support.presonus.com
2 posts
Page 1 of 1
I have been waiting for Studio One to download all features for 2 days now. The computer has been running constantly for over 36 hours and has not even completed the first couple inserts. The downloads are less than 1KB per second and keep stopping. I have an upgraded system with 10GB Ram and 2TB HD on a Win 8.2 OS System. I tried hooking direct to the modem which operates at 300MB through Comcast fiber network. It is definitely not my hardware running slow. I have downloaded numerous different software combinations and usually the content is not more than 2 hours even if the files are up to 3GB of memory. Is there an overseas tie-up with the downloads coming from the manufacturer?? Not happy Rix :-(
User avatar
by Trucky on Mon Feb 04, 2019 9:38 pm
Have you tried downloading these files from your My.PreSonus account instead of through the Studio One interface?

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 10 Pro 64-bit (v1909: Build 18363.476), Studio One 4.5.5 Pro | Notion 6.5 | Universal Control v3.1.0.53214
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
StudioLive Series III 32 v2.1.16232

2 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests