Discuss Studio 2|4, 2|6, 6|8, 18|10, and 18|24 USB 2.0 Interfaces Here
4 posts
Page 1 of 1
Hi everyone,

Hope someone can help me out, because it's driving me nuts....

I've connected a Philips DCC player using SPDIF. The input works fine and i can record in my DAW, but recording with the DCC isn't working. The link is there, but i'm not getting any signal.

I've tried all sorts of options in Universal Control, but nothing seems to do the trick.

Tried with a CD player with SPDIF and that just worked fine, so it's not the DCC player.

Is there a routing option i don't know about in UC? PC is Windows 10...

Thanks in advance for the help ;)

Kind regards,
Dennis de Haan
User avatar
by dennisdehaan on Wed Jan 02, 2019 10:53 am
To clarify, i connected the cd player to the DCC :D
User avatar
by SwitchBack on Wed Jan 02, 2019 12:16 pm
In section 4.2.2 of the owner's manual it shows you where in UC Surface you can set the S/PDIF output source.

DCC, that's kinda retro ;)
User avatar
by dennisdehaan on Wed Jan 02, 2019 1:57 pm
Thanks, but i've figured that out already.

Seems i have found a solution tough… I quited all my audio programs. Switched to 48khz and then back to 44.1khz and voila i have i signal :shock:

Kinda strange and i hope the signal will be there when i've rebooted my machine....

And yeah… DCC is kinda oldschool but a great medium to capture (even more oldschool) cassette tapes :)

Thanks for the help!

Kind regards,
Dennis de Haan

4 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests