20 posts
Page 1 of 1
The Series III 1.9 firmware comes with free plug-ins (Classic Compressor, Vintage 3-band EQ, The Tube P1B Compressor and The Tube Midrange EQ), but only for a limited time. On August 11 you will have to pay for the plug-ins again...

Read more about the new firmware and the free offer:
https://www.presonus.com/press/press-releases/PreSonus-Announces-Major-StudioLive-Series-III-Update-and-Free-Plug-Ins

RM32AI + RM16AI + CS18AI on sale now
32R

Apple routers | iPads | PreSonus SW5E & Motu AVB switches | Alesis iO Dock with AudioTools' Smaart RTA & spectograph extension |
Yamaha S112, S15e, S10e, SM12, SM10 | Galaxy Audio Hot Spots | Mac mini | Studio One Pro 3.5
User avatar
by Bbd on Mon Jul 30, 2018 7:50 pm
This is a great incentive to update to the latest firmware!
:thumbup:

Bbd

Please add your specs to your SIGNATURE.
OVERVIEW of how to get your issue fixed.
Search the ONLINE MANUAL, Create a SUPPORT TICKET and/or Post Issue.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.



OS: Win 10 x64 Home, Studio One Pro 4.1, Notion 6, Series III 24, Steinberg UR44, Haswell CPU: i7 4790k @ 4.4GHz, RAM: 16GB, Faderport 8/16, Cental Station Plus, Eris 3.5, ELAC Sub, Akai MPK261, Roland T6
User avatar
by alaistairdeacon on Tue Jul 31, 2018 12:29 am
Given the problems I had with the the last update (1.8???) I'm going to let a few of you kind folk upgrade first.

I had to roll back (to 1.7???) as 1.8 had too many issues for me, things like the SD channel record scroll disappearing etc. ANd when I've got a group of volunteers running the desk at the hurch and I'm getting calls all the time.

I saw there was more of a public beta of 1.9 - I'm looking for the posts on that...

But it would be great for folk top post their experiences. And I'm glad that Presonus is taking the firmware updates seriously - I had got the feeling that testing quality had been dropping off (I'm a S/W developer in my real life - so experienced about that kinda stuff).

Love to hear folks feedback!
User avatar
by wahlerstudios on Tue Jul 31, 2018 8:03 am
The beta forum is closed, but the threads there did not show "big" problems. We will see it in the next few weeks... No 1.9, no free vintage plug-ins... ;-)

RM32AI + RM16AI + CS18AI on sale now
32R

Apple routers | iPads | PreSonus SW5E & Motu AVB switches | Alesis iO Dock with AudioTools' Smaart RTA & spectograph extension |
Yamaha S112, S15e, S10e, SM12, SM10 | Galaxy Audio Hot Spots | Mac mini | Studio One Pro 3.5
User avatar
by alaistairdeacon on Wed Aug 01, 2018 6:31 am
Is there even a summary of what was found during beta?
Is this release exactly the same as the beta, of the beta plus a few last fixes.

I would hope to upgrade in time to get my free plug ins....

So get posting folk - interested in experiences (and I DO want to upgarde - I've just got a ton of volunteers who really moaned at me last time)
User avatar
by wahlerstudios on Wed Aug 01, 2018 7:22 am
If you wait for thousands of encouraging comments, the free plug-ins probably will be gone... ;-) Changes in firmware and software can always and everywhere cause new and old problems, but the 1.9 firmware seems to be ok for the ones who use their mixer in a "normal" way. This time there is something special going on. The release of Firmware 1.9 follows the release of UC 2.8, which gives life to the Series III "ecosystem". The theme of UC 2.8 is networking and firmware 1.9 "translates" all that to the hardware.

If you want to know more, read this article from the Knowledge Base:

https://support.presonus.com/hc/en-us/articles/360009899212-StudioLive-Series-III-1-9-Firmware-Update-Universal-Control-Version-2-8

Here are some "highlights":
● Soft-patching across AVB streams now works as expected
● Console remote preamp control over Rack Mixer in Monitor Mix mode now works as expected
● DAW Mode now works with all supported Studio One languages
● Series III Rack Mixer metering now working as expected in UC Surface
● Gain Reduction meters now shown as expected in UC Surface for Buses
● 6-band Fat Channel EQ High Shelf button now works as expected
● Console Solo PFL switch now responds instantly

but also some "known issuses":
● EQ and Comp order and switching are broken for Matrix mix buses
● Solo PFL switch is too slow
● Currently selected/adjusted Parameter Value display names need improvement

RM32AI + RM16AI + CS18AI on sale now
32R

Apple routers | iPads | PreSonus SW5E & Motu AVB switches | Alesis iO Dock with AudioTools' Smaart RTA & spectograph extension |
Yamaha S112, S15e, S10e, SM12, SM10 | Galaxy Audio Hot Spots | Mac mini | Studio One Pro 3.5
User avatar
by golishevsky on Sat Aug 04, 2018 4:35 pm
Image

in UC Control some plug-ins are very inconvenient to use with the help of the trackpad macbook. If someone from developers reads this forum, I ask to pay attention to it. I don't use the mouse for more than 10 years, I do everything on the trackpad. And think such as I a huge number of people.
User avatar
by Bbd on Sat Aug 04, 2018 8:48 pm
Best to create a feature request for your suggestion.

Bbd

Please add your specs to your SIGNATURE.
OVERVIEW of how to get your issue fixed.
Search the ONLINE MANUAL, Create a SUPPORT TICKET and/or Post Issue.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.



OS: Win 10 x64 Home, Studio One Pro 4.1, Notion 6, Series III 24, Steinberg UR44, Haswell CPU: i7 4790k @ 4.4GHz, RAM: 16GB, Faderport 8/16, Cental Station Plus, Eris 3.5, ELAC Sub, Akai MPK261, Roland T6
User avatar
by golishevsky on Sun Aug 05, 2018 3:31 am
Bbd wroteBest to create a feature request for your suggestion.


I don't know English well. I can't say and describe what I need.
User avatar
by wahlerstudios on Sun Aug 05, 2018 4:51 pm
Indeed, the "Vintage 3-band Equalizer" Plug-in is especially screen unfriendly. The three big knobs are no problem, the four small knobs are nearly impossible to grab and move. It doesn't really work on iPad either, but it works with a mouse. It's a pity, because this plug-in is becoming my favorite for fast & drastic sound shaping. But I suppose that's the price we have to pay for the "recycling" of old hardware. The older it looks, the better it must be...

RM32AI + RM16AI + CS18AI on sale now
32R

Apple routers | iPads | PreSonus SW5E & Motu AVB switches | Alesis iO Dock with AudioTools' Smaart RTA & spectograph extension |
Yamaha S112, S15e, S10e, SM12, SM10 | Galaxy Audio Hot Spots | Mac mini | Studio One Pro 3.5
I'm getting a message saying "No compatible items found in your PreSonus account.", I've upgraded both our SL32 and SL24R and it's currently before the 11th...

Any pointers as I'm not sure I'm going to be able to get in here many times before the offer expires.

Al

Attachments
Screen Shot 2018-08-07 at 15.27.57.png
No compatible items found in your PreSonus account.
stmarysbroadwateravteam wroteI'm getting a message saying "No compatible items found in your PreSonus account.", I've upgraded both our SL32 and SL24R and it's currently before the 11th...

Any pointers as I'm not sure I'm going to be able to get in here many times before the offer expires.

Al



Scrub that. I've found I needed to "purchase" the plugins first from here.

Al
User avatar
by matthewgorman on Tue Aug 07, 2018 11:28 am
nothing in the rules about going back to a previous version. The 1.9 update has many important fixes, but you know your system better than I do. As far as I have used it, it hasn't broken anything, only improved what I had.

Also to note, most times when something is fixed, we rarely see those posts made. People tend to post about problems, but go their separate ways once the fix has been made. Get the plugs. You aren't doing any lasting damage that can't be reversed.

Matt

Lenovo ThinkServer TS140 Win 10 64bit, 8GB RAM, Intel Xeon
Lenovo Thinkpad E520, Windows 7 64bit, 8 GB RAM, Intel i5 Processor
StarTech EC13942 34mm Expresscard
S1Pro V2 , Melodyne Studio 4, Nomad Factory Studio Bundle, Waves , RM16, Studio 192, DP88, Faderport, Central Station Plus, Yamaha HS50 Monitors, Sceptre 6-8 Monitors, Temblor 10.
User avatar
by wahlerstudios on Thu Aug 09, 2018 8:54 am
Just wanted to bump this up because the offer expires tomorrow.

RM32AI + RM16AI + CS18AI on sale now
32R

Apple routers | iPads | PreSonus SW5E & Motu AVB switches | Alesis iO Dock with AudioTools' Smaart RTA & spectograph extension |
Yamaha S112, S15e, S10e, SM12, SM10 | Galaxy Audio Hot Spots | Mac mini | Studio One Pro 3.5
User avatar
by Bbd on Thu Aug 09, 2018 11:03 am
I am really enjoying these plugs.
There are worth a lot more than free!
:)

Bbd

Please add your specs to your SIGNATURE.
OVERVIEW of how to get your issue fixed.
Search the ONLINE MANUAL, Create a SUPPORT TICKET and/or Post Issue.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.



OS: Win 10 x64 Home, Studio One Pro 4.1, Notion 6, Series III 24, Steinberg UR44, Haswell CPU: i7 4790k @ 4.4GHz, RAM: 16GB, Faderport 8/16, Cental Station Plus, Eris 3.5, ELAC Sub, Akai MPK261, Roland T6
User avatar
by wahlerstudios on Thu Aug 09, 2018 2:37 pm
"Offer ends Friday, August 10, 2018 @ 11:59 PM CST"

;-)

RM32AI + RM16AI + CS18AI on sale now
32R

Apple routers | iPads | PreSonus SW5E & Motu AVB switches | Alesis iO Dock with AudioTools' Smaart RTA & spectograph extension |
Yamaha S112, S15e, S10e, SM12, SM10 | Galaxy Audio Hot Spots | Mac mini | Studio One Pro 3.5
User avatar
by Steve Carter on Thu Aug 09, 2018 3:52 pm
Purchased these add-ons (zero charge) from the Presonus shop and downloaded from a seemingly coverall download Volume 1 but when I try to install in S1 v3.6.5 I just keep getting a message to say that Vol 1 is already installed.

However, none of these 'vintage' plugins appear in the Fat Channel drop down options and although I received a confirmation of order from Presonus there was no registration or verification code. I've read the instructions in the pdf relative to installing in S1 but nothing I've tried works.

Any advice as to how I might install these plugins in Studio One would be appreciated. I have raised a Support Ticket but just in case anyone out there can shed some light I'm trying here too.

Regards....

Windows 10 Pro/i7 6800k @3.4Ghz/16Gb ram. Studio One Pro, Melodyne Editor 4, Vocalign Project, Superior Drummer 3, Izotope N2-O8 and various other plugins. Focusrite Saffire Pro 40, Faderport, Focal Alpha 50's, Korg Pa3x, Korg Pad Kontrol, numerous guitars, basses & other antiquated outboard gear.
Maybe one day I'll actually finish a project!
User avatar
by themaartian on Thu Aug 09, 2018 4:46 pm
Steve Carter wrotePurchased these add-ons (zero charge) from the Presonus shop and downloaded from a seemingly coverall download Volume 1 but when I try to install in S1 v3.6.5 I just keep getting a message to say that Vol 1 is already installed.

However, none of these 'vintage' plugins appear in the Fat Channel drop down options and although I received a confirmation of order from Presonus there was no registration or verification code. I've read the instructions in the pdf relative to installing in S1 but nothing I've tried works.

Any advice as to how I might install these plugins in Studio One would be appreciated. I have raised a Support Ticket but just in case anyone out there can shed some light I'm trying here too.

Regards....

Installed, but not authorized. Open Studio One and authorize them. From the menu bar:

Studio One | Activate Purchased Items

Intel i7 3.4GHz, 16 GB RAM, 2 TB HD Win10 Home 64-bit Tascam US-16x08
Studio One 4 Pro NotionMelodyne 4 Studio SpectraLayers Pro 4 Guitar Pro 7
PreSonus FaderPort Nektar P6 M-Audio BX8 D2 Beyerdynamic DT 880 Pro
NI K9U XLN AK, AD2 AAS VS-2, GS-2, VA-2, EP-4, CP, OD Toontrack SD3, EZKeys
User avatar
by Steve Carter on Fri Aug 10, 2018 7:27 pm
Thanks... Regretfully it wasn't the case that they weren't authorised. I heard back from Support and I needed to delete the S1 Settings file (after saving a copy) and then let S1 rebuild it on reopening.

I was then able to download and install the Fat Channel add-ons. Unfortunately a lot of other plugins and soundsets disappeared and contrary to Support's advice, double clicking in the saved Settings file did not automatically put things to right again and I'm currently spending many hours downloading and installing the missing soundsets from Presence and redirecting S1 to the various locations for plugins etc.

On the bright side, rebuilding the Settings file has fixed my Macro Toolbar, which was broken and my thumbnails have reappeared again in the effects and instruments browsers after mysteriously vanishing during a session a few months back! On the downside the folders I have built and populated in the plugins browser have reverted to S1's default so I'm having to fix that as well.... Happy days

Regards...

Windows 10 Pro/i7 6800k @3.4Ghz/16Gb ram. Studio One Pro, Melodyne Editor 4, Vocalign Project, Superior Drummer 3, Izotope N2-O8 and various other plugins. Focusrite Saffire Pro 40, Faderport, Focal Alpha 50's, Korg Pa3x, Korg Pad Kontrol, numerous guitars, basses & other antiquated outboard gear.
Maybe one day I'll actually finish a project!
User avatar
by themaartian on Sat Aug 11, 2018 9:03 am
Glad you got it sorted. Sorry it wasn't simple.

Intel i7 3.4GHz, 16 GB RAM, 2 TB HD Win10 Home 64-bit Tascam US-16x08
Studio One 4 Pro NotionMelodyne 4 Studio SpectraLayers Pro 4 Guitar Pro 7
PreSonus FaderPort Nektar P6 M-Audio BX8 D2 Beyerdynamic DT 880 Pro
NI K9U XLN AK, AD2 AAS VS-2, GS-2, VA-2, EP-4, CP, OD Toontrack SD3, EZKeys

20 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 4 guests