4 posts
Page 1 of 1
Hey all,

Just wondering if anyone out there has discovered a resolution to the issue of meter & RTA lag within UC Surface. I have a brand new 32R connected via cat 5 to an ASUS router. A fairly powerful laptop also connected to the router via cat 5 which is running the latest version of UC Surface. I also have a Samsung Galaxy Tab A running UC Surface connected to the router. Both instances of UC surface, (laptop and tablet) exhibit significant lag (.5 to 1 full second) while monitoring audio. I have tried rolling back to older versions of firmware and UC Surface. I initially set up the mixer with the most recent version of firmware. No matter what I try, same lag. I submitted a ticket with PreSonus but sometimes the forums can be more helpful. Thanks in advance for any ideas!
User avatar
by wahlerstudios on Thu Jul 19, 2018 6:51 am
The display lag is also reported in the StudioLive Series III Public Beta Forum, but it is not officially acknowledged by PreSonus. The problem itself is old and the AI series of mixers suffer a lot under it, when UC Surface 2.x and FireWire is used. UC Surface 1.8 never had this problem, but Series III needs UC 2.x....

In another case it was recommended to make a factory reset (or several resets) and to install the latest firmware (no other versions in between), which might also be the current beta firmware. A fresh install can "clean" the problems of the different firmware versions, which might have conflicts with each other. But this doesn't necessarily solve the UC 2.x problem. You have nothing to loose. Try the factory reset(s), install the latest firmware and see what comes out of it.

Series III Firmware - v1.9.14575
Universal Control - v2.8.0.48221 (Current Public Release)

SL16 | 32R | 16R | 3* 16M | SW5E

Apple routers | iPads | Alesis iO Docks | Yamaha S112, S15e, S10e, SM12, SM10 | LD Systems Curv 500 | Galaxy Audio Hot Spots | Mac mini | Lenovo Laptop | Studio One Artist 5.0.0 & Pro 3.5.6
User avatar
by djangob on Sat Jul 18, 2020 3:58 pm
and continues to be an issue to this day... :(


StudioLive 32R; StudioLive 16R; Faderport 8; SW5E; Earmix16m; AR12; MacBook Pro 16” retina; MacMini (2020) MacMini (late 2014); OS X 10.15 ; AudioBox iTwo. Studio One 5 Professional ; Capture 3
User avatar
by Jessa on Sat Jul 18, 2020 10:35 pm
Yup..???? What say you Presonus??

4 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 5 guests