7 posts
Page 1 of 1
Hello fellow S1 users,

I am still trying to set up my S1, all the technical stuff. I had just solved one problem, and....well, they come in pairs, and then some, as they do.

So the next hiccup on my way to being a fluent S1 user pertains to the use of Addictive Drums in S1. I have searched the topics here, and I see many others use AD in S1, but I haven't found any threads discussing the problem I have. There were loads of pages, though, and I do not have the time to peruse them all, so if anyone is cognizant of a thread on this topic that already exists, please link it to me.

The problem I am having is getting S1 to recognise AD. I have followed instructions on how to integrate AD to S1--I clicked on ''Options'', then ''VST Plug-Ins'', then I tried both finding the location folder of AD, as well as dragging the location directly to S1. I have it installed in the XLN Audio folder, so that's all correct. I dragged it to S1, even restarted and updated plug-ins. I did everything, and still AD does not appear under ''INSTRUMENTS''. I did everything the online instructions say, I know where it is supposed to be located and how it is supposed to work, but it isn't here, and so it doesn't work.

Does anyone have any idea what the problem could be? I do not just dash to the forums for help whenever I encounter trouble; I really do spend days researching, and this is the last resort. When tutorials do nothing, the only way to go is to seek some direct advice, so I would appreciate any advice or insight anyone who uses AD might have for me. The way I know S1 the problem will solve itself before the first person even replies, but just to cover all my bases, I shall post this. Thanks in advance for any responses!
User avatar
by phillipdixon on Tue Jun 12, 2018 8:30 am
Not sure if this is relevent but when windows recently updated itself i lost add drums... had to reauthorize...this did the trick
User avatar
by garybowling on Tue Jun 12, 2018 9:12 am
sarabalazic wrote
I have it installed in the XLN Audio folder, so that's all correct.

Sounds like you're pointing to the "exe" file, which is NOT the vst plugin. You need to find the "Addictive Drums 2.dll" file and put that directory in the vst scan list. That might be in the vstplugin folder or if you're coming from another DAW, it might be in that DAWs vst folder.


Sager laptop, 32G, 1TB SSD, Win10-64, RME UFX, Studio One Pro 3, Addictive Drums, Izotope O8N2, Melodyne Studio, all versions updated frequently

The Moderns,
User avatar
by darrenporter1 on Tue Jun 12, 2018 11:08 am
If you are using AD2 because you migrated from SONAR, then put "C:\Program Files\Cakewalk\VstPlugins" in your S1 Vst Plug-ins locations list. This is what I had to do. You will also then pick up some (but not all) of the other plugins that were bundled with SONAR.

Studio One Professional 4
i5-8400 w/ six cores, 16GB RAM, Win10 Pro, 512 GB SSD, 2TB HD
TASCAM US16x08, FaderPort 8
Peavey VMP-2, Suhr Reactive Load, lots of self-built guitar amps
User avatar
by sarabalazic on Tue Jun 12, 2018 3:42 pm
The responses are quick here :D

Thanks to all who responded. My Windows updates itself abnormally fast, I feel, every few days (Windows 10 64-bit), but the application still works.....although I paid a lot for Fairfax vol. 1 and 2, and have 5 selections for each which boggles my mind--either they overprice insanely or I have no idea how to download the full version (but I registered the key, downloaded the installer, and have what I assume are the full versions)

You might be right, perhaps it is best I reinstall it if I can find the register key (I changed computers, changed mail.....chaos) because some pathway somewhere might be corrupted somewhere (as much as I appreciate everyone's help here, if anyone starts to get technical with abbreviations I truly will have no idea what you are talking about as I am notoriously resistant to learn anything computer/tech related)..so I will probably try that.

As far as for where I come from, I am a novice DAW-user, so S1 is my first. I have never heard of a DAW before last year nor does anyone where I am located have any idea what a DAW is. The music industry and scene where I am located is non-existent outside of select coteries that do not share the know-how. So I depend on this forum for help where people are what appears to be mind-bogglingy advanced when it comes to the tech stuff. I used to think the only way to create music was to book a studio session, but since 2 hours studio time here for a rough cut with no polish or production costs the equivalent of a 1000 quid and up (and there are 3 studios in the whole country so the greed is allowed to flourish) I had to find other options. That's how I learned about DAWs, and apart from the free stuff like Audacity (or it was free when I used it, anyway) which I have no idea how anyone can seriously use to create even a cheap demo, S1 is the first DAW I have ever been personally involved in. But I am flying off at a tangent now.

I shall probably try reinstalling and see what happens. And if it still doesn't work.....well....as a poetically robotic Austrian fellow once offered: ''I'll be back'' 8-)
User avatar
by Bbd on Wed Jun 13, 2018 3:34 am
Your XLN Installer has to be installed and running the latest version so it can manager your license keys and install issues.

At this moment, XLN is updating their platforms so once that is done, you should be able to download this program from your XLN account.
Once all your XLN licenses are in order, you must make sure you are pointing Studio One to the correct VST path for Addictive Drums 2.dll.


1) For HELP Read the Manual.
2) Create a SUPPORT TICKET. "Select Submit a Request".
3) For Comunity Help add your specs to your SIGNATURE AND
Include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce
Detailed how to HERE.

OS: Win 10 x64 Home, Studio One Pro 4, Notion 6, Series III 24, Steinberg UR44, Haswell CPU: i7 4790k @ 4.4GHz, RAM: 16GB, Faderport 8/16, Cental Station Plus, Eris 3.5, ELAC Sub, Equator D5 monitors, Akai MPK261, Roland T6
User avatar
by JohnBW on Thu Jun 14, 2018 8:22 am
1. Launch XLN Online Installer.

2. Click the "Advanced button" on the top. You will see the path selections here. The one that says Addictive Drums 2 is the application path. Ignore that for now. Look for the VST32 and VST64 paths below that and make note of current path locations, or change the paths to something you prefer.

3. Add the path that you found in step #2 to your Studio One "Options > Locations > VST Plug-ins". Check "Scan at startup".

4. Restart Studio One. You should see the XLN AD 2 instrument now.

DAWs: Studio One v3.5.5; Sonar Platinum; Tracktion Waveform; Ableton Live Other: Notion 6; Overture; Band in a Box; AIR Ignite Plugins: AIR Collection; Akai VIP; Cakewalk; iZotope Iris 2; SampleTank 3; SONiVOX Collection; SynthMaster bundle; Syntronik; Tracktion; Waves OS: Win10 Pro x64 1703 System: Homebuilt Asus; i3 3.4Ghz; 8GB DDR3; Intel HD Graphics; Dual Monitors; Samsung EVO 850 SSD, 250GB; WD 1.0TB 7200rpm; PCIe FireWire Audio: M-Audio FW-410 Controllers: A-300PRO; Alesis VX49; CME Xkey Hardware: Roland JV880; JV1080; XP-30; Alesis QS-6; Casio CZ-1000

7 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 17 guests