3 posts
Page 1 of 1
So, after the billionth time of trying to get this thing to work with windows 10, even buying a new firewire card, installing every driver from 1.72 up to 1.76, doing all the rebooting and %appdata% deleting "Presonus" in the Roaming folder nonsense, I decided to try 1.76 AGAIN, but this time, installing it to a different folder than C:\Program Files\Presonus\Universal Control.

I decided to install to E:\Main\Presonus\

What I got was an empty folder, devoid of a "Universal Controller" folder, and completely empty of files.
This installer refuses to install the files and drivers necessary for FSP.

I have my AV turned off to install, still nothing.
Instead I get "Driver Version 0.0.0.0 in the Controller, and a steady Red Light on my FSP.
I've done all the walkthroughs.

When I tried to install 1.74 to E:\Main\Presonus\Universal controller folder, all it did was extract everything into that folder, even the *.sys and *.dll files.
Your installers are broken and useless and only work part of the time.


NOTHING WORKS.
FIX THE INSTALLERS, THEY'RE NOT RELIABLE.
User avatar
by williambearden on Fri May 11, 2018 9:49 pm
Having the same issue. Cannot get the software to run.

Really enjoyed Notion 3, so the upgrade was a good deal, but if I can't get it to run, I need a refund.
User avatar
by Occam's Razor on Sat May 12, 2018 11:40 am
Exactly.
The installer 'sort of kind of runs", but the progress bar never goes all the way across, before the installer claims the drivers are installed.
Once the installer is done, there's no sign of the PAEFirestudio*.sys files in the windows folder, or ANYWHERE for that matter.
There's no sign of the DLLs either.

All the installer seems to do is install the little UC interface and that's it, IT COMPLETELY SKIPS INSTALLING THE DRIVERS.

I have my AV program shut off when installing, but the Presonus installer just craps out.

Any help here?

3 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests