4 posts
Page 1 of 1
A short while ago, my firepod stopped working on my computer. I had to unplug everything to move it and when I put it back together, the firepod would not sync to the computer.

I have had someone try it on their computer and it worked for them.
I have tried 2 different firewire chords, 2 different firepods (same results), and 5 firewire ports. I just bought a new one and still no change.

I've re-downloaded the drivers with no luck.
And now I am at a loss on what to do.

I just get a red light. But, if I turn on the firepod and then plug in the firewire chord, it will flash blue and red and stay on blue for some reason, but the computer will still not recognize it.

I've tried getting in touch with Presonus and they just tell me that its a discontinued product and they don't help with windows XP. Or they want me to trade it in for a discount on a newer product, which I dont want to do.

I am running windows XP Here are the specs

OS Name Microsoft Windows XP Professional
Version 5.1.2600 Service Pack 3 Build 2600
OS Manufacturer Microsoft Corporation
System Name NEWBIE
System Manufacturer System manufacturer
System Model System Product Name
System Type X86-based PC
Processor x86 Family 15 Model 35 Stepping 2 AuthenticAMD ~2009 Mhz
BIOS Version/Date American Megatrends Inc. 1103, 1/2/2006
SMBIOS Version 2.3
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = "5.1.2600.5512 (xpsp.080413-2111)"
User Name NEWBIE\Steve
Time Zone Eastern Standard Time
Total Physical Memory 2,048.00 MB
Available Physical Memory 1.63 GB
Total Virtual Memory 2.00 GB
Available Virtual Memory 1.96 GB
Page File Space 3.85 GB
Page File C:\pagefile.sys

Please help!
User avatar
by stevenboers on Thu Feb 18, 2016 2:41 pm
Still looking for help if anyone can...
User avatar
by cristofe on Fri Feb 19, 2016 11:33 am
You cannot expect Presonus to provide tech support for your ancient computer and long discontinued interface. It's time to upgrade!

I have had someone try it on their computer and it worked for them.

Well then....if your Firepod works on someone else's computer and not yours.....the problem is obviously your computer. Perhaps your OS has become corrupt. Have you tried re-formatting your HD and doing a clean install? Frankly, I would REALLY recommended you get a newer machine with better specs.....used Intel dual core Win7 machines are a dime a dozen on eBay.


PC'S: HP XW6000 Dual 3.2GHz Intel Xeon, 8GB RAM WinXP SP2 HP 6005 Pro AMD Athalon X2 B24 3.0Ghz, 4GB RAM Win8 Pro Dell Latitude E6410 Laptop Intel i5 2.67Ghz 8GB RAM Win7 Pro x64 Audio Interfaces: Terratec EWS88MT PCI (2), Audiobox 1818VSL USB & Firestudio 26x26 Firewire, Line 6 PodXT, Roland GS-10, NI Rig Kontrol 3

Monitors: Yamaha HS50M's DAW: S1 3.2.1 Pro

To add your software and hardware specs to your signature to make it easier for us to help you, click HERE.
User avatar
by stevenboers on Fri Feb 19, 2016 12:17 pm
I dont have the cash for a new machine.
I dont really know much about computers. How would I reformat?

4 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest