2 posts
Page 1 of 1
I am trying to connect instruments/ microphones in the front inputs of my firestudio 2626 then routing to my mix board via the general outputs in the rear of the unit to produce sound through my monitors and record to my computer (live recording) but after several attempts with the DAW in the universal control mixer, I have not been able to get sound through the monitors. What could I be doing wrong?
User avatar
by PreSonuSales2 on Tue Jun 16, 2015 2:55 pm
Just a couple of quick suggestions:

  1. Register your FireStudio 2626 to your account at http://my.presonus.com. Doing so will allow you to post in the FireStudio area of the forum (found at the following link: https://forums.presonus.com/viewforum.php?f=160) which may yield higher visibility and more responses. Here's a link on how to register hardware to your account: http://support.presonus.com/entries/67378690--2b-Studio-One-3-Register-New-Hardware-and-Download-Installer
  2. Create a ticket from your account at my.presonus.com. We no longer offer phone support for the FireStudio 2626, given that it is a discontinued product, but our tech support agents will be glad to help you if you create a support ticket. Once logged into your account at my.presonus.com, click on the "Support" icon in the grey toolbar near the top of the page. Once on that page, click the yellow "Create A Ticket" button.
  3. Consult the manual to ensure that you are connecting and routing everything correctly: http://www.presonus.com/downloads/products/pdf/FireStudioOwnersManual_EN.pdf

Inside Sales

*Please create a "signature" with your software and hardware specs to make it easier for us to help you... click HERE.

Home Setup: Studio 192 , Studio One Professional 3 (64 Bit), Eris E8s, Eris 4.5s, and Ceres 4.5s.
Office Setup: AudioBox 22VSL, Eris E5s, Studio One Professional 3 (64 Bit)

2 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests