24 postsPage 2 of 2
1, 2
Hello friends,

Do any of you know how to create a valid FireControl installer for Big Sur 11.2.3?
I believe that it is possible to modify the installer to do a clean installation.

Any help is welcome
User avatar
by magnosgasparini on Mon Mar 29, 2021 9:00 pm
As a matter of fact, the FireControl program is compatible with 64 bits (Intel). We would just need a way to install it from scratch correctly.
User avatar
by davecollins on Mon Apr 19, 2021 12:14 am
You, sir, are my hero! I recently re-imaged my 2012 15" MacBook Pro with a clean copy of Catalina. I wondered if I'd be able to get my Firestudio up and running again. I'm happy to say that I followed your instructions and it worked perfectly!

My System:
- Firestudio (2626)
- Monitor Station Remote (MSR)
- Firestudio Lightpipe
- 2012 15" MacBook Pro running macOS Catalina (10.15.7)

I Tested / Confirmed:
- iTunes / System Sounds work
- Pro Tools works great
- Both macOS and Pro Tools see all 58 ins & 58 outs
- FireControl sees all Firestudio 26 ins & 26 outs
- Everything is running rock-solid all the way down to 32 samples
- MSR functions 100% correctly (eg: mode switching, headphone outs, etc. all work great)

The only thing I'd like to sort out at some point is whether or not I can run FireControl and Universal Control together to have the software mixer for the Lightpipe (FireControl only sees & controls the 2626). I don't think running both at the same time is plausible but that's not the end of the world.

Thank you for posting your instructions, and thank you for keeping them updated!

User avatar
by Ozfire on Thu Jul 29, 2021 3:49 am
robmbrown wroteFor my Firestudio 26x26 in High Sierra and Mojave I did not find the above to work. Instead first uninstall everything, unit off using the Universal Control 176 driver https://www.presonus.com/products/FireS ... /downloads - it has a thorough uninstaller. Then reboot - unit off - hit cmd r after the boot tone to get into recovery mode, launch terminal and do the csrutil disable bit and reboot. Then install Universal Control 1.2.2715 Driver 3.5.5 which is under the snow leopard selection on the presonus site - https://www.presonus.com/products/firestudio/downloads - unit still off. Reboot and don't turn it on until reboot is done.

I tried to get my 2626 running in Sierra quite a while back but it ended in frustration, just couldn't get it to work. (2011 iMac 27"). Then I upgraded to High Sierra but didn't even bother try to get the 2626 running, I was resigned to the fact that as software was marching forward the 2626 was staying behind. In order to keep working I purchased a Presonus iTwo as a stop gap, and that's done the (bare minimum) job ok but not great (and no more MSR!)
Fast forward to this week and I found myself checking this forum (which I hadn't for a long time) and lo & behold people are claiming to be able to get their 2626's working in OS's post Lion.I followed the above method and BINGO! It friggin' works!!!!(High Sierra 10.13.6). I'm so happy to have my trusty 2626 back in service and more importantly the MSR under my right hand.
Thanks for all the smart cookies on here that worked this out, I'm very grateful, you're all LEGENDS!!

24 postsPage 2 of 2
1, 2

Who is online

Users browsing this forum: No registered users and 1 guest