Discuss Studio 2|4, 2|6, 6|8, 18|10, and 18|24 USB 2.0 Interfaces Here
10 posts
Page 1 of 1
Hello,

I figure I need to put this here as I am unable to lodge a support ticket on the Presonus support page (is anyone else aware of this issue)?

I have just bought a Studio 2|4 and registered it and have plugged it in to my new 2018 MacBook Pro and it isn't appearing in the Audio section of my Preferences. At first the red light was staying on but after plugging it in again it now flashes every second or so.

I am running High Sierra 10.13.6. Can anyone suggest anything? Every other external audio device I have used on Mac has just worked so Im a bit stumped here.

Thanks.
User avatar
by johnthompson22 on Sat Feb 02, 2019 9:51 pm
@danielhollins,

I'm in the same boat as you. I also have the 2018 MacBook Pro and I just received my studio interface in the mail today. I spent few hours trying to figure this thing out and eventually found a work around.

I plugged the usb-c to usb-a cable into the interface and then connected the usb-a end into a usb to usb-c adapter. I then plugged the adapter into the MacBook Pro and it worked perfectly. It appears in my preferences now and no more blinking red light.

I hope this helps. Hopefully Presonus can fix this going forward.
User avatar
by jpsbuk on Tue Feb 12, 2019 3:41 pm
How bizarre is that! I have exactly the same issue. Using a USB-C to USB-A and then USB-A to USB-C fixes the issue.

Early days I guess :)

Studio One 4.5.0 Professional
MacBook Pro (2018) 2.9GHz 7th Gen i7 Processor 512GB SSD, 16GB RAM, Radeon Pro 560 4GB with Presonus Studio 24C
Mac 27" i5 with Presonus FireStudio Mobile
Akai LPK25, NI Komplete Kontrol S49 Mk2, Komplete 11, Nektar Impact GX49, NI Maschine Jam, NI Maschine Mikro, Faderport 1, Artiphon Instrument 1

http://soundcloud.com/busterbuk
http://busterbuk.bandcamp.com
https://www.facebook.com/BusterBuk/
User avatar
by jpsbuk on Sat Feb 23, 2019 3:30 pm
Interestingly enough, the USB-C charger lead that comes with the MacBook charger works fine !!

See https://answers.presonus.com/38397/usb-c-cable-not-working

Studio One 4.5.0 Professional
MacBook Pro (2018) 2.9GHz 7th Gen i7 Processor 512GB SSD, 16GB RAM, Radeon Pro 560 4GB with Presonus Studio 24C
Mac 27" i5 with Presonus FireStudio Mobile
Akai LPK25, NI Komplete Kontrol S49 Mk2, Komplete 11, Nektar Impact GX49, NI Maschine Jam, NI Maschine Mikro, Faderport 1, Artiphon Instrument 1

http://soundcloud.com/busterbuk
http://busterbuk.bandcamp.com
https://www.facebook.com/BusterBuk/
User avatar
by jpsbuk on Sun Feb 24, 2019 10:52 am
I purchased a new USB-C to USB-C cable and all is now ok. It seems like Presonus may have shipped some units with bad cables!

Studio One 4.5.0 Professional
MacBook Pro (2018) 2.9GHz 7th Gen i7 Processor 512GB SSD, 16GB RAM, Radeon Pro 560 4GB with Presonus Studio 24C
Mac 27" i5 with Presonus FireStudio Mobile
Akai LPK25, NI Komplete Kontrol S49 Mk2, Komplete 11, Nektar Impact GX49, NI Maschine Jam, NI Maschine Mikro, Faderport 1, Artiphon Instrument 1

http://soundcloud.com/busterbuk
http://busterbuk.bandcamp.com
https://www.facebook.com/BusterBuk/
User avatar
by rinakumetsu on Tue May 28, 2019 11:33 am
The same thing =( Thanks guys with the advice to check the cable.
User avatar
by CSeye on Fri May 31, 2019 7:20 pm
I have a 2017 MBP here with nothing but USB-C and Thunderbolt 3 ports.

After a no-go with the Presonus USB-C to USB-C cable, I tried the suppled USB-C to USB-A and it worked. :+1

After reading here, I can confirm the USB-C cable that is part of the Apple MBP charger worked. So did an Amazon Basics cable.

The Studio 24c does exactly what I hoped for: It's small yet with enough heft - 2lbs - to remain stable on the table. It fits neatly into my guitar gig bag, and it plays nicely with LPX, C10, and S1 4.5.

It's very easy to use and sounds great! :thumbup:

I'll post back after testing the MIDI connections.

2017 MBP/2012 Mini, macOS 10.4.5, S1 4.5.1, Notion 6.5, Faderport 2018, Eris 5, USB-C Studio 24c, silverface Apollo Quad-TB, Integra 7, MIDI guitar controllers, Novation SL MKll for CC - no Automap!
User avatar
by richardgarifo on Tue Jul 02, 2019 4:43 am
You all are lifesavers! July and the units are still shipping with a bad C cable. Man, it is really disheartening to plug everything together and get... nothing. Thanks again!
User avatar
by danielwebster4 on Sat Jul 06, 2019 8:05 pm
Add me to the list of people who received a bad USB-c cable. :(
User avatar
by stianchristensen on Mon Sep 09, 2019 1:13 pm
I also received a bad USB-C cable with my PreSonus Studio 24c.

10 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests