3 posts
Page 1 of 1
Hi,

Finally got a FaderPort 2018 and some things are just not working as expected, or not even as stated in the manual. Wondering if it's bugs, documentation errors or user errors.

Running Studio One 4.1.2.50657, Win10 x64, latest firmware on FP (according to UC). I've selected the StudioOne mode of operation a few times so I hope that's correct :)

Primarily, it's "The Session Navigator" that's kind of wacky.

Link. Encoder controls any parameter beneath your mouse.
Navigation buttons select Next and Previous tracks respectively.

Navigation in this mode selects channels, not tracks. If channels = tracks, then Section and Scroll/Zoom are incorrectly documented. No biggie, but worth mentioning. Selecting channels seems to be the default operation for the navigation buttons. Correct?

Master. Encoder controls the Master level. Push the Encoder to reset the Master
level to 0 dB. While in this mode, the navigation buttons will control banking.

Navigation also selects channels. Maybe banking is only applicable FaderPort 8/16 and reverts to the default here? But the manual is clearly for the "regular" FaderPort.

Pan. Encoder controls panning. Navigation buttons scroll
through track list. Push the Encoder to reset the level to 0 dB.

Again, navigation selects channels, not tracks. Pushing the encoder resets pan to center, not level to 0 dB

Channel. Encoder controls individual channel scrolling. Navigation buttons
adjust the currently visible fader bank on the FaderPort by one channel.

Navigation selects channels. Maybe banking is only applicable FaderPort 8/16 and reverts to the default here?

Section. Encoder nudges the selected event. Use the navigation buttons
to navigate through the events on the Arranger track.

If focus is in the mix panel, the encoder expands/collapses the selected channel's inserts/sends section. Navigation buttons do nothing whatsoever, making the Section button next to useless. If focus is in the edit panel or the arranger panel, the encoder nudges the selected event. Navigation buttons do nothing whatsoever, making the Section button next to useless.

The only way to select the next/prev event is to unselect any mode (all buttons dark), click on a track/event and then use the navigation buttons. If focus is in mixer, the channels are selected. This means that if I want to nudge two or more events I have to continually select and unselect the Section mode between the actual nudging and event selection.

Scroll / Zoom. Encoder controls timeline scrolling. Push the encoder to
fit the timeline to the window size. Use the navigation buttons to scroll
through the track list ...

Yay! Finally navigation selects tracks! :D Everything works as described

Marker. Encoder moves the playback cursor in the Timeline. Use the navigation
buttons to scroll through markers. Press Encoder to drop a marker

Also works as documented.

So, most of these are not really that bothersome. The only really irritating one is the Section mode, as the navigation buttons do nada! But that so many of the modes operate differently than documented made me post this. What's going on? Is it just poor documentation? I am missing something?

Thanks!
User avatar
by kristoffercarnmarker on Wed Jan 30, 2019 1:42 pm
Well, no responses here, but I did get i touch with tech support so I figure I might as well update the thread with the response from tech support.

Apparently, nothing in my description "points to a hardware failure" or "failure of functionality".

Oh well ...

Queue the Twilight Zone theme...
User avatar
by MixxWizard on Mon Feb 25, 2019 7:23 pm
In this short video tutorial, I will show you have to reset, & get your Faderport 2018 buttons working again in Studio One 4. I hope this helps
https://www.youtube.com/watch?v=vmbh4XK ... e=youtu.be

3 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests