Discuss Studio 2|4, 2|6, 6|8, 18|10, and 18|24 USB 2.0 Interfaces Here
3 posts
Page 1 of 1

I figure I need to put this here as I am unable to lodge a support ticket on the Presonus support page (is anyone else aware of this issue)?

I have just bought a Studio 2|4 and registered it and have plugged it in to my new 2018 MacBook Pro and it isn't appearing in the Audio section of my Preferences. At first the red light was staying on but after plugging it in again it now flashes every second or so.

I am running High Sierra 10.13.6. Can anyone suggest anything? Every other external audio device I have used on Mac has just worked so Im a bit stumped here.

User avatar
by johnthompson22 on Sat Feb 02, 2019 9:51 pm

I'm in the same boat as you. I also have the 2018 MacBook Pro and I just received my studio interface in the mail today. I spent few hours trying to figure this thing out and eventually found a work around.

I plugged the usb-c to usb-a cable into the interface and then connected the usb-a end into a usb to usb-c adapter. I then plugged the adapter into the MacBook Pro and it worked perfectly. It appears in my preferences now and no more blinking red light.

I hope this helps. Hopefully Presonus can fix this going forward.
User avatar
by jpsbuk on Tue Feb 12, 2019 3:41 pm
How bizarre is that! I have exactly the same issue. Using a USB-C to USB-A and then USB-A to USB-C fixes the issue.

Early days I guess :)

Studio One 4.1.0 Professional
MacBook Pro (2018) 2.9GHz 7th Gen i7 Processor 512GB SSD, 16GB RAM, Radeon Pro 560 4GB
Mac 27" i5 with Presonus FireStudio Mobile
Edirol PCR500, Akai LPK25, Korg nanoKey 2, M-Audio BX5, NI Komplete Kontrol S49 Mk2, Komplete 11, Nektar Impact GX49, NI Maschine Jam


3 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests