FaderPort 8 and FaderPort 16 General Discussion
4 posts
Page 1 of 1

My Faderport 8 is not working with Studio One Pro 4 (I'm on Windows 8.1 Pro) . It is currently using firmware ver. 1.10

Q. Is the FP8 firmware version 1.10 Not Compatible with Studio One Pro 4 ?

When I launch Universal Control app. It detects the Faderport 8, and informs me that there is a firmware update for FP8. which is ver. 2.02 (Current version on the FP8 is ver 1.10).

The Universal Control app. is version , which is the latest version.

When I start the Firmware update process from Universal Control, the Faderport LEDs do not update the number of packets being transmitted from the PC. when the update is completed, I get DFU Failed message on all LEDs of the FP8.

The Universal Control App. Shows me again that there is a Firmware Update available. So, I can't get the firmware update to work.

I wonder what's going on, and how to fix this issue, hopefully I can get the Faderport 8 to work with Studio One Pro 4.

Also, is there any specific setting I need to set in Studio One Pro 4 to get the Faderport 8 to work ? or does it automatically detect the FP8 ?

I would appreciate some help to get fix this issue.

Update 1 : I tried connecting the FP8 USB cable directly to the computer's USB Port, instead of the USB Hub it was connected to, and now , Universal Control Detects the FP8, but when I click on the firmware update button, it shows a message that it can't find the midi port of the device. I find this very strange.

Update 2 : I installed the Universal Control on my personal Laptop, (don't use it for music), to see if I can update the FP8's Firmware to version 2.02, and Yes, it started updating properly, I saw the Packet Counts advancing on the FP8's LEDs, and it completed the firmware update successfully. I then rebooted the FP8, and now it shows 'Studio One waiting for Host', so I launched Studio One Pro 4, but the FP8 does not react, so it is still waiting for the Host, I then went to the options menu of S1, to access External Devices, and see the FP8's Port not found, when I try to assign the send & receive ports of the FP8, there is no FaderPort 8 Port available in the ports that show up. Why is the FP8 Port missing from the list ? and how can I fix this ?

Update 3 : OK, so I decided to connect the FP8 back to the USB Hub's port it was connected to, and test again, if the FP8 shows up in the midi port list of external controllers, and to my surprise, it does, so I set the receive from ,and Send to ports to FP8, and Bingo ! It finally is working with Studio One Pro 4. :D

Now I am curious why the USB port on my PC did not show the FP8, but the USB Hub connected to the PC showed the port. Again.. a bit strange. and why the Universal Control App. was not able to update the firmware via my main PC, but worked via my personal laptop, Well... at least I got the FP8 to work with S1Pro 4. I will post another update if I get to find out what caused the issues on my music PC.

User avatar
by cory baker on Sat Dec 08, 2018 10:55 am
Funny, this is listed as solved but I did not find the answer here.

Faderport 8
Studio ONe 4 Pro
Mac mini six core running mojave

Faderport is listed in midi but not connected.
I tried everything i could think of.
Then it hit me... just delete the old instance of faderport in your external devices menu.
For noobs... Hit ctl and then comma, mac users command comma, to bring up the preferences menu.
I deleted it and reset a new instance and it came up right away.
Hope this helps someone
User avatar
by philipgray1 on Fri Jun 28, 2019 5:10 pm
I had all sorts of trouble getting my FP8 working correctly with Studio One 4. Faders, scribble names and channel colours would not mimic Studio One. I re-installed firmware and Universal Control many times. Very perplexing and frustrating.

Then I read somewhere I should re-boot my PC. Did that and everything has worked perfectly ever since :)
User avatar
by geraldbowie on Thu Oct 22, 2020 10:35 pm
My FP8 just stopped working all together. Power comes on and you can play and stop track that’s it. I’ve only had the thing for 5 months. Does anyone know how to fix it? I’ve been through all the basic troubleshooting task and still nothing. What’s going on?

4 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests