42 postsPage 2 of 3
1, 2, 3
Thanks for updating your signature with your system specs. It helps us get to a resolution sooner.

For Studio One 3 users, here's the Windows 10 directory path for the files that need to be replaced:
Image

Just remove the files in the nanoKONTROL 2 directory and replace with the files contained in the zip file in my previous (see link below) post:
viewtopic.php?p=153216#p153216


Hope this helps.

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 10 Pro 64-bit (v1903: Build 18362.295), Studio One 4.5.3 Pro | Notion 6.5 | Universal Control v3.1.0.53214
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
StudioLive Series III 32 v2.1.16232
User avatar
by georgegidzinski on Mon Sep 10, 2018 12:54 pm
Perfect. When I plug in the NK2 for the first time using the button presses for Mackie Mode is that with or without S1/3 open?

Thanks,

George

Studio One Pro 3.5.6 32 and 64 bit, Windows 10 Pro, Desktop - Gigabyte GA-H55_USB3/i3 3.2Ghz/GeForce GT430 1G/4G ram/onboard sound Realtek ALC889/1TB WD Blue drive, Lenovo x230 and E530 laptops, Audio iTwo interface, Easy Drummer 2, Nektar GX49, Korg NanoKontrol2, Frankenstein E drum kit based on Roland/Yamaha/acoustic conversion, Strats/Tele/LP, home built tube amps, SM57/58, AT2035 and just enough confidence to be dangerous
User avatar
by Trucky on Mon Sep 10, 2018 1:23 pm
Either way should work. By design, the nanoKONTROL2 has multiple modes that can be selected based on what buttons are pressed when you plug it in to a computer. It remembers the mode you choose even after it’s unplugged.

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 10 Pro 64-bit (v1903: Build 18362.295), Studio One 4.5.3 Pro | Notion 6.5 | Universal Control v3.1.0.53214
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
StudioLive Series III 32 v2.1.16232
User avatar
by georgegidzinski on Mon Sep 10, 2018 7:11 pm
Thank you for all your help. BTW, S1/3 would not recognize the NK2 unless I plugged it in and then started S1/3.

George

Studio One Pro 3.5.6 32 and 64 bit, Windows 10 Pro, Desktop - Gigabyte GA-H55_USB3/i3 3.2Ghz/GeForce GT430 1G/4G ram/onboard sound Realtek ALC889/1TB WD Blue drive, Lenovo x230 and E530 laptops, Audio iTwo interface, Easy Drummer 2, Nektar GX49, Korg NanoKontrol2, Frankenstein E drum kit based on Roland/Yamaha/acoustic conversion, Strats/Tele/LP, home built tube amps, SM57/58, AT2035 and just enough confidence to be dangerous
User avatar
by Trucky on Mon Sep 10, 2018 7:32 pm
So is everything working for you now?

Yes, you’ll want to have it plugged in before you start Studio One because it checks for external devices, plugins, etc. during startup. My previous response regarding whether Studio One needed to be open or not was related to setting “Mackie Control” mode for the first time.

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 10 Pro 64-bit (v1903: Build 18362.295), Studio One 4.5.3 Pro | Notion 6.5 | Universal Control v3.1.0.53214
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
StudioLive Series III 32 v2.1.16232
User avatar
by georgegidzinski on Mon Sep 10, 2018 9:27 pm
Everything is good for now, on to the keyboard controller.

Thanks again,

George

Studio One Pro 3.5.6 32 and 64 bit, Windows 10 Pro, Desktop - Gigabyte GA-H55_USB3/i3 3.2Ghz/GeForce GT430 1G/4G ram/onboard sound Realtek ALC889/1TB WD Blue drive, Lenovo x230 and E530 laptops, Audio iTwo interface, Easy Drummer 2, Nektar GX49, Korg NanoKontrol2, Frankenstein E drum kit based on Roland/Yamaha/acoustic conversion, Strats/Tele/LP, home built tube amps, SM57/58, AT2035 and just enough confidence to be dangerous
User avatar
by Trucky on Mon Sep 10, 2018 11:14 pm
Super. It's nice when it all works!

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 10 Pro 64-bit (v1903: Build 18362.295), Studio One 4.5.3 Pro | Notion 6.5 | Universal Control v3.1.0.53214
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
StudioLive Series III 32 v2.1.16232
User avatar
by colin carroll on Sun Jan 20, 2019 11:32 am
I have a love hate relationship with the Nano Kontrol, love it when it works and hate it when it does not.
I have used Trucky's solution to solve the problem of not sending CC data in the past.
The NK2 will not tansmit the CC data for the scene I have loaded in the Korg editor. Therefore I have no volume sustain expression etc.
After last night's Windows 10 update the NK2 did not connect when I opened Studio One 4, reconnected and still no joy The only thing that does work are the rotary pan controls (which I believe is the opposite of what use to happen.)

It works perfectly in the Mackie mode however Ido not need that function.

I have installed the xml files that you higlighted in your 9/2/2018 post and no change.
Everything stopped after the latest Win10 update.
Any ideas on what I can do?
Cheers.
Colin.

I am using the following:

Windows 10
Studio One 4 professional (latest build)
Intel i7 4.20Ghz
Ram 32Gb
ATOM surface control
NanoKontrol2

Windows 10
Studio One 4 professional (latest build)
Intel i7 4.20Ghz
Ram 32Gb
ATOM surface control
NanoKontrol2
User avatar
by Trucky on Sun Jan 20, 2019 11:38 am
Everything is still working for me (Mackie Control Mode) with the nanoKONTROL2.
I'm running Windows 10 Version 1809 (OS Build 17763.253)

I'm not sure what mode you're running in or modifications you've made to what I provided previously but you may need to check that.

What version/build of Windows 10 are you running?

Attachments
KORG nanoKONTROL2 Setup for Studio One 3.pdf
(1.18 MiB) Downloaded 55 times

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 10 Pro 64-bit (v1903: Build 18362.295), Studio One 4.5.3 Pro | Notion 6.5 | Universal Control v3.1.0.53214
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
StudioLive Series III 32 v2.1.16232
User avatar
by colin carroll on Sun Jan 20, 2019 12:28 pm
Mackie Control is not a problem for me either I need it to transmit CC data (which it was doing last night before the the latest features update. I am running Win10 Home Edition Version 1809.
I am running in CC mode and I have not done any modifications to your xml. Your xml was working perfectly inCC mode before last night's update.

Cheers.

Colin.

Windows 10
Studio One 4 professional (latest build)
Intel i7 4.20Ghz
Ram 32Gb
ATOM surface control
NanoKontrol2
User avatar
by Trucky on Sun Jan 20, 2019 12:54 pm
What build of Windows 10 1809?

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 10 Pro 64-bit (v1903: Build 18362.295), Studio One 4.5.3 Pro | Notion 6.5 | Universal Control v3.1.0.53214
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
StudioLive Series III 32 v2.1.16232
User avatar
by colin carroll on Sun Jan 20, 2019 1:27 pm
17763.253

Windows 10
Studio One 4 professional (latest build)
Intel i7 4.20Ghz
Ram 32Gb
ATOM surface control
NanoKontrol2
User avatar
by Trucky on Sun Jan 20, 2019 1:48 pm
I just enabled CC mode (SET CYCLE while plugging in USB cable] and confirmed with MIDI-OX that CC data is working correctly.

Do you have any firewall(s) enabled? If so, try disabling it temporarily to see if it's blocking CC data for the nanoKONTROL2.

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 10 Pro 64-bit (v1903: Build 18362.295), Studio One 4.5.3 Pro | Notion 6.5 | Universal Control v3.1.0.53214
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
StudioLive Series III 32 v2.1.16232
User avatar
by colin carroll on Sun Jan 20, 2019 2:23 pm
Tried that, nothing apart from transmitting panning on the rotary pots.

Windows 10
Studio One 4 professional (latest build)
Intel i7 4.20Ghz
Ram 32Gb
ATOM surface control
NanoKontrol2
User avatar
by colin carroll on Sun Jan 20, 2019 3:03 pm
Korg (3).png


This a screenshot of my Korg Editor.
The CC data for the sliders is being shown in the Midi Monitor and is showing the correct CC data ie CC 1 CC11 etc. But they are not controlling anything in my VIs the only thing that is happening is panning in the audio faders in the mixing desk.

Windows 10
Studio One 4 professional (latest build)
Intel i7 4.20Ghz
Ram 32Gb
ATOM surface control
NanoKontrol2
User avatar
by colin carroll on Sun Jan 20, 2019 4:39 pm
Screenshot (2).png


A picture of the Midi Monitor showing the CC data from the NK2 but it wont transmit to my VSTs such as Kontakt.

I have spent 10 hours on this.

Windows 10
Studio One 4 professional (latest build)
Intel i7 4.20Ghz
Ram 32Gb
ATOM surface control
NanoKontrol2
User avatar
by Trucky on Sun Jan 20, 2019 5:58 pm
colin carroll wroteAfter last night's Windows 10 update the NK2 did not connect when I opened Studio One 4

Try rolling back the Windows update that caused this and let me know the results

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 10 Pro 64-bit (v1903: Build 18362.295), Studio One 4.5.3 Pro | Notion 6.5 | Universal Control v3.1.0.53214
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
StudioLive Series III 32 v2.1.16232
User avatar
by colin carroll on Sun Jan 20, 2019 7:27 pm
I did a roll back no joy. I am beginning to think could it be the latest S1 V4.1.2 update of Jan 15th?

Windows 10
Studio One 4 professional (latest build)
Intel i7 4.20Ghz
Ram 32Gb
ATOM surface control
NanoKontrol2
User avatar
by Trucky on Sun Jan 20, 2019 7:52 pm
colin carroll wroteI did a roll back no joy. I am beginning to think could it be the latest S1 V4.1.2 update of Jan 15th?


Yes, please note that Studio One updates often will replace the device files and you may need to reinstall them.

Do you remember how you installed the nanoKONTROL2 files? The one I posted is designed to use the nanoKONTROL2 as a control surface (Faders 1-8 with Bank support, Pans, Solo, Mute, Record, Set Markers, Transport, Loop On/Off) for Studio One 3 or 4.

I'm wondering if you were using a modified version of the one I posted that usingdanielejchan uploaded? His updates included the following:

- The eight channel is connected to the master out.
- Knobs are not binded to the pan by default.
- Slightly renamed Marker Left/Right and Track Left/Right channels.

Check out his post here:
viewtopic.php?p=175026#p175026

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 10 Pro 64-bit (v1903: Build 18362.295), Studio One 4.5.3 Pro | Notion 6.5 | Universal Control v3.1.0.53214
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
StudioLive Series III 32 v2.1.16232
User avatar
by colin carroll on Mon Jan 21, 2019 5:11 am
I cant remember to be honest.
I have raised a ticket with presonus and I will wait for their reply.
Thank you for your sterling help.

Cheers.

Colin.

Windows 10
Studio One 4 professional (latest build)
Intel i7 4.20Ghz
Ram 32Gb
ATOM surface control
NanoKontrol2

42 postsPage 2 of 3
1, 2, 3

Who is online

Users browsing this forum: jBranam and 9 guests