This forum is for Tips and Tricks. Please do not post any questions in this forum. It is only for information.
20 posts
Page 1 of 1
I hope this helps.

For Windows 7-64

It took a while, but it's working great.

First: Hook up the keyboard via USB directly to your computer-- the standard MIDI ports are not needed.

Important!
Download and install the newest firmware for the keyboard.
Shut down the keyboard.
Download and install the latest driver for the Komplete Kontrol software.
Do not skip this one!

Restart the computer and power up the keyboard.

Launch the Komplete Kontrol app.
Click Edit; Audio and MIDI Settings. Click the MIDI tab.
Enable "Komplete Kontrol -1" and "Komplete Kontrol DAW -1" on BOTH, the Inputs and Outputs Tabs.
When you are finished, the window should look like this:

Komplete Kontrol Setup.png


Next launch S1-3.

On the Start Page, click Configure External Devices.
For the transport controls, proceed according to this video : https://www.youtube.com/watch?v=sDD1aik9mIw
The transport controls work through Mackie Control.
The To and From MIDI should be Komplete Kontrol DAW-1

When you are done, the screen should look like this:

S61 Transport setup.png


Next, click Add in the External Devices Window.
Click New Keyboard at the top.
Name it.
Select ALL for MIDI channels.
Select "Komplete Kontrol -1" for To and From.
Check the Default Box if desired.
When you're finished, the window should look like this:

S61 MIDI Setup.png


Shut everything down and restart.

In S1-3, the Komplete Kontrol app should be listed in your Instruments Folder. Just drag and drop for tons of fun. :D

S1-3 Pro -- FireStudio Project -- FaderPort -- HP60 -- Sceptre S6 -- Temblor T10
Creation Station 400 v3 -- Intel Core i7-4770 @ 3.4 GHz -- 16GB DDR3 -- Velociraptor 600 D Drive
Siig w/TI Chipset
Windows 7 Home Premium SP1 - 64 Bit
NI Komplete Kontrol 61
NI Komplete 10 Ultimate
Antares AVOX EVO (64)
ReVoice Pro 3
Lots of 3rd party VST's
Korg M3 - 73
http://www.hookstownbrown.com
User avatar
by brent mosher on Wed Dec 09, 2015 5:26 pm
Thanks for posting this. I've had the S61 for over a year and could never figure out how to get the transport to work. Now it does.
User avatar
by kevvvvv on Tue Dec 29, 2015 2:12 pm
another big thank you

kev

Studio One, Avenger, Komplete, Spire, Dune, Omnisphere, BFD, Win 10
User avatar
by anthonypearshouse on Fri Mar 18, 2016 2:37 am
Thanks a lot.
Tony
User avatar
by RobertBeach00 on Wed Aug 17, 2016 1:24 pm
Thanks very much! This was a great article.

My only issue: Komplete Kontrol doesn't show up as an instrument. How do I add it?
User avatar
by HookstownBrown on Wed Aug 17, 2016 2:33 pm
Offhand guess:
Make sure Komplete Kontrol is in the proper location and then rescan in S1-3.

S1-3 Pro -- FireStudio Project -- FaderPort -- HP60 -- Sceptre S6 -- Temblor T10
Creation Station 400 v3 -- Intel Core i7-4770 @ 3.4 GHz -- 16GB DDR3 -- Velociraptor 600 D Drive
Siig w/TI Chipset
Windows 7 Home Premium SP1 - 64 Bit
NI Komplete Kontrol 61
NI Komplete 10 Ultimate
Antares AVOX EVO (64)
ReVoice Pro 3
Lots of 3rd party VST's
Korg M3 - 73
http://www.hookstownbrown.com
User avatar
by andystecklein on Tue Aug 23, 2016 6:32 am
By chance did anybody here have issues with S1 version 3.2 hanging when trying to use Komplete Kontrol version 1.5 or higher? I had no issues until just recently. When attempting to open a song file that has a KK instrument track on it S1 hangs and I must kill it from task manager. If I open a fresh song file and try to add a KK instrument track to it the same thing happens. Worked great before.

Andy
User avatar
by HookstownBrown on Tue Aug 23, 2016 9:29 am
That's a new one. Haven't heard of it before.

S1-3 Pro -- FireStudio Project -- FaderPort -- HP60 -- Sceptre S6 -- Temblor T10
Creation Station 400 v3 -- Intel Core i7-4770 @ 3.4 GHz -- 16GB DDR3 -- Velociraptor 600 D Drive
Siig w/TI Chipset
Windows 7 Home Premium SP1 - 64 Bit
NI Komplete Kontrol 61
NI Komplete 10 Ultimate
Antares AVOX EVO (64)
ReVoice Pro 3
Lots of 3rd party VST's
Korg M3 - 73
http://www.hookstownbrown.com
User avatar
by brent mosher on Tue Aug 23, 2016 11:06 am
andystecklein wroteBy chance did anybody here have issues with S1 version 3.2 hanging when trying to use Komplete Kontrol version 1.5 or higher? I had no issues until just recently. When attempting to open a song file that has a KK instrument track on it S1 hangs and I must kill it from task manager. If I open a fresh song file and try to add a KK instrument track to it the same thing happens. Worked great before.



Yes, I've had the same issue.
User avatar
by andystecklein on Thu Aug 25, 2016 7:14 am
I discovered that my issue has something to do with Presonus Notion. After installing it, that's when the problem started. After uninstalling Notion the problem goes away. Reinstall Notion and the problem comes back. Hopefully somebody can help get this resolved.

Andy
User avatar
by andystecklein on Mon Sep 12, 2016 10:05 pm
Well if you upgrade to Notion 6 the issue goes away. At least it did for me!

Andy
User avatar
by gkillmaster on Thu Oct 20, 2016 7:28 pm
keyboard doesn't work for me. I'm on Mac OSX. If anyone has any tips, I'd appreciate it...
User avatar
by monoxide works on Sat Dec 24, 2016 12:16 pm
Any way to browse presets on "native" instruments in S1 using the keyboard? For example, have a Presence XT or Impact loaded up and then browse presets of mentioned instruments?

Thanks.

---------------------------------------------------------------------------------------
Windows 10 64 bit
Adobe Creative Suite
Ableton Live 9
Presonus Studio One 3 Pro
Presonus AudioBox 1818VSL
Novation Launch Control XL
Ableton Push 1 and 2
Native Instruments Komplete Kontrol S88
M-Audio Axiom Pro 25
KRK Rokit 6 G3
KRK VXT 6
Presonus Eris E5
Presonus MTM E44
monoxideworks@gmail.com
User avatar
by jamesjohnson34 on Mon Feb 06, 2017 3:51 pm
The "Komplete Kontrol -1" does not show up as an option. The only one that shows up is the "Komplete Kontrol DAW-1"
User avatar
by chrome7713 on Tue Aug 01, 2017 2:11 pm
HookstownBrown wroteI hope this helps.


you sir, are a legend! :)
Thank you!
User avatar
by mikehowell1 on Thu Nov 01, 2018 9:05 pm
Looking for NKS support and Just found this, and set it up on S1-4, on my iMac. I can now use the S61 Kbd and control play, fwd, backward and stop. Thanks!


Edited: sigh... :? And now I have no midi from my Keyboard, but the controls were working great!

iMac 27" 3.5 Ghz Intel Core i7 Processor, 32 GB DDR3 1600 Mhz Ram, 3 TB Fusion DRV, UA Apollo Quad, Faderport 8, Softube Console 1- and on and on and on....
User avatar
by kristinkorpos on Sat Dec 15, 2018 7:30 am
Just moved over to a new computer and having weird issues. Keyboard is set up properly, shows NKS info in Browser, it is synced with Studio One, BUT the keyboard doesn't play anything? I am baffled, anyone else know what may be up? Other programs recognize it, so this is a studio one thing. I disconnected it, restarted everything, reconnected it in preferences.... So frustrated, hopefully someone can nail this one!

*** SOLVED -- if anyone ends up here, note that the instructions telling you to choose DAW -1 as your input / output were not correct for my computer for some reason. I used MK2 Port 1 for in and out and now I am getting signals from the actual keyboard.
User avatar
by Travelor on Thu Apr 25, 2019 2:37 pm
kristinkorpos wrote*** SOLVED -- if anyone ends up here, note that the instructions telling you to choose DAW -1 as your input / output were not correct for my computer for some reason. I used MK2 Port 1 for in and out and now I am getting signals from the actual keyboard.


If you're installing your Komplete Keyboard for use as a Keyboard you choose the option with the -1 (port 1)
If you're installing your Komplete Keyboard for use as a "DAW" controller (Transport Control) The Stop/Play/Record Buttons and fader POTS - Then you seled the DAW-1 option.
Do not quote me because I have not tried it in Studio One - I know this from other DAW software - Which require the same steps to setup my KK..

Be Blessed...

Edited Coinfusing Instruction - Aplogies for the old post visite-

Excuse Me: Is this where I brag???
Travelor's - :punk: Home Studio - Setup :shock:
Alienware Area-51m - Intel(R) Core(TM) i9-9900K CPU - 32GB RAM - NVIDIA GeForce RTX 2070
Razer Chrome and Mamba
Audio Interface: PreSonus Studio 192 (USB3) Using UC 3.0
Audio Monitors: Paired - PreSonus Eris E8
Primary Recording - Mixing: PH Reason v10 -
Secondary Recording: NI Maschine & StudioOne 4 Artist
Komplete Kontrol 61MK2
Nektar Panorama P6
Yamaha MX88 Ivo-Ebo
Line6 JTV-89F - Ruby
Strat MIM Tex-Mex - Hazel
Strat MIJ HSS - Creamy
User avatar
by Quietly on Tue Dec 03, 2019 9:09 am
All working fine until I just updated Komplete Kontrol to 2.2.0 via Native Access and now neither Loop or Record buttons work in S1. Any help appreciated. (Just checked it in Cubase 10 and all works correctly.)

People who can't dance always blame the band.
https://soundcloud.com/gerry-cooper-855281238
Studio One 4.6 Pro. Windows 10 64 Bit 4 GB Intel 2 Quad Q 9950 @ 2.83 GHz . Focusrite Scarlett 2i4, NI Komplete Kontrol S61, NI Komplete 12 Ultimate, Izotope Ozone 5 and 8. Yamaha HS 80 Monitors.
User avatar
by Mats Nermark on Tue Dec 31, 2019 6:25 am
Quietly wroteAll working fine until I just updated Komplete Kontrol to 2.2.0 via Native Access and now neither Loop or Record buttons work in S1. Any help appreciated. (Just checked it in Cubase 10 and all works correctly.)


My problem with the last update of Komplete Kontrol and Kontakt is that they don't work at all anymore. Not as stand-alone nor as plugins.

NI hasn't responded. It's been a week.

Cheers,

Mats N

20 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 2 guests