Discuss Studio One with FaderPort here.
4 posts
Page 1 of 1
Hi guys,

I just purchased a Faderport because I really wanted to have a nice seamless integration with my Studio One 2.6 Pro software. However... the Faderport was apparently developed prior to the Studio One DAW. The instructions still refer to XP as the latest software and for the life of me.. I couldn't get the thing to integrate with Studio One at all. And yes.. I downloaded the latest firmware from the site.

I contacted Sweetwater tech support and even they couldn't figure iout how to get it working. So... they contacted the Presonus tech team for help and asked that they contact me. This was two days ago and I've still been unable to use my Faderport. Nice!

Also... I'd like to say that I'm fairly disappointed with the build quality of it. It's absolutely nothing like the Audiobox as far as quality goes. The fader isn't silky smooth and the pan knob feels like plastic. Not only does it not have a high quality feel as it rotates, but it isn't a solid feeling potentiometer at all. It pretty wobbly..

I really feel that Presonus dropped the ball on keeping this around in this form. It really needs to be pulled and redeveloped with better components. This has really made me question buying any future Presonus products.

Please help change my mind if you can. It's killing me to say how bad this is, because I've loved the Studio One DAW so much. The Audiobox is also rock solid with good feeling pots and aluminum knobs. Just way better in general.
Last edited by mwright137 on Thu Sep 25, 2014 5:14 am, edited 1 time in total.
Reason: Moved to the proper forum.
User avatar
by PreSonuSupt2 on Wed Sep 24, 2014 7:52 pm
I'm starting you a tech support ticket in our system and will have it assigned to a technician by 9:30 Central Time and you should have initial contact with someone from our side of the house by Close of business.

Check the email you have registered to this account or check your account under support tickets to have a look.
User avatar
by DWdrummer on Wed Oct 01, 2014 11:55 am
It's been over a week and still no call... good thing I got it working myself. Really, really disappointing.
User avatar
by PreAl on Wed Dec 06, 2017 3:48 pm
Please tell me what your long term review is. Are you still using faderport?

Studio One Pro 3.
Faderport.
Focusrite Saffire Pro 40.
Windows 10 Pro 64 bit.
A bigly amount of other gear.

4 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest