Page 1 of 1

Eris 5 speakers - noisy upon install?

Posted: Tue Dec 09, 2014 6:54 pm
by dankruse
I just hooked up a pair of Eris 5 speakers to my home audio system; they're connected to a Focusrite 2i2 interface. I notice that there's a very soft, kind of "rustling" sound coming out of the speakers at all times. It isn't affected by the gain control on the interface. I do note, however, that it's affected by my simply scrolling on my computer screen, either on a document or on the web. Any idea why this is happening? Suggestions??

Re: Eris 5 speakers - noisy upon install?

Posted: Wed Dec 10, 2014 1:17 am
by FinalSaga
Hey Dan

I have had similar in the past, turned out to the wires being to close to my old monitor - happened becaue of lack of shielding
I would try to move the wires away from the monitor or power sourse as a first
It's worth a try

Ch33rs
Saga

Re: Eris 5 speakers - noisy upon install?

Posted: Fri Jan 02, 2015 11:11 am
by ksmason
I have the same problem as Dan. And since my rack is built into my desk right under my computer monitor, I really don't have the option of moving the cables out of the way so I actually bought a couple of Hosa cables that are supposedly shielded for EMI and RFI rejection, but I still get noise from the monitors when scrolling on the computer.

Does anyone know of any good shielded cables that can stop this?

Re: Eris 5 speakers - noisy upon install?

Posted: Fri Jan 02, 2015 11:12 pm
by mrpicholas
Before buying new cables, do some troubleshooting to make sure they are the issue.

If you move them away from the monitors does the noise change in any way?

Turn the output of the AudioBox all the way to zero. Is the rustling noise still there?

Unplug the inputs to the speakers. Is the noise still there?

Re: Eris 5 speakers - noisy upon install?

Posted: Fri Oct 30, 2015 2:33 am
by demoncamberx
Lol I have the same issue right now.

Eris E5's connected on my PC by a premium mini headphone to RCA cable to my Xfi sound card. I hear it more while scrolling a page on my screen just like you. Not sure what the issue is yet, but If I just plug it into my phone and play back audio with same cable, same place, I get no interference at all. So it's something between my PC to the speakers. Hmm... I just bought a line conditioner/power strip so hopefully that will clean up everything. We'll see. Let me know if you figure it out as well! :readit:

Re: Eris 5 speakers - noisy upon install?

Posted: Fri Oct 30, 2015 7:22 am
by matthewgorman
You may be getting noise from the cabling also. Studio monitors are meant to be connected via balanced cable. The longer the cable in your setup, the more chance for noise also.

Just something to look out for when troubleshooting.

Re: Eris 5 speakers - noisy upon install?

Posted: Fri Oct 30, 2015 10:52 am
by demoncamberx
My cable runs are short, less than 6ft. I'm looking into the balanced connections, would using a quarter inch balanced cable to a mini headphone jack adapter still keep it balanced?

Re: Eris 5 speakers - noisy upon install?

Posted: Fri Oct 30, 2015 11:37 am
by matthewgorman
No. Balanced connections are trs, but not stereo. The added conductor is for shield the noise. Its not unheard of, but results may vary.

Re: Eris 5 speakers - noisy upon install?

Posted: Sat Oct 29, 2016 9:57 am
by ajflinne
Resurrecting this thread.....

I also have a rustling sound in one of my Eris 5 monitors and it has become distractingly loud. How did you guys fix this issue? I really don't want to spend $70 plus shipping to send this in to PreSonus, and I'm going to be really frustrated if I'm expected to pay for a faulty part after only a couple years of light use. :hunf:

Help???

Re: Eris 5 speakers - noisy upon install?

Posted: Mon Oct 31, 2016 6:44 am
by ajflinne
))))))))Bump))))))))

Re: Eris 5 speakers - noisy upon install?

Posted: Tue Dec 27, 2016 9:58 am
by spmartin
Yes, I have the same problem. I really wish someone from Presonus could chime in here and give us some solutions. These are great speakers when they are not making the noise.

Re: Eris 5 speakers - noisy upon install?

Posted: Tue Dec 27, 2016 10:16 am
by matthewgorman
This is primarily a user forum. For official word from Presonus, you would need to open a support ticket.

Re: Eris 5 speakers - noisy upon install?

Posted: Wed Jun 28, 2017 3:12 am
by AfterGlow
I have just replaced my M-Audio AV40s with Eris E5s and I am also getting this noise.
The noise is the same level whether the output on my Steinberg UR242 is turned to zero or turned up. I am using the same cabling as on my previous setup, 1/4 inch to 1/4 inch TRS, as my audio interface doesn't have XLR outputs.

I wondered if having the other inputs on the speakers not connected to anything was allowing them to pick up interference. Any thoughts?

Re: Eris 5 speakers - noisy upon install?

Posted: Tue Jul 04, 2017 3:49 am
by AfterGlow
Ok, I checked my cables and realised I was using unbalanced ones to connect from my audio interface to the speakers. :thumbdown:

I have now purchased some of these --> https://www.amazon.co.uk/HosaTech-STX-1 ... h+STX-110M and the noise has gone. :thumbup:

Re: Eris 5 speakers - noisy upon install?

Posted: Sun Mar 31, 2019 5:06 am
by christhomas15
I use TRS cables going from the interface monitors out going into the Temblor T10 inputs and XLR cables going from the Eris E5s inputs to the T10 outputs with the T10 ground switch in the Ground position. No hiss or hum at all. I recommend a power conditioner or a surge protector with efi and rmi protection

Re: Eris 5 speakers - noisy upon install?

Posted: Fri May 10, 2019 8:59 pm
by CSeye
I'm still amazed at the sound stage provide by the Eris 5.

The E5s are hooked up to my audio interface via balanced cables with XLR connectors. The cables are low-end (cheap :D ) 15ft Monster brand purchased in 2006. No noise.

Re: Eris 5 speakers - noisy upon install?

Posted: Sun Jul 21, 2019 4:38 pm
by nickmadaffari
I get some RF interference from my phone when it's close by, and if I shut my PC off with my E5s powered on I get a terrible popping noise. But other than that, no noise. Using some nice balanced quad cables from Canare to go to my sub and then to my monitors. Great set for the price, might I add.

Re: Eris 5 speakers - noisy upon install?

Posted: Thu Oct 31, 2019 4:07 am
by tiffanysnellgrove
Simply pugging each speaker into a separate outlet will help that.