Discuss Eris E4.5, E5, E8, E44 and E66 here
6 posts
Page 1 of 1
Hi Team,

I would just like to verify this issue with my Eris 4.5 BT. I use my Eris 4.5 BT exclusively over Bluetooth. I know this isn't the optimal input for the Eris 4.5 BT but I figured getting a Stereo BT capable speakers are way better than purchasing those Mono BT speakers being sold at the same price. So please bear with me. ;)

I paired my Eris 4.5 BT to my Phone (Android 10) and a MBP - Pairing both successful.

The issue starts when:

Scenario 1 :shock:
MBP connected to Eris 4.5 BT. I disconnect the MBP and connect my Phone, It doesn't connect to Eris 4.5 BT. Off/On Eris 4.5 BT, still doesn't connect. I tried connecting back to MBP, it doesn't connect too. In order to resolve this - I have to press and hold the Pairing button so that either MBP and Phone can connect successfully. So everytime this happens, I had to press the Pairing button.

Scenario 2 :shock:
MBP connected to Eris 4.5 BT. Suddenly the music cuts out - and loses BT connection. Tried reconnecting, doesn't connect again. Off/On Eris 4.5 BT, still nothing. In order to resolve this, I have to press and hold the Pairing button AGAIN so that the MBP can connect successfully to the Eris 4.5 BT.

Scenario 3 :shock:
Turn on Eris 4.5 BT - connect either MBP or Phone - either won't connect! I have to press and hold the Pairing button AGAIN in order for either one to connect.

I already raised this concern to my local distributor - they said they do the same thing in store - always press the Pairing button to connect.

BUT, this shouldn't be the case, Pairing should only be done once - it's a design characteristic of Bluetooth. Reconnection too is a pain. So my questions are:
- Is this really how PreSonus implements their Bluetooth connection?
- Or is this a defective batch of speakers?
- Is there something PreSonus can do to resolve this BT issues? Because honestly, it's starting to annoy me. And my wife too who uses the Eris 4.5 BT more than I do.

I already checked the Knowledge Base and it doesn't have any articles on Eris BT issues, only Ceres BT - and no article was even close to my concerns.

Thank you!

Eris 4.5 BT
User avatar
by karlo4 on Tue Apr 28, 2020 10:06 pm
Anyone from please PreSonus can address my issue???

Eris 4.5 BT
User avatar
by AlexTinsley on Tue Apr 28, 2020 10:34 pm
Your answer is here:
https://support.presonus.com/hc/en-us/a ... -to-audio-

There is a full online tutorial / troubleshooting section for the Ceres Speakers available here:
https://support.presonus.com/hc/en-us/c ... Home-Audio

This is a community forum, if you're looking for a faster response from the company, please log a support request at https://support.presonus.com or through your http://my.presonus.com account.

If you'd like to dicuss your issue with the community, and get their suggestions, then this is the right place to post.

Forum Admin
Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.
User avatar
by karlo4 on Tue Apr 28, 2020 11:01 pm
AlexTinsley wroteYour answer is here:
https://support.presonus.com/hc/en-us/a ... -to-audio-

There is a full online tutorial / troubleshooting section for the Ceres Speakers available here:
https://support.presonus.com/hc/en-us/c ... Home-Audio

This is a community forum, if you're looking for a faster response from the company, please log a support request at https://support.presonus.com or through your http://my.presonus.com account.

If you'd like to dicuss your issue with the community, and get their suggestions, then this is the right place to post.


Thanks for the reply Alex.

However my issue is not signal dropouts entirely. The issue/s are that previously paired devices fails to reconnect to the Eris (on user command). I need to press the "Pairing" button again (and again) in order for the devices to connect.

These devices were already paired before - why do I need to keep on pressing the "Pairing" button? This shouldn't be the case as it's a design characteristic of Bluetooth to just pair once and that should be it.

I have combed the Knowledge Base regarding this issue and no article comes even close to my issue. Is it a failed implementation on the 4.5 BT?
Last edited by karlo4 on Wed Apr 29, 2020 3:24 am, edited 2 times in total.

Eris 4.5 BT
User avatar
by AlexTinsley on Tue Apr 28, 2020 11:24 pm
This is because Apple devices will always be looking to connect, while Anroid devices will make an attempt for 30 seconds and then give up, Apple won't give up.

If your Bluetooth device is on and Apple is not in control it may arbitrarily try to grab a hold of it. Apple can steal a Bluetooth connection from an Android device easier than an Android can grab it away from an Apple device.

As the two devices will fight for BT control, your audio will drop out as you're experiencing.

To manage this, you'll need to select "Forget this device" to clear the memory from your computer or phone when you don't want it to arbitrarily take control from the other one.

Forum Admin
Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.
User avatar
by karlo4 on Wed Apr 29, 2020 3:22 am
AlexTinsley wroteThis is because Apple devices will always be looking to connect, while Anroid devices will make an attempt for 30 seconds and then give up, Apple won't give up.

If your Bluetooth device is on and Apple is not in control it may arbitrarily try to grab a hold of it. Apple can steal a Bluetooth connection from an Android device easier than an Android can grab it away from an Apple device.

As the two devices will fight for BT control, your audio will drop out as you're experiencing.

To manage this, you'll need to select "Forget this device" to clear the memory from your computer or phone when you don't want it to arbitrarily take control from the other one.


Thanks for the reply again Alex. Your explanation partially explains Scenario 2. :thumbup: But unfortunately, even if the connection drops on the MBP, the Eris doesn't connect to my phone.

But the main issues for Scenarios 1-3 is that the Eris 4.5 BT fails to reconnect to my devices (from "Off" to "On" state or while the Eris is "On") when they have already been paired beforehand. I have to constantly hit the Pairing button at the back of the Eris (without deleting the paired profile in my devices) in order for the Eris to connect again to any of my devices.

The local distributor also confirms that they have the same "issues". So that's why I know it's not an issue with my unit only.

Eris 4.5 BT

6 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 2 guests