Discuss Eris E4.5, E5, E8, E44 and E66 here
4 posts
Page 1 of 1
Hi,

Have you come around over any problem with the tweeter of these speakers?
I power them off over the night with a dedicated power switch. But the next day when I power them in my left Eris E5 speaker exhibits a strange behaviour at low volumes, I've got no tweeter sound, its like its blown, but if I crank the volume a bit, it gets unstuck and starts to sing normally, and after that I can return to low volume with no problem.
My speakers are ~1 month old, should I expect any issue in near future?

My setup:

Eris E5's , Temblor T10, AudioBox iOne
User avatar
by Trucky on Mon Mar 02, 2020 10:13 am
My Eris E5 monitors don't act that way.

I'd contact the vendor and ask for an exchange.

Please add your specs to your SIGNATURE.
Download the STUDIO ONE 5 PDF MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 10 Pro 64-bit (2004), Studio One 5.0.1 Pro | Notion 6.7.489 | Universal Control v3.3.0.59348
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
StudioLive Series III 32 v2.3.16845
User avatar
by mattogrady on Mon Jun 29, 2020 7:47 pm
I've noticed exactly the same thing with my Eris E5XTs but its a problem that has evolved over the past 10 months. At first I started noticing the tweeter coming in and out especially at low volume and would only kick in when you cranked more signal into it. Now it happens regardless of volume. Still under warranty fortunately but did you find out what was causing yours to behave this way?
User avatar
by marius-aurelmerciu on Fri Jul 24, 2020 10:04 am
Nope, send them to store service 3 weeks ago with the following message:

Code: Select all
Unfortunately I have some problems with one of the two active speakers from Presonus.


I have problems with the speaker with the serial [redacted] and Manufacture Date D011904.

Problem description:


- It has a lower volume than the other functional one; (with INPUT GAIN set to 0)
 - it has problems with the smaller loudspeaker (tweeter); (it sounds interrupted for about 1 hour until it "heats up" and then the problems return after a few hours)
 - Due to the problems listed above, I can't balance them evenly from the "INPUT GAIN" potentiometer (which normally should be set to 0 for both) because I can bring only one of the two speakers from the speaker box to the same volume level as the other active speaker box.

How they are connected:
All Presonus equipment is powered on a separate power socket from the audio interface and computer. I use the Presonus AudioBox iOne audio interface with balanced XLR Jack 6.3mm cables together with the Presonus Temblor T10 subwoofer.

What I tried:
I changed the speakers (left to right)
I changed the XLR cables between them.
I set "Downmix channels to mono" to see the stereo-mono differences and tested on countless songs. I tested through another audio interface without balanced output (RCA) (Fiio E10K)
I tested on Foobar / Spotify / Youtube.

What I noticed:


It doesn't matter what I tried above, the problem persists.
 It doesn't seem to be the speaker itself (the tweeter), but rather the power supply circuit of the speaker box.
If the audio system is set to a higher volume, it recovers in a shorter period of time.
I use them mainly 90% of the time at a volume of 25% of the Presonus iOne console, with short periods ~ 10% to 50% of the volume.

I had this problem relatively from the beginning but initially I said it seemed to me. But slowly it began to become more obvious and the situation worsens with each passing day.
I really like these speakers but I had the misfortune to get a lemon.
I originally posted on the manufacturer's forum here:

https://forums.presonus.com/viewtopic.php?f=76&t=38123&p=223713#p223713

Given the situation with covid-19, I preferred to wait until I made this request.

4 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest