StudioLive 2442, 1642 and 1602 with Universal Control Ai, SL Remote & QMix
2 posts
Page 1 of 1
Hi!
I've purchased the StudioLive 16.0.2 USB console and it had worked with my PC for a while but recently stopped working. When I plug it in now, my computer prompts a notification saying the USB device was not recognized. I have tried on multiple devices, all had up-to-date Universal Control with the USB Classic Driver installed.
I've submitted a ticket with PreSonus support, but in the meantime.. Did someone else encounter the same issue?

Thanks!
User avatar
by PAE Seth on Fri Sep 10, 2021 11:01 am
Could be bad cable. Change to a quality USB 2.0 cable.

Also, after that, you can check on another computer by install UC. If the problem follows, then it could be hardware. Support can help with that.

PC: ASUS X299 Prime Deluxe II, i7-7820X 8c/16t @ 4 GHz, 16GB 2666 MHz DDR4, AMD RX 5500 XT 8GB

Mac: 2010 Mac Pro 6 core 3.33 GHz, 32GB 1333 MHz DDR3, nVidia GT 710 1GB, Alpine Ridge Thunderbolt 3 Card, Aquantia 10GB AVB card

2 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest