StudioLive 2442, 1642 and 1602 with Universal Control Ai, SL Remote & QMix
8 posts
Page 1 of 1
The statement was announced today. Currently there is no compatibility, so DO NOT INSTALL 10.15 if you want to work with PreSonus equipment. "We will provide an update when we have qualified 10.15 for use with our products and what updates are needed to ensure proper compatibility."

https://support.presonus.com/hc/en-us/a ... Statement-

SL16 | 32R | 16R | 16M

Apple routers | iPads | PreSonus SW5E & Motu AVB switches | Alesis iO Docks | Yamaha S112, S15e, S10e, SM12, SM10 | LD Systems Curv 500 | Galaxy Audio Hot Spots | Mac mini | Lenovo Laptop | Studio One Artist 4.5.4 & Pro 3.5.6
User avatar
by stenmars1 on Wed Nov 13, 2019 10:53 am
Hi there, is there any update on this? I stupidly updated to Catalina and have now just bought a Studiolive 16.0.2 FW which is great but right now I can't use the Firewire interface.

Neil
User avatar
by andreschnherr on Fri Dec 06, 2019 4:13 pm
I‘m waiting too... :-/
User avatar
by wahlerstudios on Fri Dec 06, 2019 4:18 pm
From the above mentioned document:

Universal Control 1.7.6 - [Updated: 12-4-2019] - for FireWire products still work on Mac OS X 10.8.5—macOS 10.14 Mojave (Windows 7, 8.1, and 10, as well as). However, it will not be available on macOS 10.15 Catalina or future macOS versions. Users of these products are advised not to update their systems beyond macOS 10.14 Mojave:

StudioLive 1642
StudioLive 2442
StudioLive 1602 Classic
FireStudio Project
FireStudio Mobile
FireStudio Tube
FireStudio Lightpipe

SL16 | 32R | 16R | 16M

Apple routers | iPads | PreSonus SW5E & Motu AVB switches | Alesis iO Docks | Yamaha S112, S15e, S10e, SM12, SM10 | LD Systems Curv 500 | Galaxy Audio Hot Spots | Mac mini | Lenovo Laptop | Studio One Artist 4.5.4 & Pro 3.5.6
User avatar
by mihaelabramovic on Tue Dec 17, 2019 4:38 am
So, if i get it right, all the Mac users are stuck on an old OS if they want to use Presonus Hardware? Not very user friendly because we have to keep the old OS and accept security risks on the system because we are not allowed to update it.
User avatar
by wahlerstudios on Tue Dec 17, 2019 6:46 am
No, it's not "all" Mac users and only the listed products are concerned (the "classic" StudioLive mixers and some FireStudio devices). The changes happened on the Mac side for "Catalina", not to forget the history of Apple and FireWire... Why not get an "old" Mac and use it exclusively for audio? Using a computer ONLY for audio/music things has always been a good practise and you can keep your "working system" as long as it works. Often parts can be replaced by buying used equipment. You would not want to connect a modern navigation system to an old car's electroncis... ;-)

SL16 | 32R | 16R | 16M

Apple routers | iPads | PreSonus SW5E & Motu AVB switches | Alesis iO Docks | Yamaha S112, S15e, S10e, SM12, SM10 | LD Systems Curv 500 | Galaxy Audio Hot Spots | Mac mini | Lenovo Laptop | Studio One Artist 4.5.4 & Pro 3.5.6
User avatar
by Wally on Sat Jan 11, 2020 7:02 am
wahlerstudios wrote No, it's not "all" Mac users and only the listed products are concerned (the "classic" StudioLive mixers and some FireStudio devices). The changes happened on the Mac side for "Catalina", not to forget the history of Apple and FireWire... Why not get an "old" Mac and use it exclusively for audio? Using a computer ONLY for audio/music things has always been a good practise and you can keep your "working system" as long as it works. Often parts can be replaced by buying used equipment. You would not want to connect a modern navigation system to an old car's electroncis...


I understand Presonus wanting to drop support for discontinued products, especially when they don't make any money from doing driver updates on these products. So what if they pi$$ off a few users. After all there can't be that many of us left. Right? Can you tell I still feel neglected. I wouldn't think an update to UC "Classic" would be that time consuming, after all it shouldn't be a ground up re-write, just a few changes to make it compatible with the new OS security features. But what do I know I'm just a programmer.

My SL24.4.2 still functions fine as my live board and studio interface. UC 1.6.5 and UC 3.xx run in harmony supporting my old SL24.4.2 and newer Quantum interfaces. I must be the last person on the planet using Classic Presonus hardware.

IMO The above quote is just a crazy statement. If I don't upgrade my OS how am I suppose to stay current with StudioOne, VST's and Quantum upgrades?!? Not to mention my non-Presonus software and equipment. Wish I had your money so I could afford to upgrade every time a perfectly good piece of equipment went obsolete. :? Or to own 2 MACs?? :hunf:

MacMini (2014 version)
Quantum, StudioLive 24.4.2, FireStudio Mobile
FaderPort

Tascam VL-A5 Monitors
StudioOne, Logic X
Rode NT2-A, Shure Beta 52, SM58's, SM57's
Roland A-49 Keyboard Controller, Korg M1, Kronos 88
Gibson Les Paul Studio, Godin Freeway Classic
Boss ME-50, GT-10, GT-1000
User avatar
by andreschnherr on Thu Jan 16, 2020 1:29 pm
Will never again invest money on Presonus products.

Luckily there a other companies out there with better support.

I‘m sad.

:thumbdown:

8 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest