2 posts
Page 1 of 1
While using universal control and studio one on PC (windows 10) with my io24 things worked fine for 1 session then during the next session the io24 stopped responding over USB.

I put in a support ticket and will update this if / when I hear something back but curious if others have seen this / warn others this could happen during their sessions, maybe even while live.

The io24 physical hardware is functional and I hear myself on loopback. I can use the knob to turn phantom power on / off and it does perform the action. However, using universal control I can see the serial number, see the device is connected, can change the block size and it seems to "reset" in some way but when opening the io24 app nothing syncs / controls the device. phantom power will be active on the device but show off on the app and clicking has no effect. turning the preset knob has no effect.

I have rebooted, unplugged, tried the reset in the io24, uninstalled UC and S1, reinstalled everything again, etc etc. Nothing seems to make a difference. I tried to reflash the firmware and the process starts then I get an error saying cannot communicate with device. This device seems to need some sort of factory reset switch.

I wish I had looked through the forums here before purchasing because it seems like this may be a solid unit for ~$100-135 or when a reliable V2 launches if still at the $200 price point.
User avatar
by Trucky on Wed May 18, 2022 11:57 am
Welcome to the Forum!

My io24 works great for me on Windows 10 with my Dell laptop and Lenovo desktop computer.

Have you made any progress in troubleshooting the issue since submitting your support ticket?

Please add your specs to your SIGNATURE.
Download the STUDIO ONE 5 PDF MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 10 Pro 64-bit (21H2), Studio One 5.5.2 Pro | Notion 6.8.2 | Universal Control v3.6.2.85277
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
Series III 32 v2.5.1.84445, Revelator io24 v1.21

2 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 2 guests