16 posts
Page 1 of 1
Has anybody got the io24 to work well with OBS for recording tutorials?

I am certainly not a newbie to audio and production, but I am new to OBS. I have been requested to make some tutorial videos with Studio One for some mixing and mastering students and it was suggested I use OBS and the io24 with Studio One using the Loopback features and recording my screen and audio etc. I am on Windows 10, the latest update, and have Studio One 5.3.
I know that I can set up OBS using Voicemeeter or the Voxengo method (32bit with jbridge) but I was really hoping for a less complicated way. And this is what I thought the io24 did.
I can get my mic showing up in Universal Control, I can get Studio One showing up on the Loopback input on UC, UC seems to be working fine. But I cannot get the audio to show up in OBS at all. I have tried everything. All the tips and tricks online. No joy.
I wondered that if somebody has successfully connected OBS and Studio One's audio with Loopback that they could possibly share their settings if it wasn't too much trouble.



Otherwise, unfortunately. my io24 is a paperweight as I already have a mastering grade interface to do my actual work and only bought the io24 for making tutorials using OBS.

ASUS ROG Windows 10 i7 2.3ghz 8 Core 32GB RAM, Studio One 5.x, Sequoia15, Faderport V2, RME ADI-2 DAC, SPL Phonitor 2, Arturia Minilab II, Novation 49SL MKII, Audeze LCD-X, Genelec.
User avatar
by SwitchBack on Sun Sep 12, 2021 9:53 am
Hi and welcome to this forum :)

Quick look at the OBS features tells me that OBS doesn't offer native ASIO support. Studio One does. So best option is to set your computer's system audio to use one of the io24's loopback channels as that will make OBS to use that channel too. And then make Studio One use the io24 as its interface too. Looks like the details are on p.27-29 of the User's Manual.
User avatar
by conanmanchester on Sun Sep 12, 2021 10:01 am
Thank you, I will try that. I have tried so many different ways I can't remember if I have tried that yet.
Cheers

ASUS ROG Windows 10 i7 2.3ghz 8 Core 32GB RAM, Studio One 5.x, Sequoia15, Faderport V2, RME ADI-2 DAC, SPL Phonitor 2, Arturia Minilab II, Novation 49SL MKII, Audeze LCD-X, Genelec.
User avatar
by SwitchBack on Sun Sep 12, 2021 10:12 am
Yeah, loopback can be a real brain-twister. Wish you success working it out :thumbup:
User avatar
by conanmanchester on Sun Sep 12, 2021 10:16 am
Unfortunately, no joy there either but thank you so much for the suggestion. It's really got me beat. I am beginning to think that the io24 has exactly the same issues that every other interface has when you use ASIO on a PC with OBS. I was really hoping this eradicated the ASIO with OBS issue, but it would appear not. They kind of market it in such a way that it appears to eradicate the ASIO OBS issue, I just haven't quite find out how yet haha.

ASUS ROG Windows 10 i7 2.3ghz 8 Core 32GB RAM, Studio One 5.x, Sequoia15, Faderport V2, RME ADI-2 DAC, SPL Phonitor 2, Arturia Minilab II, Novation 49SL MKII, Audeze LCD-X, Genelec.
User avatar
by SwitchBack on Sun Sep 12, 2021 12:07 pm
I think the idea is to use WDM for Windows and OBS, and to use the io24's native driver for Studio One. No need to worry about ASIO.

As for the loopback brain-twister: Loopbacks show up as an input and an output. You send something to the output and it comes back from the input. Can make sense one moment and make no sense the next ;)
User avatar
by Bbd on Sun Sep 12, 2021 5:59 pm
Agreed.

Bbd

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 5 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


OS: Win 10 x64 Home, Studio One Pro 5.x, Notion 6, Series III 24, Studio 192, Haswell CPU: i7 4790k @ 4.4GHz, RAM: 16GB, Faderport 8/16, Central Station +, PreSonus Sceptre S6, Eris 3.5, Temblor 10, ATOM, ATOM SQ
User avatar
by conanmanchester on Sun Sep 12, 2021 9:26 pm
SwitchBack wroteI think the idea is to use WDM for Windows and OBS, and to use the io24's native driver for Studio One. No need to worry about ASIO.

As for the loopback brain-twister: Loopbacks show up as an input and an output. You send something to the output and it comes back from the input. Can make sense one moment and make no sense the next ;)


Ok I will try that. Thank you again.

ASUS ROG Windows 10 i7 2.3ghz 8 Core 32GB RAM, Studio One 5.x, Sequoia15, Faderport V2, RME ADI-2 DAC, SPL Phonitor 2, Arturia Minilab II, Novation 49SL MKII, Audeze LCD-X, Genelec.
User avatar
by conanmanchester on Sun Sep 12, 2021 11:06 pm
No joy :(

Looks like io24 is a paperweight lol

Thank you for all your input guys.

ASUS ROG Windows 10 i7 2.3ghz 8 Core 32GB RAM, Studio One 5.x, Sequoia15, Faderport V2, RME ADI-2 DAC, SPL Phonitor 2, Arturia Minilab II, Novation 49SL MKII, Audeze LCD-X, Genelec.
User avatar
by Bbd on Mon Sep 13, 2021 1:44 am
Please open a support ticket to see if they can help.

Bbd

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 5 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


OS: Win 10 x64 Home, Studio One Pro 5.x, Notion 6, Series III 24, Studio 192, Haswell CPU: i7 4790k @ 4.4GHz, RAM: 16GB, Faderport 8/16, Central Station +, PreSonus Sceptre S6, Eris 3.5, Temblor 10, ATOM, ATOM SQ
User avatar
by conanmanchester on Mon Sep 13, 2021 3:01 am
Thanks buddy. Yes I opened one yesterday when I made this post. I don't think they work weekends so I will hopefully get a reply today or tomorrow if they're not too busy. If I get this resolved, I will post it here for everyone else who may run into this issue. Thanks again.

ASUS ROG Windows 10 i7 2.3ghz 8 Core 32GB RAM, Studio One 5.x, Sequoia15, Faderport V2, RME ADI-2 DAC, SPL Phonitor 2, Arturia Minilab II, Novation 49SL MKII, Audeze LCD-X, Genelec.
User avatar
by chillheimer on Tue Sep 14, 2021 3:09 pm
please keep us posted if you have any success. trying to live stream audio from studio one via obs. but I just can't get any audio into obs. systemsounds, specifiv applications like spotify, all no problem.
but chosing my apollo solo out, that I actually listen to: silence.
User avatar
by conanmanchester on Wed Sep 15, 2021 8:46 pm
chillheimer wroteplease keep us posted if you have any success. trying to live stream audio from studio one via obs. but I just can't get any audio into obs. systemsounds, specifiv applications like spotify, all no problem.
but chosing my apollo solo out, that I actually listen to: silence.


Sure, I will reply on this post if I have any progress. I am talking to support now but they cannot work out the issue. I have now tested the io24 on three systems. None of them can get audio to OBS using the Loopback system. For now I am using the FL Studio ASIO driver method but that is not ideal as the latency is 60ms at best. I am used to working with 5ms at worst. Also I didn't buy an IO24 to then have to workaround with FL Studio ASIO. I could have saved the money and used the interface I owned to do that.

ASUS ROG Windows 10 i7 2.3ghz 8 Core 32GB RAM, Studio One 5.x, Sequoia15, Faderport V2, RME ADI-2 DAC, SPL Phonitor 2, Arturia Minilab II, Novation 49SL MKII, Audeze LCD-X, Genelec.
User avatar
by tomkunzelmann on Fri Sep 17, 2021 5:52 am
Hello :D

What i have found to be a great solution is a free VST Plugin by the Reaper People, called ReaStream. This VST can be put on the Master Bus / Monitoring section of Studio One. Choose stream local there. Now you can put the VST as an Audio Input to OBS. It works very good for me. You should record your voice (if you plan on doing so) inside of Studio One and not OBS and turn off the Main Audio of your computer while recording so you will not be influenced by the latency.
User avatar
by SwitchBack on Fri Sep 17, 2021 9:47 am
It should work with the io24 alone because the interface was designed for exactly this purpose of making apps talk to each other. Better to make that work rather than introducing an ‘in between’ app. Keep faith :)
User avatar
by Trucky on Tue Sep 21, 2021 6:04 pm
I have my mic and Studio One connected to the Revelator io24 and OBS working. The method I'm using does not require a plugin or 3rd party add-on. I'm documenting this now and will share here when I'm finished.

Please add your specs to your SIGNATURE.
Download the STUDIO ONE 5 PDF MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 10 Pro 64-bit (21H1), Studio One 5.3 Pro | Notion 6.8.1 | Universal Control v3.5.2.65533
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
StudioLive Series III 32 v2.5.17953

16 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest