3 posts
Page 1 of 1

I've just received the Revelator and plugged in into Windows 10 through the USB cable. The device is recognized by windows (default windows driver). I then installed the Universal Control software (version Win x64 with all components/drivers selected) and reboot the computer.

When I run the Universal Control software, the Revelator is not shown as in the documentation.


And from the File menu, the Show All Devices and Close All devices features are disabled.


Related topics I tried without success:
- viewtopic.php?p=252992#p252992 with 2 install/uninstall and reboots: KO
- viewtopic.php?p=252338#p252338 but the Universal Control software is NOT present into the Windows the list of software candidates for mic privacy. Do I really need this privacy setting? I guess the Universal Control software can access the mic through the driver?... And if I need it, how to enable it from the privacy list if it is not part of it?

Any ideas how I can get the Reletator USB into the Universal Control on Windows 10?



PS: I tried both available versions: Universal Control v3.4.1.63149 and the previous Universal Control v3.4.0.61835. Same behavior.
User avatar
by maximenaslain on Wed Mar 17, 2021 5:26 pm
I finally found a workaround by disabling the windows UAC before installing Universal Control (as said in https://answers.presonus.com/51507/univ ... ot-working).


This is not a normal behavior; setup should work fine with UAC enabled (at least with a message, or privileges escalation window).
User avatar
by Bbd on Wed Mar 17, 2021 6:21 pm
Glad you got this working.
You should report this to Support to document the issue.


Please add your specs to your SIGNATURE.
Search the STUDIO ONE 5 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.

OS: Win 10 x64 Home, Studio One Pro 5.x, Notion 6, Series III 24, Studio 192, Haswell CPU: i7 4790k @ 4.4GHz, RAM: 16GB, Faderport 8/16, Central Station +, PreSonus Sceptre S6, Eris 3.5, Temblor 10, ATOM, ATOM SQ

3 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest