Discuss Quantum Series Interfaces Here
4 posts
Page 1 of 1
I know this has been asked but I've recently bought the Quantum 2626. I've loaded universal control and it isn't seeing the device. I've looked in the computer thunderbolt and it sees it. I've unloaded and tried unplugging power and cable and restart but nothing. I can't get universal control to do anything ,any help would be great. I'm not computer savvy navigating if things don't go as planned from instructions. Thank you.
User avatar
by TerjeNorway on Wed Dec 30, 2020 8:44 am
What is you hardware setup? Motherboard and add on thunderbolt if you have that.

My system
Intel Core i9-10900K Processor
Noctua NH-U12A CPU cooler
Gigabyte Z490 VISION D
Samsung 970 EVO Plus 1TB SSD
Corsair Vengeance LPX DDR4 3200MHz 32GB
MSI GeForce GTX 1070 Ti Gaming 8GB
StarTech Thunderbolt Cable 2M (TBOLTMM2MW)
StarTech Thunderbolt 3 to Thunderbolt 2 adapter (TBT3TBTADAP)
Neumann TLM 102 microphone
Presonus Quantum
Windows 10, Ableton 10, Cubase 10
User avatar
by wynlewis on Thu Jun 24, 2021 12:52 pm
Did you manage to sort this? I'm having same issues and getting nowhere fast
User avatar
by timmorris on Thu Jul 01, 2021 12:47 pm
Did you guys sort this?...I had same issue with Mac M1..

I had to change my security settings to allow external Kernal thingies

Then I had to run an update to the 2626...this got stuck saying 6sec to go but never ended.

I quit UC, and when I reopened it said update had ben applied ?...then tried again but it didn't see the 2626...I powered off the 2626 for 10sec then back on....now UC sees the 2626 and all works

The Presonus help on this is poor to say the least.

Presonus 16.4.2 - Mac mini 2.3G i7, 16G Ram, Faderport - S1 -3 Pro
Novation Impulse 49 - Yamaha HS7 - Kemper Profiler -
SE 3300 - SE2200 - SE Reflexion - EBMM AAxis super sport - Taylor 414CE - PRS 513.

4 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 3 guests