Discuss Studio 2|4 / 24c, 2|6 / 26c, 6|8 / 68c, 18|10 / 1810c, and 18|24 / 1824c USB 2.0 Interfaces Here
2 posts
Page 1 of 1
I have lost my usb connection to my Windows 10 pc. Formerly, everything was working fine, and today I tried activating Trusted Platform Module 2.0 (TPM 2.0) which is required for future Windows versions. All my audio stuff blew up. Pro Tools wouldn't load and there was no audio of any sort, so I deactivated TPM and rebooted. Still no audio. Did a system restore to before the TPM stuff. Still no audio. After much head scratching, I have learned that the system doesn't recognize that the 1824c is there. The usb light on the front panel is red. Universal Control does not see the interface. I reinstalled Universal Control, and still not seeing it. I looked at the hardware manager, and there is no driver for the 1824c. I tried installing the 1824c driver manually, and it installs, but cannot start, with a Code 10 error. I'm stuck. Any suggestions?

System is Windows 10 with latest updates, Single Intel(R) Core(TM) i9-9900K CPU 3.60 GHz processor, 32.0 GB ram, and Pro Tools 12,
User avatar
by Trucky on Wed Jun 22, 2022 7:42 am
Welcome to the Forum!

Here's a link for something to try:

Have you submitted a support ticket for this?
If not, please do so (see link below in my signature).

Please add your specs to your SIGNATURE.
Download the STUDIO ONE 5 PDF MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.

Windows 10 Pro 64-bit (21H2), Studio One 5.5.2 Pro | Notion 6.8.2 | Universal Control v3.6.4.87069
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
Series III 32 v2.5.1.84445, Revelator io24 v1.21

2 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 2 guests