Discuss Studio 2|4 / 24c, 2|6 / 26c, 6|8 / 68c, 18|10 / 1810c, and 18|24 / 1824c USB 2.0 Interfaces Here
2 posts
Page 1 of 1
I am using Studio One 5 and Studio1824C interface.
Now my Studio1824C interface is not recognized. It worked perfectly before.
I tried several times installing Universal Controller and reconnecting the interface but no luck.
Please advice how to solve the issue.
My system configuration as below:
OS: Microsoft Windows 10 64-bit [10.0.19044]
Processor: Intel(R) Core(TM) i7-10700F CPU @ 2.90GHz
Physical: 1
Cores: 8
Logical: 16
L1 Cache: 32 KB (16)
L2 Cache: 256 KB (8)
L3 Cache: 16384 KB (1)
Installed RAM: 32665 MB

Kind regards
Robin Guda
User avatar
by johnbruce2 on Wed Feb 09, 2022 7:17 am
I have the same problem as well. It's a shame nobody has responded yet! I bought my 1824c second hand and I didn't get the original cable so I bought a usb c to usb A. I suspect that maybe the cable is faulty as it all worked yesterday and studio one recognised it. Today it isn't having it. I am running windows 10 64 bit!

2 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 2 guests