Discuss Studio 2|4, 2|6, 6|8, 18|10, and 18|24 USB 2.0 Interfaces Here
2 posts
Page 1 of 1
Hi, I recently purchased a Studio 24c interface and hooked it up to a WIndows 10 PC. The PC is high end and should be able to handle the workload easily. It is connected via the USB 3 to USB C cable included. I downloaded the official Presonus ASIO drivers and removed the ASIO4LL drivers (I read they are incompatible). I am also using the DAW software from Presonus.

The problem I'm having is that there is a half-second latency. I hit the strings, and the sound comes out just after that. It's short, but it's bad, and makes it unusable.

The driver, for whatever reason, doesn't seem to allow me to change the sampling sizes or other settings.

Any advice on where to start? I've tried everything I know, and have no idea why this is occurring?
User avatar
by Trucky on Sat Jun 12, 2021 9:11 pm
What block size are you using?
What are your computer specs?
You should be able to lower the block size in Universal Control to achieve less latency.

Please add your specs to your SIGNATURE.
Download the STUDIO ONE 5 PDF MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 11 Pro 64-bit (21H2), Studio One 5.4 Pro | Notion 6.8.1 | Universal Control v3.6.0.66460
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
Series III 32 v2.5.17953, Revelator io24 v1.13

2 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest