Discuss Studio 2|4, 2|6, 6|8, 18|10, and 18|24 USB 2.0 Interfaces Here
2 posts
Page 1 of 1
I got a brand new 18|24 from B&H Photo and connected to my computer. On launching UC, it asked me to update the FW. I followed the instructions and did the update. After that I am getting USB Unknown device - Device Descriptor Request Failed and UC doesn't talk to it. Seems like the FW update has bricked the system. I went to website and found that you can reset it to factory FW by pressing the Line button 5 times after turning on the system but that doesn't seem to work (I tried all sorts of ways - slow press, fast press, etc). I have raised a ticket and they are very slow to respond, one response per day. I am sure I am not the only person who is experiencing this. Is they are chance to recover? Or i got a Lemon?

Thanks for any help.

User avatar
by Benoni on Sun Jun 23, 2019 2:14 pm
Have you tried uninstalling the driver and re-install?

Have you tried another USB port?

2 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest