Discuss Studio 2|4, 2|6, 6|8, 18|10, and 18|24 USB 2.0 Interfaces Here
6 posts
Page 1 of 1
I'm running Win10 + Ableton Live 10 and I recently added a Studio 68c interface.

Live recognises the interface and the buffer size defaults to 512 samples. I'd like to reduce this.

I have Universal Control 3.0.051747 Win 64 built on Mar27 2019 installed. Show all devices is greyed out.

I can input and playback through Studio 68 but I can't change any of the settings.

Has anyone had this previously/any ideas what's wrong?

Kind reards

User avatar
by brianhaywood1 on Mon Apr 22, 2019 8:09 am
I had exactly the same problem after updating to the new Universal Controller software, I uninstalled the software completely and re-installed the previous version, and it all works again,....

Maybe its something on my PC, but im guessing the update might have a few problems
User avatar
by BarrowfordBluesman on Tue Apr 23, 2019 2:44 am
Thanks for the reply.

I think I've sorted this now, but no real idea how or why.

Uninstalled/reinstalled and lo and behold it is now recognised.

My old Firebox (nothing wrong with it - just 10 years old) worked straight away on my new system, even using the old driver.

Hope it all continues to work.
Thanks again
User avatar
by brettcusack on Mon Aug 17, 2020 3:24 am
Hey all!

Running 2014 Mac book pro with Catalina with Studio 68c

Universal Control recognises the unit and I can playback audio from logic and my computer but I can't actually open universal control.

Tried uninstalling and reinstalling.

Any ideas?
User avatar
by samuelverreth on Mon Nov 02, 2020 2:15 pm
I cannot open Studio 68c in UniversalControl. When I click on it, it wouldn't open. This happens with my mixer console StudioLive 24.4.2AI, and it's really useful. I really would like to access the mixer to adjust the output volumes of studio 68c.

Schermafbeelding 2020-11-02 om 20.55.53.png
User avatar
by BarrowfordBluesman on Mon Nov 02, 2020 2:35 pm
I am sorry, I see you are on a Mac and I've never used one. Since my early problem, the age old trick of uninstall/reinstall worked, I have had no further issues.


6 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 3 guests