Discuss Studio 2|4 / 24c, 2|6 / 26c, 6|8 / 68c, 18|10 / 1810c, and 18|24 / 1824c USB 2.0 Interfaces Here
2 posts
Page 1 of 1
Hi, I didn't know if anyone could help me with this issue...

I noticed I was having some sound issues when using my studio 24c so I downloaded universal control and attempted to update the firmware. As soon as I hit update the light went from blue to blinking red, i guess signaling that it was updating. about four minutes in, universal control told me it couldn't connect (it already had) and there was no physical factor that could've disconnected it. after said incident the 24c wont be recognized by reaper, by universal control, or even by my computer.

tried multiple cables, tried looking for a way to factory reset the firmware so i could at least try again or get it working in some regard but even in the owners manual there's absolutely no reference on how to do that.

for reference,

I'm running windows 10, x64
Universal Control 3.6.4.

any help at all would be greatly appreciated
User avatar
by Trucky on Thu Aug 04, 2022 2:18 pm
Welcome to the Forum!

Please submit a support ticket (see link in my signature below) for this. Thanks!

Please add your specs to your SIGNATURE.
Download the STUDIO ONE 5 PDF MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.

Windows 10 Pro 64-bit (21H2), Studio One 5.5.2 Pro | Notion 6.8.2 | Universal Control v3.6.4.87069
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
Series III 32 v2.5.1.84445, Revelator io24 v1.21

2 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 2 guests