Discuss Studio 2|4, 2|6, 6|8, 18|10, and 18|24 USB 2.0 Interfaces Here
6 posts
Page 1 of 1
I bought a 26c on 10/5/2019....unable to register product. Had to take photos of my receipt, the device and the serial # on it before Presonus would register device. Took several days since I am in the US and they are in Ireland. Got it registered. Then Input 1 and 2 were not working.I spent almost 30 days trying to get someone from Presonus to help trouble shoot. They finally suggested I work with someone in the US...BRILLIANT...been 3 weeks screwing around. The Tech guy said it was garbage and I should return it. I returned it on the last day I could and bought a second 26C. I just got it tonight. Failed to Register. Not a good sign, Is this company worth a xxxx? How long before I can use this xxx? 2020-or beyond? Getting fed up.
User avatar
by Bbd on Thu Nov 07, 2019 10:16 am
Michael,
About your issue, Support has a 26c registered in your account as of October 9th.
Please create a Support Ticket for any issues you are now having.
There's nothing anyone can do here in the forum to help you solve your issue.

Please also read our forum Code of Conduct for inappropriate language.
Thanks much.

Bbd

Bbd

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


OS: Win 10 x64 Home, Studio One Pro 4.x, Notion 6, Series III 24, Studio 192, Haswell CPU: i7 4790k @ 4.4GHz, RAM: 16GB, Faderport 8/16, Central Station +, PreSonus Sceptre S6, Eris 3.5, ELAC Sub, ATOM
User avatar
by michaelsauber on Thu Nov 07, 2019 7:36 pm
Yes, I know. That was my first 26C...which I could not register. I had to return it because the Inputs were dead right out of the box. Took a month for Presonus to give me the okay to return it. Second one cost more because price went up while Presonus was troubleshooting, and now I can't register the NEW ONE. It is very worrisome and yes...I put in another ticket.
Swearing may not be allowed on this forum, but IMO it certainly was not inappropriate considering the situation. Swearing seems to be the only way to get someone to respond to a post.
User avatar
by Bbd on Thu Nov 07, 2019 8:51 pm
It's not about swearing. It's about getting help thru Support. I inquired on your behalf. Now you need to get with them and get this fixed!
;)

Bbd

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


OS: Win 10 x64 Home, Studio One Pro 4.x, Notion 6, Series III 24, Studio 192, Haswell CPU: i7 4790k @ 4.4GHz, RAM: 16GB, Faderport 8/16, Central Station +, PreSonus Sceptre S6, Eris 3.5, ELAC Sub, ATOM
User avatar
by michaelsauber on Sun Nov 10, 2019 4:07 pm
This is my second Presonus 26C in 35 days and it is having the same issue as my last one. Can't register and Inputs 1 & 2 DO NOT WORK AT ALL! Nice products!
How can Tech Support in Ireland help me when I am in the United States? A back and forth on email for 30 days in not good enough. The first one should have worked out of the box, but when It did not, I thought okay, I will work to see what the issue is. Turns out to be bad inputs. I buy a second (Because I am fair) and IT DOES NOT WORK!!! How many years before I luck out and get a Presonus that works????
Can anyone recommend a quality Audio Interface? I am in the market.
User avatar
by AlexTinsley on Sun Nov 10, 2019 7:55 pm
Hi Bbd alerted us that you're still having issues.
I also see you have a support ticket open, I read through all of your support ticket history.
From what I gather you're having an impedance issue between your guitar and the 26c.

Can you provide more details for the community so we can assist further.

What guitar are you using?
Is it active or passive output?
Do you happen to know what is its output impedance?
I read in the support ticket you're using a Passive DI Box, exactly which one are using?

Forum Admin
Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.

6 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest