23 postsPage 1 of 2
1, 2
I use AVB to play multi-channel playback in my band’s live sessions. I am having a problem with high CPU usage.
The operating mode of the AVB interface is currently 64 \ 64. And you can’t change it.
The system reserves power data for the computer by pre-loading the processor, sysmon say 80-90% of 400%. I have 4 core processor. Macbook Pro 2014 i7 4core.
In this case, a very significant heating of the processor and the entire laptop as a whole occurs. There is a slowdown in the rest of the processes.

Is it possible to somehow set the AVB operation mode not only 64 \ 64 but also for example 8 \ 8 or 16 \ 16 or 32 \ 32?

After all, you do not always need to transfer 128 channels back and forth, most often a substantially smaller number of channels is sufficient for this.
For me at the moment this is a very significant problem. In parallel to starting the play back from Studio One to StudioLive via AVB, I use the channel strip to send some signals from SludioLive to Studio One and process them with VST and return them to StudioLive. This additionally takes processor time, and when working with a minimum delay of 64-128 buffers, it all works perfectly in conjunction. But due to the high processor load of AVB streams, it is not always possible to use the functions I need.

I very much ask the developers to add functions for choosing the AVB operating modes (8 \ 8, 16 \ 16 .... 64 \ 64) Previously, the AVB operating mode was 56 \ 56 and the processor load was slightly less than now, and there were problems with freezing and drop Out on the same project did not appear. Now when you turn off AVB, the problem goes away completely, the processor is significantly unloaded. But it’s worth connecting the cable, the processor load is again greatly increased.

hardly anyone uses this functionality in the same mode as me (8-17 channels of multitrack playback and VST processing on microphones), which is probably why I only write about the problem

thanks

Studiolive 24R / Mac Book Pro 15 2014 / Mikrotik WiFi router / Studio One 4.6.1 / XR18 /
User avatar
by AlexTinsley on Wed Feb 26, 2020 5:08 pm
Running that many channels on your 2014 MacBook Pro will definitely make your system hot. Your system is turbo speeding up and then it's throttling because it's getting hot.

Short of trying to super cool your notebook, you could drop your AVB I/O configuration from 64x64x8 to 16x16x8 however you're system is still going to run warm and increase your latency to not put so much load on the system. Your mileage may vary with this tweak. Treat this as experimental / not supported.

1) Open Universal Control, under Settings click on AVB Audio Configuration
2) Open the AVDECC Configuration Utility in UC Surface.
3) Go to Window menu drop down
4) Select Audio Entity Configuration
5) Click on your Computer
6) Change the current configuration drop down from:
- 64 in, 64 out, 8 ch streams to 16 in, 16 out, 8 ch streams
7) You will be prompted to approve the configuration change.
8) Click on Window again and select AVDECC Connection Matrix to change your Ins and Outs.
9) Open Studio One / DAW and remap your Audio I/O to match the new configuration.
User avatar
by golishevsky on Thu Feb 27, 2020 7:50 am
Your method doesn't work. The fact is that the connected avb device still remains connected in 64/64 mode and consumes a lot of system resources. Moreover, I could not connect the threads in the matrix, I get an error.

In setup mode, you can only use a virtual device with 16/16 mode, but studiolive still remains connected in 64/64 mode and consumes a lot of system resources. There is still no possibility to choose the configuration of the operation - only one "configuration 0" Processor is loaded by the "coreaudioid"process.

Studiolive 24R / Mac Book Pro 15 2014 / Mikrotik WiFi router / Studio One 4.6.1 / XR18 /
User avatar
by SwitchBack on Thu Feb 27, 2020 8:22 am
Have you tried using usb instead? If that doesn't work for you then you'll probably need a more powerful Mac - as Alex already suggested - because the mixer can't be a 64x64 AVB channels interface for some and less for others.
User avatar
by AlexTinsley on Thu Feb 27, 2020 9:25 am
golishevsky wroteYour method doesn't work. The fact is that the connected avb device still remains connected in 64/64 mode and consumes a lot of system resources. Moreover, I could not connect the threads in the matrix, I get an error.


If you get an error, you'll need to quit Apple AVB Configuration utility and relaunch it. It can be very finicky. In some cases you may need to reboot the computer.
User avatar
by PAE Seth on Thu Feb 27, 2020 10:23 am
golishevsky wroteYour method doesn't work. The fact is that the connected avb device still remains connected in 64/64 mode and consumes a lot of system resources. Moreover, I could not connect the threads in the matrix, I get an error.

In setup mode, you can only use a virtual device with 16/16 mode, but studiolive still remains connected in 64/64 mode and consumes a lot of system resources. There is still no possibility to choose the configuration of the operation - only one "configuration 0" Processor is loaded by the "coreaudioid"process.


There are two methods of AVB connections.

One assumes that the Mixer IS the audio device, the other is the MAC is the AVB audio device.

If you have already enabled the mixer under the first method, you must undo that before attempting the steps Alex presented (which do work).

Using the first method eats up CPU resources, as you have seen. Here is how to fix it:

1. Open Audio MIDI Setup, Press CMD + 3 to open Network Browser
2. Uncheck the Mixer in the device list. This will remove it as an AVB Audio device.
3. Follow the steps above from Alex again.

It may be necessary to reboot after step 2, prior to step 3 just to be safe.

Once you get this working, it should perform a little better, and you will have greater flexibility with the Mac, as you can treat it like another AVB device on the network, but with routing control.
User avatar
by golishevsky on Fri Feb 28, 2020 3:52 pm
SwitchBack wroteHave you tried using usb instead? If that doesn't work for you then you'll probably need a more powerful Mac - as Alex already suggested - because the mixer can't be a 64x64 AVB channels interface for some and less for others.


the only reason why I chose presonus studiolive is that it can be to cling 100m LAN cable. USB has a length limit. I always have a mixing console on stage in the rack case, and as an engineer I’m sitting in FOH with an extended LAN cable. It is very comfortable. Other budget mixing consoles can't do that! even to X32 you can’t just connect a computer via LAN and use it as a play for multi channel playbacks.

Studiolive 24R / Mac Book Pro 15 2014 / Mikrotik WiFi router / Studio One 4.6.1 / XR18 /
User avatar
by golishevsky on Fri Feb 28, 2020 3:53 pm
PreSonus Seth wrote
golishevsky wroteYour method doesn't work. The fact is that the connected avb device still remains connected in 64/64 mode and consumes a lot of system resources. Moreover, I could not connect the threads in the matrix, I get an error.

In setup mode, you can only use a virtual device with 16/16 mode, but studiolive still remains connected in 64/64 mode and consumes a lot of system resources. There is still no possibility to choose the configuration of the operation - only one "configuration 0" Processor is loaded by the "coreaudioid"process.


There are two methods of AVB connections.

One assumes that the Mixer IS the audio device, the other is the MAC is the AVB audio device.

If you have already enabled the mixer under the first method, you must undo that before attempting the steps Alex presented (which do work).

Using the first method eats up CPU resources, as you have seen. Here is how to fix it:

1. Open Audio MIDI Setup, Press CMD + 3 to open Network Browser
2. Uncheck the Mixer in the device list. This will remove it as an AVB Audio device.
3. Follow the steps above from Alex again.

It may be necessary to reboot after step 2, prior to step 3 just to be safe.

Once you get this working, it should perform a little better, and you will have greater flexibility with the Mac, as you can treat it like another AVB device on the network, but with routing control.


I will try to do it as soon as I have time to check it. thanks

Studiolive 24R / Mac Book Pro 15 2014 / Mikrotik WiFi router / Studio One 4.6.1 / XR18 /
User avatar
by wahlerstudios on Fri Feb 28, 2020 5:22 pm
Using DAW Mode would not be a better solution? 128 tracks and more...?

SL16 | 32R | 16R | 3* 16M | SW5E

Apple routers | iPads | Alesis iO Docks | Yamaha S112, S15e, S10e, SM12, SM10 | LD Systems Curv 500 | Galaxy Audio Hot Spots | Mac mini | Lenovo Laptop | Studio One Artist 4.6.1 & Pro 3.5.6
User avatar
by golishevsky on Sat Feb 29, 2020 4:27 pm
I tried to follow the instructions.
in the end, something happened to me. and now studiolive is detected incorrectly. and nothing works at all. everything is broken! return back as it did not work. I tried restarting both the computer and studiolive. PLEASE HELP ME

Снимок экрана 2020-02-29 в 22.46.38.png


I can’t get everything back as it was originally

Studiolive 24R / Mac Book Pro 15 2014 / Mikrotik WiFi router / Studio One 4.6.1 / XR18 /
User avatar
by golishevsky on Sun Mar 01, 2020 11:49 am
i unistall and reinstall UC control and mixer is is displayed correctly in network find tab in audio midi setup
BUT
i check checkbox, the device appears in the list, but after 3-6 sec - the connection is lost, the device disappears from the list, the checkmark in the checkbox itself is removed

what am I doing wrong?

the problem is the same as here
https://answers.presonus.com/24082/cant ... i-with-avb

I couldn’t get the system to work according to your manual. nothing works for me. produces various errors. some kind of squares are green some kind of red (clock). I tried changing the protocols - some of the squares turned green, but there was still no sound. I didn’t understand anything, I sat for 2 hours trying to do something, but I didn’t succeed.

Studiolive 24R / Mac Book Pro 15 2014 / Mikrotik WiFi router / Studio One 4.6.1 / XR18 /
User avatar
by golishevsky on Sun Mar 01, 2020 12:39 pm
PreSonus Seth wrote
golishevsky wroteYour method doesn't work. The fact is that the connected avb device still remains connected in 64/64 mode and consumes a lot of system resources. Moreover, I could not connect the threads in the matrix, I get an error.

In setup mode, you can only use a virtual device with 16/16 mode, but studiolive still remains connected in 64/64 mode and consumes a lot of system resources. There is still no possibility to choose the configuration of the operation - only one "configuration 0" Processor is loaded by the "coreaudioid"process.


There are two methods of AVB connections.

One assumes that the Mixer IS the audio device, the other is the MAC is the AVB audio device.

If you have already enabled the mixer under the first method, you must undo that before attempting the steps Alex presented (which do work).

Using the first method eats up CPU resources, as you have seen. Here is how to fix it:

1. Open Audio MIDI Setup, Press CMD + 3 to open Network Browser
2. Uncheck the Mixer in the device list. This will remove it as an AVB Audio device.
3. Follow the steps above from Alex again.

It may be necessary to reboot after step 2, prior to step 3 just to be safe.

Once you get this working, it should perform a little better, and you will have greater flexibility with the Mac, as you can treat it like another AVB device on the network, but with routing control.


I could not do according to the instructions

"2. Uncheck the Mixer in the device list. This will remove it as an AVB Audio device." its ok (but now I can’t put this checkmark back)

so steps above from Alex again

.................
"7) You will be prompted to approve the configuration change"
yes, approve
"8) Click on Window again and select AVDECC Connection Matrix to change your Ins and Outs"

but here I don’t understand anything at all.
Could you take a screenshot of how it should look

at first I had it

Снимок экрана 2020-02-27 в 16.16.29.png


then I went to the settings of the AVB interface

then I went into the settings of the AVB interface and changed the settings of the stream format to IEK 61883-6(blah blah blah)......

orange squares turned green, but red remained red (media clock input stream, media clock output stream)

what should I do next I did not understand.

Studiolive 24R / Mac Book Pro 15 2014 / Mikrotik WiFi router / Studio One 4.6.1 / XR18 /
User avatar
by PAE Seth on Thu Mar 19, 2020 12:40 pm
Welcome to Apple's AVB. It's not completely stable, nor user friendly. This is why we do not publish guides regarding this setup, because it is not consistent computer to computer.

Based on your last response, this is correct.

Media Clock stream is not used and should be ignored.

I will have to create some sort of guide, as this is a lot of information to write down in a single post. I'll put it on the list..
User avatar
by golishevsky on Thu Mar 19, 2020 2:05 pm
"this is not a bug, it should be so"
apple iCar - "we don’t need a steering wheel - we only move forward"

well. I will wait for it.
but it seems to me it would be much more stable to add switching of the operating mode directly to the mixer, for example, in some tab in UC. In addition to the standard mode 64 \ 64, add for example 8 \ 8 16 \ 16, etc.

Studiolive 24R / Mac Book Pro 15 2014 / Mikrotik WiFi router / Studio One 4.6.1 / XR18 /
User avatar
by ibanez6 on Sat Mar 28, 2020 4:58 pm
Hey guys. Just dropping into this thread as I've recently been keen to play around with AVB again amidst the streaming boom we are having right now and this thread seems the most related.

I have set up my 2012 Macbook Pro as an endpoint and have used Hive to configure everything. I can successfully send audio to \ from the mixer using Pro Tools on my Macbook and all the circles have turned green indicating the connections are all good. However, I'm having consistent audio dropouts which I cannot seem to find a cause. The clock on the mixer is set to internal, and on the AVB configuration, I have the MBP set to clock via Audio Input Stream 1. Also, I am running the latest version of Universal Control and the firmware on my 24R is up to date. I have unchecked the mixer in the audio \ midi setup under browse network audio as well.

Any ideas? Seth if you are still planning to put together that guide, I would definitely appreciate it myself. I know everyone says to use USB, but I have a use case for AVB in my setup and I think there is a lot of untapped potential with this technology still.

Cheers!
User avatar
by golishevsky on Sun Mar 29, 2020 3:33 am
ibanez6 wroteHey guys. Just dropping into this thread as I've recently been keen to play around with AVB again amidst the streaming boom we are having right now and this thread seems the most related.

I have set up my 2012 Macbook Pro as an endpoint and have used Hive to configure everything. I can successfully send audio to \ from the mixer using Pro Tools on my Macbook and all the circles have turned green indicating the connections are all good. However, I'm having consistent audio dropouts which I cannot seem to find a cause. The clock on the mixer is set to internal, and on the AVB configuration, I have the MBP set to clock via Audio Input Stream 1. Also, I am running the latest version of Universal Control and the firmware on my 24R is up to date. I have unchecked the mixer in the audio \ midi setup under browse network audio as well.

Any ideas? Seth if you are still planning to put together that guide, I would definitely appreciate it myself. I know everyone says to use USB, but I have a use case for AVB in my setup and I think there is a lot of untapped potential with this technology still.

Cheers!


I have problems with dropout with S1 since version 4.5 **. Before that, it seemed 3.5.1 and there were no problems with the buffer in 64-128. Now with any buffer size there is a dropout and I could not identify the problem. The problem lies in another algorithm for using processor cores, I see no other reasons.

Studiolive 24R / Mac Book Pro 15 2014 / Mikrotik WiFi router / Studio One 4.6.1 / XR18 /
User avatar
by roblof on Fri Apr 03, 2020 10:06 am
This is actually totally possible on the x32 using three different options, not counting a 2nd x32.

1) dn-9630. This will give you 48by48 channels over cat5 and aes50.

2) x-dante. This will give you 32by32 channels over standard ethernet using the dante protocol.

3) x-wsg. This will give you 32by32 channels over standard ethernet using the Waves Soundgrid protocol.

golishevsky wrote
SwitchBack wroteOther budget mixing consoles can't do that! even to X32 you can’t just connect a computer via LAN and use it as a play for multi channel playbacks.

Behringer Wing, iMac late 2015, Behringer X-Touch, X-Touch ONE, M-Air mr18, X-Air xr18, x32 with Dante/aes67, x32-rack with Dante/aes67, s16 and sd16 stageboxes, p16 monitor system, TurboSound iQ-speakers, Waves x-wsg with SoundGrid server, Motör 61, BCR-2000, StudioLive 24, FirePod 10, Apogee Ensemble, Alesis HD24, Studio One Pro v4, Notion 6, NI Komplete 11 Ultimate, Halion 6, Nuendo 10, Ableton Live 8 Suite, Reaper 4, misc Line6 gear/software, True Temperament Frets on basses and guitars, Korg Kronos, Roland vk-7, Behringer Deepmind 12, Behringer Neutron, Yamaha 02r.....
User avatar
by golishevsky on Fri Apr 03, 2020 3:54 pm
roblof wroteThis is actually totally possible on the x32 using three different options, not counting a 2nd x32.

1) dn-9630. This will give you 48by48 channels over cat5 and aes50.

2) x-dante. This will give you 32by32 channels over standard ethernet using the dante protocol.

3) x-wsg. This will give you 32by32 channels over standard ethernet using the Waves Soundgrid protocol.

golishevsky wrote
SwitchBack wroteOther budget mixing consoles can't do that! even to X32 you can’t just connect a computer via LAN and use it as a play for multi channel playbacks.


this will not allow me to simply connect my laptop to the mixing console without any adapters.
I'm not prepared to spend a bunch of dollars buying an adapter I don't need when it can all work perfectly without it. however, at the moment it has stopped working perfectly. I hope this is temporary.

Studiolive 24R / Mac Book Pro 15 2014 / Mikrotik WiFi router / Studio One 4.6.1 / XR18 /
User avatar
by SwitchBack on Fri Apr 03, 2020 7:30 pm
roblof wroteThis is actually totally possible on the x32 using three different options, not counting a 2nd x32.

1) dn-9630. This will give you 48by48 channels over cat5 and aes50.

2) x-dante. This will give you 32by32 channels over standard ethernet using the dante protocol.

3) x-wsg. This will give you 32by32 channels over standard ethernet using the Waves Soundgrid protocol.

golishevsky wrote
SwitchBack wroteOther budget mixing consoles can't do that! even to X32 you can’t just connect a computer via LAN and use it as a play for multi channel playbacks.

Did I say that? I never knew I said that. What did I know about the X32 I don't know I knew? :lol:
User avatar
by golishevsky on Wed May 27, 2020 2:15 pm
Several months passed, but no one helped me. Really everyone has super powerful computers, and everyone uses 128 channels ... I could not solve the problem.
Your suggested methods do not work. Stream routing is not prescribed. Khiva does not see the interface created by a checkmark in the checkbox at all.

Снимок экрана 2020-05-27 в 23.05.04.png

Studiolive 24R / Mac Book Pro 15 2014 / Mikrotik WiFi router / Studio One 4.6.1 / XR18 /

23 postsPage 1 of 2
1, 2

Who is online

Users browsing this forum: No registered users and 1 guest