Page 1 of 1

Faderport 8 MIDI MODE is Not Working

Posted: Wed Feb 19, 2020 3:08 am
by muziksculp

I noticed there is a new MIDI MODE that I can switch my FP8 into at startup, so I was very happy and optimistic it will work as advertised. But ... It sadly doesn't work. I'm using Studio One Pro 4.61

The MIDI Monitor in Studio One shows the Faders are transmitting the correct MIDI CCs, but they don't seem to reach the VST, or HW Instrument. Something is broken. The only message that worked for me was PAN. which is MIDI CC 10 assigned to Fader 4 , but works a bit strange in terms of where in the fader's movement the values change for PAN.

All other CC #s that are Pre-Assigned to the faders don't do anything to the target VST Instruments, or HW Synths.

The Faders are Pre-Assigned according to the documentation as follows :

F1 = CC 1
F2= CC 11
F3= CC 7
F4= CC 10
F5= CC 5
F6= CC 84
F7= CC 2
F8=CC 16

Anyone able to get MIDI MODE to work ? Any feedback would be appreciated.

If this is a broken functionality, hopefully Presonus will fix it ASAP, since it is a very useful feature to have in the FP8/16.


UPDATE : I also checked if I needed to update my Firmware and Universal Control, I had to update both to the latest versions. But again, MIDI MODE is not working.

Re: Faderport 8 MIDI MODE is Not Working

Posted: Wed Feb 19, 2020 12:26 pm
by bastiaanmarcscholtemeijer
I have reported this issue to Presonus twice (2nd time 2 weeks ago) and its confirmed to be a bug that will need to be fixed in an update of UC and/or perhaps Faderport firmware. Unfortunately no indication as of when that may be :(

I know this does not help you, but I am glad to see I am not the only one with this issue. I am doing the exact same thing as you using Kontakt libraries. But there is a work around in Native Mode. I have tested this extensively, and found this is the only way to make it do what we want (i.e. send MIDI CC data to VST's).

Check my post (at the bottom) of this thread: viewtopic.php?f=337&t=24034

The only downside is that this reveals another issue: the Faderport MIDI CC data will only be sent to MIDI channel 1 of the selected track. Meaning, you can have a Kontakt instance with 10 instruments, each configured to use MIDI channel 1 to 10, but only the instrument using channel 1 will get MIDI CC data.

If you are layering instruments this way its not an issue (simply use channel #1 for all.. ) but for efficiency sake (i.e. using Kontakt in a multi instrument setup per instance) this is a big limitation, since you will need a separate Kontakt instance for each track.

This will of course use more system resources, and, added bonus: will increase load & save times quite a bit. But since I want to use my FP8 for sending modulation and expression.. this is something we have to live with at the moment.

In my case it results in 160-180 Kontakt instances per project.. which resulted in me stepping away from using orchestral templates and just load "on the fly", plus disabling the auto-save feature which is enabled by default to 5 minutes.

Get ready to press Ctrl-S often :roll: ;)

Btw, I wonder if other DAWs experience the same behavior.. never tested in Cubase, Reaper, etc.

EDIT: Just checked my old forum post about this issue, and saw it was around May 2019 I reported this initially. So I guess this is not high up the priority ladder.

Re: Faderport 8 MIDI MODE is Not Working

Posted: Wed Feb 19, 2020 1:40 pm
by muziksculp
HI bastiaanmarcscholtemeijer,

Thanks for the feedback. I'm aware of this functionality, but It's not what I need. I basically want to assign my Faderport's faders to send CC# 1, 11, 10, 21, ...etc. and have them always do that, regardless of which VST, or HW Synth I select in S1.

I'm surprised that this type of MIDI-CC functionality is still not available/working for the Faderport 8/16. Hopefully they are going to fix it soon, the sooner the better.


Re: Faderport 8 MIDI MODE is Not Working

Posted: Thu Feb 20, 2020 2:58 am
by bastiaanmarcscholtemeijer
If you follow the link I've sent, you can basically assign any MIDI CC to any fader, as long as you can do it via Control Link (meaning: only for visible elements in VST's). And this will be in native mode, not midi mode.

It just has the limitations I mentioned re your choice of Sampler - Kontakt was just my example..

Re: Faderport 8 MIDI MODE is Not Working

Posted: Thu Jan 14, 2021 6:43 am
by tonkerkhof
I work with Protools 12 on Catalina. My Faderport 8 works fine, but not in midi-mode. It doesn't send cc's to Protools. The FP has version 3.44. Anyone who can help me?

Re: Faderport 8 MIDI MODE is Not Working

Posted: Thu Jan 28, 2021 4:51 pm
by stephannimtz
hi all, same problem here.
not getting any midi data in midi mode on logic pro x.
need help to control expression and dynamics in spitfires bbcso with fp8.

Re: Faderport 8 MIDI MODE is Not Working

Posted: Sat Feb 13, 2021 6:24 am
by jinxchin
Hi all,

When the firmware was at one of it's most early iterations, the CC control actually worked, and last year when I updated to the latest firmware at that time, the CC control functionality got more elegant and I was quite happy with it, but then within the last couple of firmware updates, all the CC controls disappeared.

I'm now on 3.44 firmware and now it seems like the control of plugins has devolved into something much less intuitive than before (not that it was that intuitive before, but I kind of grew into the workflow).

I'm pretty sure folks who work with Studio One probably don't have any of these woes at all, but I'm a Cubase person and at the current firmware, aside from the regular play stop and adjusting the faders for volume and pan, the unit is pretty much useless for more involved control.

Re: Faderport 8 MIDI MODE is Not Working

Posted: Tue Jun 08, 2021 5:29 am
by peterdebeer
I have the same issue - FP16 doesn’t send data in Midi Mode to Cubase (v10.5 on Mac Catalina).
Also unclear if all Transport Controls are disabled in Midi Mode?
This function (firmware 3.44) is starting to look like a not well planned/ tested afterthought.

Re: Faderport 8 MIDI MODE is Not Working

Posted: Sun Jul 18, 2021 12:11 am
by bastiaanmarcscholtemeijer
I would suggest you open your MIDI monitor equivalent in Cubase (something to see the messages coming in & out) and start pressing buttons or moving faders.

If nothing shows up I'd say either a) no messages arrive, or b) a configuration issue with the FP in the DAW).

Remember that MIDI mode takes a different device (MIDIIN2 and MIDIOUT2) than for MCU or Native SO mode.