FaderPort 8 and FaderPort 16 General Discussion
9 posts
Page 1 of 1
Hello everybody,

I'm new to this forum so I don't know if this has already been discussed.

I find Faderport useful as a Mackie controller but I find its MIDI mode very frustrating.

First of all you can send MIDI values from the faders to the DAW but if you try to update the faders from the DAW values, the faders are not updated correctly, which is one of the points of having motorized faders in the first place...Here's a long video where I explain in detail what is happening:
https://user.fm/files/v2-18550f7a42d1cf ... roblem.mp4
(jump to minute 3:10 to skip the setup and see what is not working)

Second, I mainly use the MIDI faders to control expression parameters for string ensembles, winds etc. As a result, I need to play, stop, record all the time while I move them however the play, rec, stop, rew, ffd buttons are not working as usual in MIDI mode and can't even be mapped to normal MIDI CC parameters.

Any help would be appreciated.
User avatar
by Trucky on Sun Jul 18, 2021 9:06 pm
Welcome to the forum!
Are you using the latest FaderPort 8 firmware?
Any reason why you're not just using native Studio One mode and the [Edit Plugins] button, transport, etc. for this?
It's nice to have many of these mappings already done for many of these effects.

Also, don't forget Link mode. When [Link] is enabled, the Pan / Param encoder will control any parameter beneath your mouse. To lock a parameter to this encoder, press SHIFT + [Link].

Please add your specs to your SIGNATURE.
Download the STUDIO ONE 5 PDF MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 10 Pro 64-bit (21H1), Studio One 5.3 Pro | Notion 6.8.1 | Universal Control v3.5.2.65533
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
StudioLive Series III 32 v2.5.17953
User avatar
by fl16 on Mon Jul 19, 2021 2:22 am
Trucky wroteWelcome to the forum!
Are you using the latest FaderPort 8 firmware?

Thanks! Yes I'm using the latest firmware.

Trucky wroteAny reason why you're not just using native Studio One mode and the [Edit Plugins] button, transport, etc. for this?
It's nice to have many of these mappings already done for many of these effects.


Those problems in the MIDI mode are also present in the native Studio One mode but, regardless of that, there are several reasons for me to not use the native mode and Edit Plugins functionality:
1) I still have to use Cubase in many projects. Studio One still misses critical features for complex projects. So I switch quite often between Studio One (to play live or in simple recordings) and Cubase (orchestral scores). It is too time consuming to switch my Faderport between Mackie mode and native mode all of the time.
2) I need the plugin parameters to be predictable and adapted to my personal needs, so the default mappings don't suit me always. In particular I always map 4 parameters to the same faders to be able to develop muscle memory.
3) I often record a MIDI part and change instruments later to test different sounds or double certain melodies. It is essential that the parameters are recorded with the same MIDI CC data to be able to change the plugin and get the same or a similar expression.
4) Last and not least, standards are useful and I want to be able to use the same gestures in different DAW's. Proprietary gear is often a waste of time, particularly when products get discontinued. Mackie and MIDI are simply excellent and work with all DAW's and external hardware! No DAW is perfect so I will always need to use different ones for different environments. I also need to share projects with people working with other DAW's. Actually, Presonus also benefited from this: I started using Studio One because I was looking for a Mackie controller for Cubase and I got a free license with my Faderport.

Trucky wroteAlso, don't forget Link mode. When [Link] is enabled, the Pan / Param encoder will control any parameter beneath your mouse. To lock a parameter to this encoder, press SHIFT + [Link].


Thanks for that but both of my hands are busy already to take care of the mouse: one is on the MIDI keyboard and the other one on the faders 😅
User avatar
by Trucky on Mon Jul 19, 2021 7:31 am
No worries. Have you reported your issues regarding MIDI mode to PreSonus support?
If not, I'd recommend submitting a Support Ticket (see link below) or creating a Feature Request.

Here's a PreSonus FaderPort 8/16 MIDI Mode setup and how to use video:
phpBB [video]

Please add your specs to your SIGNATURE.
Download the STUDIO ONE 5 PDF MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 10 Pro 64-bit (21H1), Studio One 5.3 Pro | Notion 6.8.1 | Universal Control v3.5.2.65533
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
StudioLive Series III 32 v2.5.17953
User avatar
by fl16 on Tue Jul 20, 2021 3:28 am
Trucky wroteNo worries. Have you reported your issues regarding MIDI mode to PreSonus support?
If not, I'd recommend submitting a Support Ticket (see link below) or creating a Feature Request.

I did. They basically encouraged me to buy another device (from another company, I guess) and closed the ticket.

Trucky wroteHere's a PreSonus FaderPort 8/16 MIDI Mode setup and how to use video:
phpBB [video]

I watched the video and I don't think that I have missed any steps.
Here you can see in detail how I set it up: https://user.fm/files/v2-18550f7a42d1cf ... roblem.mp4
User avatar
by Trucky on Tue Jul 20, 2021 6:10 am
Thanks for reporting back and yes the setup steps in your video looks correct to me. Please note that direct comments from your support ticket were removed as that's not allowed in the forum.

Here's what I found (per the latest manual) in regards to why the FaderPort 8 is not receiving communication back from the software:
Image

I don't know if there's plans to change the implementation but you can always submit a Feature Request for this or vote it up if one already exists.
https://answers.presonus.com/search?q=faderport+feature+request

Please add your specs to your SIGNATURE.
Download the STUDIO ONE 5 PDF MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 10 Pro 64-bit (21H1), Studio One 5.3 Pro | Notion 6.8.1 | Universal Control v3.5.2.65533
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
StudioLive Series III 32 v2.5.17953
User avatar
by pauldecesare on Wed Jul 21, 2021 6:43 pm
The transport controls don't work in MIDI mode, why is there discussion about firmware updates, etc etc? MIDI mode gives you preset CC numbers, there's NO programming and transport is disabled. Now of course you want motorized off when doing CC Expression, etc, but you have to stay in MIDI mode, don't hit both Shift buttons and go to DAW mode because the faderPort 8 WILL pick up where your channel faders are and move them there. That in itself is OK, but when you switch back to MIDI mode, there is NO memory of the CC faders plus the motorized is turned off. So your CC positions are totally messed up. You have to commit to MIDI mode and keep it there, and you have to MIDI-Learn everything in your library to match the hardcoded CC numbers in the FaerPort, nd you have no transport. This was a nice thing to try and bring us CC control for free, but unless those issues are fixed, it's not actually usable. Thats'a shame, because those 100mm faders for CC Expression are WONDERFUL, but the limitations and the huge footprint for three CC faders kills it.

I submitted a product idea to PreSonus for a 4-fader 100mm MIDIPort in the same case as the FaderPort, but I got told that submitting a product idea was in violation of something. Wow. The members of the VI-Control website went bonkers over the idea but PreSonus told me, it's customer, that I was in violation. Whatever.

Current rig (and if I can't produce decent music with this I need serious help):
14-core i9-7940X | MSI M7 ACK Mobo | 128GB Ballistix RAM | EVGA GTX 1080 | Four NVME SSDs for Libraries, OS | Studio One Pro 4 | EWHO & Choirs, EWSO & Choirs, SD3, EW Pianos, Spaces II | Berlin Strings/Brass/Inspire 1 & 2/Time Macro | NI KU11 | M-Audio CODE 61 | PreSonus Studio 192 Mobile pushing Eris E5s & T10 sub | PreSonus FaderPort 8 | AudioQuest Forest digital USB Cables | Two analog gems: AKG C414 XLS Mic, Taylor 618e v2
User avatar
by fl16 on Thu Jul 22, 2021 5:38 am
Thank you Trucky, it was a very helpful post. I had missed that part from the manual.

Trucky wroteI don't know if there's plans to change the implementation but you can always submit a Feature Request for this or vote it up if one already exists.

Here are the links for the Feature Requests:

(I encourage those who believe like me that those are important features to vote for them!)

Make MIDI mode exclusive to faders (i.e. enable transport buttons ) + Friendlier MIDI mode shortcut
https://answers.presonus.com/62639/excl ... r-shortcut

Motorized faders in MIDI mode (to react to the CC values set from the DAW)
https://answers.presonus.com/62143/moto ... om-the-daw
User avatar
by Trucky on Thu Jul 22, 2021 8:29 am
I agree @fl16 and voted for both of them.

Please add your specs to your SIGNATURE.
Download the STUDIO ONE 5 PDF MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 10 Pro 64-bit (21H1), Studio One 5.3 Pro | Notion 6.8.1 | Universal Control v3.5.2.65533
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
StudioLive Series III 32 v2.5.17953

9 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest