Discuss the new PreSonus CS18Ai
38 postsPage 2 of 2
1, 2
Jason,

I'd like to thank you for taking the time to respond and would also like to expose my problem to you as well.

We recently acquired a CS18ai, Rm32 and Studio One 3 for our studio (rehearsal, live recording and music production studio).

I followed all the advice, watch a lot of videos, read a lot of documents and completed the installation as required however i still can't get the system to function correctly.

Allow me to describe my set up a little:on the network side I have a Router connected to the internet, a MOTU AVB switch, RM32, CS18ai and an iMac. I also have an iPad.
The RM32, CS18ai, Router and iMac are all connected to the AVB switch via Ethernet cable (CAT6). The router provides DHCP. The RM32 is also connected to the iMac via a Firewire cable. The ipad connects wireless to the Router. The wifi dongle on both the RM32 and CS18ai are removed.

I switch ON the router and the switch first and wait 5 minutes before switching ON (in this order) the RM32, the CS18ai and finally the iMac.

Some days i can control the RM32 from the cs18ai most days i can't. Power cycling many times sometimes yields results sometimes it doesn't. The UC control software from the iMac controls the RM32 everytime as it sees it as a firewire device.
On the UCNET menu, the CS18ai sees the RM32 and when i start Studio one 3 on the computer it sees that as well.
The ipad also controls the RM32 correctly. All my firmwares are up to date have tried many approaches to solve my problem.

The first approach was to reserve IP's on the Router for the CS18, RM32, iMac and iPad so that they would not get different ip's each time they were switched on, that changed nothing.

The second approach was to in addition to the reserving IPs on the router to assign static IPs on the CS18ai, RM32, iMac and Ipad that matched those reserved for them on the router. this worked the first day i configured it (i had control of the cs18ai from iMac and iPad and could also control the RM32 from the cs18ai), but stopped the next day. One very odd behavior was that I stored a scene with all my mixes and settings and named and saved it, the next day it had disappeared.

This is where i stopped trying different things and started pouring into the forums a little more to check for any solutions.

Today the CS18ai would not work at first with the RM32 not could the the software control the CS18ai (not is DAW). after a few times power cycling the cs18ai, it just came to life and everything started functioning the way it should up until i could not hear a few on my instruments despite their faders being lifted and assigned correctly. after looking a while longer I discovered that the UC surface on the iMac had a mute of those faders, and the CS18ai was not showing the mute as active nor was it removing the mute when i press the button. i had to remove the mute from the software first and then only was i able to use the mute button successfully on the CS18ai.

Your help in solving this would be very welcome as we are a small business and we have invested all our hard earned money into this setup and as things stand we are not able to reliably say to our future customers that we provide recording services if we can't rely on our equipment.

Oh and by the way, our studio is located in Nigeria, Lagos, we acquired our Presonus gear via their local agent and we do not enjoy the 30 days return your gear if not happy option.

Regards,

Marwan
User avatar
by gregorbeyerle on Sun Jul 10, 2016 3:46 pm
rhrmusic wroteI called Tech support and in a few minutes found out it was the firmware that needed fixing. I changed the CS18AI firmware from public 7055 to the Beta firmware version 2. Once that was updated, I went to UCNET and Wired IP then selected Static Self Assign to get the IP address for this direct ethernet connection between CS18AI and my PC. Next I set the Software control to my Studio One. After that, I had perfect control of faders and no latency at all in any of the other controls. There are a few small issues that I'm sure will be addressed on the next public firmware.

I hope other customers can read this and know what to do. Download the Beta firmware (version 2 at this time) and the unit will work as expected.

It was frustrating to have to debug a product that should have been working out of the box. Failing that, all registered owners should receive an email upon registration telling them to download the proper firmware whether it be public or beta. Presonus dropped the ball here pushing the CS18AI to market to capture market share over customer satisfaction.



Hi,

I have exactly the same problem as you described. Extremely laggy graphical response in Studio One when I move the faders on the CS18AI for instance.

So...WHERE CAN I DOWNLOAD BETA FIRMWARE 2? I absolutely looked everywhere but cant find it. Any pointers would be greatly appreciated!!

System Info: Mac Mini 2018 (10.14.6 Mojave) with Blackmagic eGPU, MacBook Pro 2017 (10.14.6 Mojave), Razerblade Stealth (Win10), i7 Quad PC (Win10)
User avatar
by matthewgorman on Sun Jul 10, 2016 4:49 pm
These posts are a bit dated. The versions referenced are now public releases, and is now 2 versions old. There is no current public beta runnng. Public betas will happen just prior to an official firmware release, after the firmware has been through private beta first.

The latest firmware version out there is 8591, and is available in your presonus account.

Provide us with some more details on your system, how its hooked up, and software and firmware versions, and there is a good chance we can help. Option 2 would be to open a support ticket.

Matt

Lenovo ThinkServer TS140 Win 10 64bit, 8GB RAM, Intel Xeon
Lenovo Thinkpad E520, Windows 7 64bit, 8 GB RAM, Intel i5 Processor

S1Pro V5
User avatar
by gregorbeyerle on Mon Jul 11, 2016 12:01 pm
Hi Matthew, thanks for the info! I'm running Windows 7 64bit with Studio One version 3.2.3, also 64bit. I now have my computer hooked up via cat5 ethernet cable to my router, same for the CS18AI. The CS18AI is running the latest firmware, which I now figured thanks to your info ;)

I really don't know how much latency is normal for such a configuration, however the latency is very audible to me (especially when making fast volume changes with the faders). I do have to note though that the latency seems kind of one-sided if that makes any sense -
for instance, if i move a fader with my mouse, the CS18AI would follow along very smoothly and fast, also the numeric values in the CS18 display would change very quick according to my movements, even when they are quite rapid. However, when going the other way, e.g. moving a fader upwards on the CS18AI, would make for a quite sluggish response on my studio one mixer, which is also audible. Putting a fader up and down on my CS18AI I am almost guaranteed to get a glitch at least once or twice in Studio One.

System Info: Mac Mini 2018 (10.14.6 Mojave) with Blackmagic eGPU, MacBook Pro 2017 (10.14.6 Mojave), Razerblade Stealth (Win10), i7 Quad PC (Win10)
User avatar
by matthewgorman on Mon Jul 11, 2016 12:23 pm
I will take a look tonight. I don't make very rapid moves, so I can't say for sure if its happening on my system. Add that to the fact that my current projects are nearing completion, with very small moves, so I really don't see it right now.

I will check and report back.

Matt

Lenovo ThinkServer TS140 Win 10 64bit, 8GB RAM, Intel Xeon
Lenovo Thinkpad E520, Windows 7 64bit, 8 GB RAM, Intel i5 Processor

S1Pro V5
User avatar
by gregorbeyerle on Fri Jul 15, 2016 8:35 pm
Hi Matthew,

did you find the time to look into this yet?

Thanks and all the best!

System Info: Mac Mini 2018 (10.14.6 Mojave) with Blackmagic eGPU, MacBook Pro 2017 (10.14.6 Mojave), Razerblade Stealth (Win10), i7 Quad PC (Win10)
User avatar
by matthewgorman on Mon Jul 18, 2016 9:27 am
Did look in to it, just forgot to reply. Sorry about that. I notice a very slight lag on rapid movements on both the RM and Studio One, but its nothing that has ever affected me for what I am doing. I tend to write my automation in S1 with the transform tool, and any fader moves I do outside of automation aren't needed in realtime.

What are you doing where it affects you the most? Is everything on the most current version? Sometimes things like this can be exaggerated when the versions are different.

Matt

Lenovo ThinkServer TS140 Win 10 64bit, 8GB RAM, Intel Xeon
Lenovo Thinkpad E520, Windows 7 64bit, 8 GB RAM, Intel i5 Processor

S1Pro V5
User avatar
by nostrillaflamme on Mon Dec 12, 2016 8:03 pm
In case this helps others. Bought cs18ai yesterday and even after updating to firmware 9032 couldn't connect to MacBookPro with direct ethernet cable.
Solution: Got the cs18 to create it's own static IP - write this down.
On Networking tab of MBP, select manual ethernet. Set the IP to the same as the CS18 creates for itself except add one to the last digit. For example: cs18 x.x.x.49 and for the MBP x.x.x.50.
For the subnet mask, 255.255.0.0 and leave the router field blank.
After about 20 secs the cs18 found studio one 3 (v3.3.2) and all's good.
The only other thing was that I had to insert a switch (not a hub) between cs18 and the MBP.

Close call as I was about to return it!
User avatar
by bubbaguth on Mon Dec 12, 2016 9:05 pm
@ nostrillaflamme

This seems like a big hassle and you are making it more difficult than it needs to be. Do yourself a favor and obtain a router (not a switch) that will manage IP addresses for you via DHCP - most routers have this enabled right out of the box, or you can read the router manual and figure out how to do it. Your computer and CS18 will be happy to obtain their IP addresses from the DHCP server that is enabled and configured from your router. This is how 99% of computer networks work and your CS18 is really no different than a computer. Just to be fair then, the issues you were having are no fault of the CS18, it's how networks work.

Your way will work, but it's not necessary and simply ends up to be extra work for no benefit and will get even more unmanageable as you add devices.

RM32AI, RM16AI, CS18AI, SL16, 32R, NSB 16.8, 328AI, 18sAI
MOTO AVB and 5WSE Switch
NowSonic Stage Router Pro
Microsoft Surface Pro
Apple iPad Pro
Macbook Pro
User avatar
by hraudio on Thu Dec 29, 2016 3:46 am
bubbaguth wroteYour way will work, but it's not necessary and simply ends up to be extra work for no benefit and will get even more unmanageable as you add devices.


I am not a technical person when it comes to network settings etc... but after I followed Nostrillaflamme's advice It was easy for me to setup manually an ip-address.

I now have my CS18ai connected directly to my iMac with a cat5 cable. No switch involved just a straight connection.
Removed the wireless dongle and the response of the faders is absolutely great. :D

Hans
User avatar
by gregorbeyerle on Sun Feb 05, 2017 6:40 am
Hi Hans,

I will try a direct connection from my CS18AI to my PC tomorrow, I only need it for studio one control really. I bought a dedicated PCIe network card and a cat6-cable for this and I really hope that I can solve the somewhat-sluggish response I've experienced with the CS18 so far.

I'd love to know - how do you define "absolutely great" fader response? No audio/graphical lag at all? My reference is the faderport via USB, which responds with absolutely zero lag and the fader on the screen follows along as smooth as it can be...I'd LOVE to have the same kind of responsiveness with the CS18AI.

System Info: Mac Mini 2018 (10.14.6 Mojave) with Blackmagic eGPU, MacBook Pro 2017 (10.14.6 Mojave), Razerblade Stealth (Win10), i7 Quad PC (Win10)
User avatar
by hraudio on Tue Feb 07, 2017 7:31 am
When used via the wireless dongle I found the response a little bit slow although very manageable.
Then connected the Cs directly via ethernet and immediatley I could move the faders more "direct" , so the response has definitely improved..

Note: I found that I have to disable Wifi on the Mac to make the CS18ai recognize S1 when pressing the UCnet button. After the CS18ai has established the connection with the software you can enable Wifi again if necessary.

Hans
User avatar
by Mac Money on Mon Apr 17, 2017 8:01 am
After reading this I really don't know if I want to buy a SC18ai, My current set up is a Windows 10 Pro 64bit w/6-core i7. Running Waves SoundGrid system with an IOS interface. I don't need any switches or routers. It's never failed me. And I was about to buy a CS18ai from Guitar Center but after this I don't know. Where can I find a UP TO DATE setup configuration? I have 2ea. Gig-e ethernet ports on my MB, one goes to the IOS and the other goes to a router for internet.
So that's​ my situation. Will my setup work with the CS18ai?

George Ware
StudioOne v5.1.2 Pro 64bit
Waves SoundGrid Studio 2
Waves DigiGrid IOS
Waves DigiGrid IOX
Waves SoundGrid Server One
PreSonus CS18ai & BCR2000 Control Surface
Intel 6 Core i7 3.2Ghz.
Windows 10 Professional 64bit. v20H2
Arturia KeyLab-88 Essential
URS, Waves v12 (Everything), EMI, Sonnox Oxford (Everything), Antares Unlimited, Plugin Alliance (Everything), Nomad Factory,TL Labs, Massey, Komplete Ultimate 12 CE, Arturia V9 (Everything), Korg Collection, UVI Falcon v2, Melodyne Studio 4.4.2, VocAlign, Eventide (Everything), Softube and IKM Total Studio Max.
As of 4 Feb 21
User avatar
by Mac Money on Fri May 12, 2017 6:05 pm
DEEP Sigh.................I pulled the trigger and bought a CS18ai from Guitar Center.
It will be here (El Paso Tx) this Thuesday May 16th.
I've been reading and looking at every video I can find. :)

George Ware
StudioOne v5.1.2 Pro 64bit
Waves SoundGrid Studio 2
Waves DigiGrid IOS
Waves DigiGrid IOX
Waves SoundGrid Server One
PreSonus CS18ai & BCR2000 Control Surface
Intel 6 Core i7 3.2Ghz.
Windows 10 Professional 64bit. v20H2
Arturia KeyLab-88 Essential
URS, Waves v12 (Everything), EMI, Sonnox Oxford (Everything), Antares Unlimited, Plugin Alliance (Everything), Nomad Factory,TL Labs, Massey, Komplete Ultimate 12 CE, Arturia V9 (Everything), Korg Collection, UVI Falcon v2, Melodyne Studio 4.4.2, VocAlign, Eventide (Everything), Softube and IKM Total Studio Max.
As of 4 Feb 21
User avatar
by lamac23 on Tue Jan 02, 2018 1:55 am
Hello rhmusic. I was reading your post on the CS18AI and understood what you did. However, did you still have the wifi dongle connected to the CS18AI or just the ethernet cable connected? The only way I can get a connection is with the wifi dongle plugged in. I did see the wired IP address on the wired side but no studio one 3 in the software control section unless I inserted the wifi dongle. Just was wondering if I'm missing something. Thank you.
User avatar
by matthewgorman on Tue Jan 02, 2018 9:56 am
lamac23 wroteHello rhmusic. I was reading your post on the CS18AI and understood what you did. However, did you still have the wifi dongle connected to the CS18AI or just the ethernet cable connected? The only way I can get a connection is with the wifi dongle plugged in. I did see the wired IP address on the wired side but no studio one 3 in the software control section unless I inserted the wifi dongle. Just was wondering if I'm missing something. Thank you.


You might be. Can you describe how everything is connected/networked?

Matt

Lenovo ThinkServer TS140 Win 10 64bit, 8GB RAM, Intel Xeon
Lenovo Thinkpad E520, Windows 7 64bit, 8 GB RAM, Intel i5 Processor

S1Pro V5
User avatar
by thierryhervouet on Wed Jun 19, 2019 3:14 am
Hi, I'm in France, I'm also a good Presonus Customer... I have 32.4.2 ai, CS18 and RML32ai... I had also network's problems with my CS18.... I crashed my connection last week, suddenly.... In fact I made a BIG MISTAKE that everyone here must be informed : If you have a WIRED connection, you must not avec WIRELESS connection too ! So I think about my Network and started it again from the begining... And today it seems to be working without any trouble... So for those who wants to set their network here is my configuration :

RML32ai (no wifi dongle plugged in) connected to an AVB SWICHT (Motu), my laptop is also connected to the AVB SWITCH and my CS18ai Also. I have a wireless router (TP LINK who is connected to the AVB switch on the "E" (Ethernet) port... so I can also connect my I pad to this network.
The RML is in Dynamic mode for the IP ADRESS and the CS18 is also in Dynamic mode...
Every components can connect to the RML, the digital returns of my CS18 is OK and the talkback too.
I hope this will be helpful for someone.... And if there are french people on this forum you can contact me
User avatar
by gbam55 on Wed Jun 19, 2019 4:05 am
thierryhervouet wroteHi, I'm in France, I'm also a good Presonus Customer... I have 32.4.2 ai, CS18 and RML32ai... I had also network's problems with my CS18.... I crashed my connection last week, suddenly.... In fact I made a BIG MISTAKE that everyone here must be informed : If you have a WIRED connection, you must not avec WIRELESS connection too ! So I think about my Network and started it again from the begining... And today it seems to be working without any trouble... So for those who wants to set their network here is my configuration :

RML32ai (no wifi dongle plugged in) connected to an AVB SWICHT (Motu), my laptop is also connected to the AVB SWITCH and my CS18ai Also. I have a wireless router (TP LINK who is connected to the AVB switch on the "E" (Ethernet) port... so I can also connect my I pad to this network.
The RML is in Dynamic mode for the IP ADRESS and the CS18 is also in Dynamic mode...
Every components can connect to the RML, the digital returns of my CS18 is OK and the talkback too.
I hope this will be helpful for someone.... And if there are french people on this forum you can contact me



Thanks for your post. Personally, I disable WiFi on my Mac when connected FireWire for recording and don’t usually use any dongle. I start up the Rm32ai first then the Mac & only then the router otherwise the Rm connects via the router and not FireWire. Then I power on the Cs18ai after the rooter is fully powered up.

Cheers, santé

Presonus StudioLive 16.4.2, 16.0.2 (x2), Studiolive mobile, Mac mini i7 Quad core, 16GB, MacBook Pro 2012 (1T Ssd & with all the Ports you need) Studio One Professionnal. Mélodine editor, Fader Port, StudioLive RM32-AI, CS18-ai, KRK VTX4 monitors and KRK 10s.
KRK 10 3 monitors. Yamaha O1v, KRK rokit 10 3 monitors. RCF 725-II PA and RCF 325 stage monitors. Turbosound TQ425/455 DP PA.

38 postsPage 2 of 2
1, 2

Who is online

Users browsing this forum: No registered users and 1 guest