2 posts
Page 1 of 1
Anyone else getting a legacy update from MAC showing that the software will be outdated with the newest version of IOS? Been hesitant to update my MAC for that exact reason cause I don't want to have to go through the trouble of deleting my entire MAC again (like I had to to with my old eleven rack because Pro Tools basically said screw you to old eleven rack users). Wondering if Presonus knows about this and if they do, is there a software update coming to keep the audio interface compatible.
User avatar
by henrinagelhout on Wed Nov 18, 2020 1:52 am
Your mac doesn't run on iOS but on macOS. (iOS is for your phone, not your laptop/desktop)
And yes some software will stop working with a new version of macOS.
If it's non presonus software you're talking about, then the only thing you can do is to update that software to a version that supports the latest macOS.
And if there's no update available for the software, your best option is to stick with the current version of macOS.

As for the Audiobox iOne/iTwo. These interfaces are class compliant.
Basically this means that they will work on macOS and your DAW without any drivers/software.
So if you are talking about Universal Control, it is not necessary to install this.
But afaik the current version of Universal Control works on macOS 11.0.1, as does studio one 5 and notion 6.


PC: MacBook Pro 13" (2016), i5-6267U, 8Gb RAM, 512Gb SSD, macOS Big Sur 11.0.1
Interface: Audiobox iTwo | MIDI: Nektar Impact LX61 | Monitors: Eris E5 | DAW: Studio One 5.1.1 Pro
Plug-Ins: Amplitube 4, Komplete 11 Select, Melodyne 5 Editor, Superior Drummer 2.0, and various freebies

2 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest