3 posts
Page 1 of 1
I have found that the only way for me to access the unit through a PC and Universal Control is by using an all USB 2.0- chain. As soon as USB 3.0 is involved either as cable or port, the unit does not show up. You have hook it up to a PC with 2.0-ports and use a cable clearly marked USB 2.0.

Seen some posts about this and just wanted to share how I made it work.

Regards,
Joakim
Last edited by joakimmller on Tue Feb 05, 2019 12:57 am, edited 2 times in total.
User avatar
by Trucky on Mon Feb 04, 2019 9:27 pm
Thanks for sharing your results!

Please add your specs to your SIGNATURE.
Download the STUDIO ONE 5 PDF MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


Windows 11 Pro 64-bit (21H2), Studio One 5.4 Pro | Notion 6.8.1 | Universal Control v3.6.0.66460
Dell Inspiron 17 5770 (Intel Core i7-8550U 1.8 GHz, 4GB AMD Radeon 530 Graphics, 16GB RAM, Samsung 860 EVO 2TB SSD
Series III 32 v2.5.17953, Revelator io24 v1.13
User avatar
by mombof on Mon Oct 11, 2021 1:06 pm
Have a similar problem with my HP x360 windows10 laptop. All version 3 of the universal control app drivers do not install the itwo device for me, only 2.9 of UC works. Apparently it has some weird issue with some hardware and versions of win10 and does not install the asio control panel or the asio drivers and the universal control app is empty and shows nothing at all except the File, System, and Demo menu.. It wasnt until installed version 2.9 that all the above worked for the first time with the itwo interface.
after none of the asio hosts worked and no finding any asio control panels, I had thought "oh well, must only be a usb class device and doesn't have asio"... today i gave it one more search and saw that 2.9 of universal control fixes many compatibility issues! and once i installed it Everything worked as expected, uc shows my itwo device and that ithas a fimware update availble, allth ehosts apps show asio driver availble and i also have asio control panel! I was pleasantly surprised.

3 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest