Share your songs!
15 posts
Page 1 of 1
I've been going through and adding the "audio" tags for you guys so it's easier for others to listen to your music via an embedded audio player. I thought I would post this suggestion and info on how to do this yourself.

It's fairly easy. On the "Post new topic" screen, there are two buttons above the "Message" window - one called "audio" and one called "video". The forum FAQ states:
We support SoundCloud, PromoDJ.com, as well as oga, ogg, mp3, and m4a audio files via HTML5

So all you have to do is go to the URL for the audio you want to share and copy it. Then in your message, wherever you want the embedded audio player to appear, click the "audio" button and the BBCode audio tags will be inserted for you. Simply paste the URL you copied above in between these tags and you will now have an embedded audio player instead of a link to another website.

I usually click the "Preview" button to make sure all is kosher before clicking "Submit" but that's up to you.

Happy sharing!

I am Sir Melvis Bacon, Knight of BaconHam Palace.

Studio One 2 Pro 3.3.x (64 bit). MacBook Pro 13". OS X Sierra version 10.12.3.
RM16AI and CS18AI connected in Stagebox mode via MOTU AVB Switch.
StudioLive 328AI (x2); AudioBox 22 VSL; BlueTube DP V2; FaderPort; Monitor Station; RC 500; Temblor T10.

To add your software and hardware specs to your signature to make it easier for us to help you, click HERE.

My Website
User avatar
by boudie123 on Sat Jul 04, 2015 12:37 pm
So,, I can take a song mastered in studio one straight to this forum with having to go to soundcloud,etc. and have it heard in this forum? I've been trying for months to get a song to this site, to no avail. PERHAPS, YOU CAN WALK ME THROUGH THIS?

presonus 1642.. studio one pro 2.. presonus Sceptre 8.. les paul epiphone standard pro.. Ibanez g2000 bass.. Yamaha apx500ii.. apple imac intel core i5 processor. presonus hp4.. ez drummer2... melodyne essentials , mapex drums ,big baby taylor. persons sceptre 8, presonus monitor station,ozone isotope 7, peavey t-40, peavey falcon, yamaha ypg 535
User avatar
by mwright137 on Sat Jul 04, 2015 12:42 pm
As I said - you need to go to the url where the MP3 is already, so it needs to be online somewhere for the streaming to work.

I believe you can attach an MP3 to a post, but then people have to download the file to play it unless their browser supports playing the file.

I am Sir Melvis Bacon, Knight of BaconHam Palace.

Studio One 2 Pro 3.3.x (64 bit). MacBook Pro 13". OS X Sierra version 10.12.3.
RM16AI and CS18AI connected in Stagebox mode via MOTU AVB Switch.
StudioLive 328AI (x2); AudioBox 22 VSL; BlueTube DP V2; FaderPort; Monitor Station; RC 500; Temblor T10.

To add your software and hardware specs to your signature to make it easier for us to help you, click HERE.

My Website
User avatar
by mickedge on Thu Aug 03, 2017 3:49 am
Once again i seem to be the only one here unable to figure out something which seems to be so simple to everyone else. I cannot for the life of me, figure out how to embed an audio player. I posted a song which is hosted on soundcloud but it just links to soundcloud. As always, i have followed the steps outlined here. It just doesn't work for me somehow..?

Can someone, anyone tell me what i am doing wrong..?

I just tried again....went to soundcloud...& i cannot even see a URL...???

Appreciate any help...

Dell XPS-15, i7, 16GB RAM, 250GB SSD, Apollo Twin USB, Studio One 3 Pro, Win 10, guitars....lots of guitars..!
User avatar
by mickedge on Fri Aug 04, 2017 8:48 am
mwright137 wrote
So all you have to do is go to the URL for the audio you want to share and copy it. Then in your message, wherever you want the embedded audio player to appear, click the "audio" button and the BBCode audio tags will be inserted for you. Simply paste the URL you copied above in between these tags and you will now have an embedded audio player instead of a link to another website.

Happy sharing!



Ok, so it seems that this is fairly elementary for 99.9% of people here. Good. For some reason, i CANNOT get this simple thing to work. I follow the steps meticulously, i have read the guide on how to embed an audio player more than 20 times now. No matter what i do....i cannot embed the audio player, it just links to soundcloud. Is that it...?

If i go to my soundcloud app to share the song, there is NO URL....its not a web page. If i google soundcloud, it opens my soundcloud app which means there is STILL NO URL TO COPY & PASTE..! I can share it from there.....but it just links to souncloud. Honestly.....i feel like i'm living in the twilight zone..!

Is there some caveat or gotcha that i'm not aware of? Is there a fee that needs to be paid..? Is there a secret code word..? Do i need a masters degree in computer science....? What exactly do i need to do, in order to do this simple thing which 99.9 % of folks do without having ask the questions i'm asking here...?????

Sorry for my sarcasm & frustration ...but this is supposed to be really simple....right..?

Dell XPS-15, i7, 16GB RAM, 250GB SSD, Apollo Twin USB, Studio One 3 Pro, Win 10, guitars....lots of guitars..!
User avatar
by PreSonuSupt4 on Fri Aug 04, 2017 1:06 pm
Hi,

We fixed your other thread. Your SoundCloud song is embedded there now. viewtopic.php?f=206&t=26404 You just had the formatting wrong. Doing this below, wrapping it with the [audio] tag ...

Code: Select all
[audio]https://soundcloud.com/user-448119360/the-beer-song[/audio] 
... will embed the Soundcloud song into a forum post.
User avatar
by mickedge on Fri Aug 04, 2017 5:32 pm
PreSonuSupt4 wroteHi,

We fixed your other thread. Your SoundCloud song is embedded there now. viewtopic.php?f=206&t=26404 You just had the formatting wrong. Doing this below, wrapping it with the [audio] tag ...

Code: Select all
[audio]https://soundcloud.com/user-448119360/the-beer-song[/audio] 
... will embed the Soundcloud song into a forum post.



Thank you. Having never needed to embed an audio player anywhere before, i obviously had no idea i had to actually edit anything....& honestly i dont understand how i was meant to know that..?

Cheers

Dell XPS-15, i7, 16GB RAM, 250GB SSD, Apollo Twin USB, Studio One 3 Pro, Win 10, guitars....lots of guitars..!
User avatar
by PreSonuSupt4 on Sat Aug 05, 2017 7:31 am
There's a guide here: faq.php?mode=bbcode but the audio tag isn't in it.
User avatar
by leosutherland on Sat Dec 08, 2018 3:17 pm
Apologies for resurrecting this.

What button or menu item do I click on the Soundcloud site to get the URL of one of my tracks?

...said Halo

Studio One Pro v4.1.1
Xpand!2 +AIEP3, Serum, E-Hu Diva, Syntronik Bully
KLC: Polysix, Monopoly, Wavestation
Windows 10 Home 64-bit

3XS SQ170 Music Studio PC (Main DAW)
i7 8700 Hexcore 3.2GHz, 16GB DDR4-2666
500GB Samsung 970 EVO M.2 NVMe SSD + 1TB SATA HD
Focusrite Scarlett 2i4 (Gen 2), Korg Taktile 25
Faderport V2


MSI GE62VR 7RF Apache Pro (Standby DAW)
Intel Core i7 7700HQ 2.8GHz, 16GB RAM
500GB Samsung 970 EVO M.2 NVMe SSD + Samsung 1TB 860 SATA III SSD
User avatar
by sirmonkey on Sat Dec 08, 2018 8:28 pm
Click on the "Share" button. Then just copy the link and paste it wherever you need.

Atari 5200, 64K RAM S1PRO Radio Shack Cassette Recorder w/internal Mic,
User avatar
by leosutherland on Sun Dec 09, 2018 4:57 am
Click on the "Share" button. Then just copy the link and paste it wherever you need.

OK did exactly that - when I Previewed my post I got a message:

Sorry this URL is not supported :roll:

I saw that URL had an extra code at the end

...soundcloud.com/<user name>/<song name>/<some sort of code>

so I removed that so it would be same format as

...soundcloud.com/<user name>/<song name>

as described above in the thread - this time I get the message:

You have not provided a valid Soundcloud URL :shock: :roll:

So what is going on? :evil: ie. GRRRRR!

...said Halo

Studio One Pro v4.1.1
Xpand!2 +AIEP3, Serum, E-Hu Diva, Syntronik Bully
KLC: Polysix, Monopoly, Wavestation
Windows 10 Home 64-bit

3XS SQ170 Music Studio PC (Main DAW)
i7 8700 Hexcore 3.2GHz, 16GB DDR4-2666
500GB Samsung 970 EVO M.2 NVMe SSD + 1TB SATA HD
Focusrite Scarlett 2i4 (Gen 2), Korg Taktile 25
Faderport V2


MSI GE62VR 7RF Apache Pro (Standby DAW)
Intel Core i7 7700HQ 2.8GHz, 16GB RAM
500GB Samsung 970 EVO M.2 NVMe SSD + Samsung 1TB 860 SATA III SSD
User avatar
by sirmonkey on Sun Dec 09, 2018 9:44 am
Hmmm. I know the feeling. But maybe it's this:
When you copy the link, does it start with "https:...." ? If so, get rid of that part. Paste the link, but then delete the "https" part, so that the link then reads "www..... "
The "https" part is some sort of security thingy (I think) that identifies individual computers, and works to only give access to certain computers. There's complex anti-hacking stuff under the hood.
So in short, leaving the "https" part out lets you make a link public. So maybe that's it. If not, fear not... we'll figure it out.

Atari 5200, 64K RAM S1PRO Radio Shack Cassette Recorder w/internal Mic,
User avatar
by leosutherland on Sun Dec 09, 2018 10:52 am
Hi Simon

No combination of http, https, www, or the funny code at the end being there or not being there makes any difference. In fact if I try

http://www.soundcloud.com <===

then it fails, and the post is changed to read

http://www.soundcloud.com :?

And in additon, when I preview this post, the the www-soundcloud-com that I put above (marked <===, note I had to replace the '.' with '-' to stop what I just wrote getting httpified as well) also gets changed to http://www.soundcloud.com - so apparently the forum engine sees it as a link because of the www and sticks http in front of it. If I don't put www, or http or https at the start, it just gets put into the post as plain text.

I know, that is horribly confusing :)

...said Halo

Studio One Pro v4.1.1
Xpand!2 +AIEP3, Serum, E-Hu Diva, Syntronik Bully
KLC: Polysix, Monopoly, Wavestation
Windows 10 Home 64-bit

3XS SQ170 Music Studio PC (Main DAW)
i7 8700 Hexcore 3.2GHz, 16GB DDR4-2666
500GB Samsung 970 EVO M.2 NVMe SSD + 1TB SATA HD
Focusrite Scarlett 2i4 (Gen 2), Korg Taktile 25
Faderport V2


MSI GE62VR 7RF Apache Pro (Standby DAW)
Intel Core i7 7700HQ 2.8GHz, 16GB RAM
500GB Samsung 970 EVO M.2 NVMe SSD + Samsung 1TB 860 SATA III SSD
User avatar
by sirmonkey on Sun Dec 09, 2018 2:35 pm
Just above the text box, there are 3 bottons: "audio" , "collapse", and "video". When you click "audio", a pair of quotes gets inserted, with the cursor put in between them. Then paste, and do the same as before (get rid of "http).
Maybe you're already doing this, but posting without using the "audio" button should still work (it should still appear as a text link to Soundcloud, even if the waveform doesn't appear on the post).
Maybe your browser security settings have something to do with this....but this is just a wild guess.
Does posting audio work in other forums?

Atari 5200, 64K RAM S1PRO Radio Shack Cassette Recorder w/internal Mic,
User avatar
by klypeman on Sun Dec 09, 2018 3:43 pm
Here is what I do:
First I go to my Soundcloud page with my music on, select the song and goto the little pencil (edit) and goto permissions and allow Display embeded code and save the changes , then start the song I want to post in "Made in SO", go down on the right to the player on Soundcloud and right-click the playing title And select "copy the link" and do that, then switch to the forum page and goto "made in SO" and post a new topic and write the title then down to the text field with my cursor press once and press the audio button once, make shure my cursor is between the two audio brackets then press Ctrl and then V to paste the link I just copied, goto the end of the last bracket and press return. After that I write the text/greetings I want and press the submit. Done.
Hope this helps.
:)

Windows 10 64bit Home, Studio One 3.5.6, Studio One 4.1, Cubase 9.5.2 , Logic, Pro Tools, MacBook Pro, 24.4.2, Project, Firestudio 2626, Firestudio Mobile, Midas 320, Yamaha MGXU16, Soundcraft Spirit, Faderport 1+8, Mackie MCU, Softube Console 1, All Steinberg CMC´s, Yamaha SY 55, DSI Mopho, Roland JU-06, Impulse 49, NI Maschine Mk.3, NI Komplete S61, KRK Rokits 6´s, KRK VXT 8´s, SE Electronics HP6, CME 61, Nocturn 25, UAD Plugins, TC Touch, UAD Apollo Twin USB/TB Duo, Satellite Quad, Quad PcIe, Warm Audio 76, JoeMeek MC2, DBX 266XS, TC C300, TC 2290, Yamaha REV 7. Toontrack. :mrgreen:

15 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest