Routers, Switches, Cabling, Access Points, Repeaters, etc all discussed here
8 posts
Page 1 of 1
Hey all. I’m trying to help out a customer and I’m not in front of the board so I’m a little handicapped troubleshooting myself. Here goes:

Studiolive 32 SII with two NSB 16.8’s. Inputs from the NSB all seem to be working fine, but on channels 25-32 they can’t get phantom power to lock on. The push the button on the mixer, but there is no change in the display and the indicator on the NSB doesn’t light up. When they change the input on the board to the onboard XLR, phantom power lights up and provides.

Ideas?

Thanks in advance.
User avatar
by wahlerstudios on Tue May 05, 2020 6:23 pm
There were problems with phantom power display in earlier firmware versions, which were resolved. You should always use the latest version:

● Series III Firmware - v2.3.0.16845
● NSB 16.8 - v1.2.16705
● NSB 8.8 - v1.2.16705
● EarMix - v1.2.16705
● SW5E - v1.2.16705

The files can be downloaded on the download pages of mixer and stagebox or in your PreSonus account.

SL16 | 32R | 16R | 3* 16M | SW5E

Apple routers | iPads | Alesis iO Docks | Yamaha S112, S15e, S10e, SM10 | LD Systems Curv 500 | Galaxy Audio Hot Spots | Mac mini | Lenovo Laptop | Studio One Artist 5.1.2 & Pro 3.5.6
User avatar
by Josjor on Tue May 05, 2020 6:25 pm
wahlerstudios wroteThere were problems with phantom power display in earlier firmware versions, which were resolved. You should always use the latest version:

● Series III Firmware - v2.3.0.16845
● NSB 16.8 - v1.2.16705
● NSB 8.8 - v1.2.16705
● EarMix - v1.2.16705
● SW5E - v1.2.16705

The files can be downloaded on the download pages of mixer and stagebox or in your PreSonus account.

I should have mentioned: all updates done with the latest firmware just this Saturday on the mixer and the two NSB16.8’s.
User avatar
by wahlerstudios on Tue May 05, 2020 6:29 pm
Ah, I see. I don't own a NSB stagebox, so I can't check what the situation is. Could you try this firmware version for the mixer?

● StudioLive Series III (all models) - v2.2.16741

SL16 | 32R | 16R | 3* 16M | SW5E

Apple routers | iPads | Alesis iO Docks | Yamaha S112, S15e, S10e, SM10 | LD Systems Curv 500 | Galaxy Audio Hot Spots | Mac mini | Lenovo Laptop | Studio One Artist 5.1.2 & Pro 3.5.6
User avatar
by SwitchBack on Tue May 05, 2020 6:45 pm
Probably, unless they have a lot of custom patching going, a reset of all digital patching is a good idea. Should get rid of any previous patching gremlins.

If the reset doesn’t restore phantom power control for all NSB channels then at least It will take a lot of guesswork out of further communication with your customer ;)
User avatar
by johne149 on Sat Feb 06, 2021 10:07 pm
i have a 16.8 nsb have phantom power only working on input 4 have an 8.8 all phantom power works but none outputs working
User avatar
by SwitchBack on Sun Feb 07, 2021 4:45 am
There's quite a few details you need to get right before an NSB does what you want it to do. Of course there's the possibility of a faulty unit but with these mixers I'd look at user error first. This is not a plug-and-play system, far from it..

So maybe we - as a users community - can come up with a step-by-step to rule out faulty gear. And users with problems should provide details about their gear, computer, setup, software and firmware versions, and experience level. One-liners won't do with these complex mixers. Thanks :)
User avatar
by wahlerstudios on Sun Feb 07, 2021 10:19 am
Did you check this video?

"Routing Outputs to One PreSonus NSB Stage Box"

https://youtu.be/07Vp68rprBA

SL16 | 32R | 16R | 3* 16M | SW5E

Apple routers | iPads | Alesis iO Docks | Yamaha S112, S15e, S10e, SM10 | LD Systems Curv 500 | Galaxy Audio Hot Spots | Mac mini | Lenovo Laptop | Studio One Artist 5.1.2 & Pro 3.5.6

8 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 2 guests