AudioBox 1818VSL, 44VSL and 22VSL
2 posts
Page 1 of 1
Hello peeps!

I've had an AudioBox1818VSL for a few years now, and just recently migrated to a new Macbooks computer, 2016 model with USB3/Thunderbolt ports. OS is High Sierra.

I can run it, both with Universal Control (ver. 2.5) running and not running, but sound is interrupted every 1/10 of a second. Sort of kill-switch on-and-off sound effect. Haven't tried recording with it, but all output sound has this fault.

Universal Control says I should be updating Firmware to 1.49, since it says my box has firmware 1.04 installed. I do the update, but afterwards my AudioBox just shows red light, and nothing in, nothing out.
After leaving it off for a few minutes, it'll come to life again, and back at square one. UC says update firmware, and wobbly coming-and-going sound in output.

Is this hardware? Is this software? Is my machine incompatible, or is the box finally dead?

PS: Did the installation just as described, by first running the uninstall to get rid of anything old related, rebooting, then installing UC and plugging in the box.
User avatar
by waibp on Mon Jan 15, 2018 8:31 am
I have the same problem, I would now need to wait several days for my audio box 1818 (powered off) to revert back to firmware 1.48 for it to work again. It work fine before updating to firmware 1.49. After the update to firmware 1.49 my mac just could not detect the 1818vsl, I've tried with Windows also, same problem. I've tried Presonus helpdesk.......what a disappointment. Every time the UC detected old firmware, its goes auto update again......the problem repeats.....I'm considering other audio interface. Please let meknow if you have a fix. Thanks

2 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 3 guests