Page 1 of 1

Audiobox 1818VSL not working after Firmware 1.49 update

Posted: Wed Nov 22, 2017 2:45 am
by waibp
Hi All,

My Audiobox 1818 was working fine, before the update. Once updated to v1.49, the system is unable to detect the 1818...... the USB sync button will go from Blue to Red and blink between then stops at red. Is there any ways I can revert the firmware and stop the system from automatically updating the firmware? HELPPPP thanks

SYS:
Mac Mini (2012) Core i5, OS High Sierra/8GB Ram, SSD & External HDD. USB 2.0,

Re: Audiobox 1818VSL not working after Firmware 1.49 update

Posted: Tue Apr 03, 2018 2:37 pm
by soadek
Hi!

Just wanted to ask if you (or anyone having a similar problem) managed to fix it?
My 1818VSL was working great for around 4-5 years. My first firmware update to 1.48 ended in a failure since my USB cable somehow stopped working. The thing went crazy after that. I finally managed to update it succesfully to 1.49 (had to do a full uninstall from the Presonus page) and now I have the same problem. It goes from blue to red and my PC won't even recognize it anymore...

Any suggestions?

Thanks in advice,
Karol M.

Edit:
Nevermind... I switched it off, waited a few minutes and it's working again. But it seems the firmware update to 1.49 failed. I'm stuck with 1.48. Still not sure if I can finally record anything or not.

Edit 2:
Allright... still nothing. After changing the bitrate to 16 bit, 48 kHz the device gets disconnected and I have to switch it off for a few minutes before I can use it again. Still not fully functional.

Re: Audiobox 1818VSL not working after Firmware 1.49 update

Posted: Sat Jun 30, 2018 8:11 pm
by bruceleonard1
I have the same problem and tried my backup tablet and it tried to roll back the firmware update from 1.49 to 1.48 but it just fails and the regular computer I use on it doesn't efen give my a firmware option. Any one > or do I have to dump windows 10 for 8 to get my 1818 to run? since Microsoft isn't fixing their mistakes . :) Bruce Leonard