AudioBox 1818VSL, 44VSL and 22VSL
3 posts
Page 1 of 1
I am using AudioBox 22VSL for a long time now, and never had and issue I could not handle.
But this time something happened, and for some reason every time I play a sound on my PC, even if it's just a windows volume control I have 2 pops.
First I checked if the sample rate is the same in universal audio and Win10. And everything is fine there.
I feel like drivers go to sleep after being inactive for 10 seconds.

This happened when I downloaded VU Meter from the website, and once I launched the installation file, I got this error "This file does not have a valid digital signature", and at the same time (and for the first time ) speaker icon in task bar got a red cross (as if it got inactive for few seconds).

So I tried installing fresh drivers that also did not work.
Only thing that is working is if I check listen to Line in all the time in Windows settings, but I don't like that option to be permanent since all was working fine before.

Did anyone else had similar issue?

If this helps:
OS: Win 10 64bit
CPU: i9700kf
GPU: GT 7300
Ram: 32GB

Thank you,

Error I got when started the VUMeter installer.

PC: CPU:i9700kf, Ram 32GB DDR4 Kingston HyperX, GPU: Nvidia GT730 2Gb, Audio Interface: RME BabyFace Pro FS, WIN 10 64bit, DAW Studio one v5
User avatar
by NatoCannon on Wed Jan 11, 2023 3:32 pm

Necro'ing thread because I just went through this frustration and finally fixed it.

1) You need to uninstall the modern version of Universal Control + the driver for the audiobox
2) you need to download the oldest version of the Audiobox control software called "AudioBox VSL v1.3" - go to the product page's downloads, click "Show / Hide all versions of software downloads" on the left, and download "AudioBox VSL v1.3"
3) Install that, then configure the windows audio (AND THE MICROPHONE DEVICE!!) to all be the same input kHz as each other / what you wanna work in, whether that's 44.1, 48, whatever.

There was still the odd pop whenever devices were transitioning between sample rates, but I figured out that was because my mic device was set to 44.1kHz in Windows and I was using discord/nvidia broadcast to do some stuff :roll:

Anyway, points to presonus at the very least that this old (functional) driver software is still easily available and works seamlessly with windows. I'll be sticking on this one until I can't anymore. It's not perfect but hey it all still works, even with the new drivers pops are suboptimal but I'd still be able to work with the unit at least.

Also, bonus! VSL actually works properly on the old driver and doesn't work with the newer Universal Control. :thumbup:
User avatar
by aleksandarristic on Wed Mar 08, 2023 2:52 pm
Thank you for your reply! Hopefully somebody will find this helpful!
I have replaced my interface with a better one so no issues with drivers anymore.

PC: CPU:i9700kf, Ram 32GB DDR4 Kingston HyperX, GPU: Nvidia GT730 2Gb, Audio Interface: RME BabyFace Pro FS, WIN 10 64bit, DAW Studio one v5

3 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest