AudioBox 1818VSL, 44VSL and 22VSL
6 posts
Page 1 of 1
Hi All,

My Audiobox 1818 was working fine, before the update. Once updated to v1.49, the system is unable to detect the 1818...... the USB sync button will go from Blue to Red and blink between then stops at red. Is there any ways I can revert the firmware and stop the system from automatically updating the firmware? HELPPPP thanks

SYS:
Mac Mini (2012) Core i5, OS High Sierra/8GB Ram, SSD & External HDD. USB 2.0,
User avatar
by soadek on Tue Apr 03, 2018 2:37 pm
Hi!

Just wanted to ask if you (or anyone having a similar problem) managed to fix it?
My 1818VSL was working great for around 4-5 years. My first firmware update to 1.48 ended in a failure since my USB cable somehow stopped working. The thing went crazy after that. I finally managed to update it succesfully to 1.49 (had to do a full uninstall from the Presonus page) and now I have the same problem. It goes from blue to red and my PC won't even recognize it anymore...

Any suggestions?

Thanks in advice,
Karol M.

Edit:
Nevermind... I switched it off, waited a few minutes and it's working again. But it seems the firmware update to 1.49 failed. I'm stuck with 1.48. Still not sure if I can finally record anything or not.

Edit 2:
Allright... still nothing. After changing the bitrate to 16 bit, 48 kHz the device gets disconnected and I have to switch it off for a few minutes before I can use it again. Still not fully functional.
User avatar
by bruceleonard1 on Sat Jun 30, 2018 8:11 pm
I have the same problem and tried my backup tablet and it tried to roll back the firmware update from 1.49 to 1.48 but it just fails and the regular computer I use on it doesn't efen give my a firmware option. Any one > or do I have to dump windows 10 for 8 to get my 1818 to run? since Microsoft isn't fixing their mistakes . :) Bruce Leonard
User avatar
by dnino4 on Thu Sep 03, 2020 4:41 pm
Seems I have the same problem. So, what next?
User avatar
by cristofe on Fri Sep 04, 2020 11:39 am
Buy a NEW expensive interface.....or buy an old USED cheap computer.....or sell the 1818 to some sucker. I'll give you $20 for it....LOL!! :lol:

https://soundcloud.com/cristofe-chabot/sets/main

PC'S: HP XW6000 Dual 3.2GHz Intel Xeon, 8GB RAM WinXP SP2 HP 6005 Pro AMD Athalon X2 B24 3.0Ghz, 4GB RAM Win8 Pro Dell Latitude E6410 Laptop Intel i5 2.67Ghz 8GB RAM Win7 Pro x64 Audio Interfaces: Terratec EWS88MT PCI (2), Audiobox 1818VSL USB & Firestudio 26x26 Firewire, Line 6 PodXT, Roland GS-10, NI Rig Kontrol 3

Monitors: Yamaha HS50M's DAW: S1 3.2.1 Pro

To add your software and hardware specs to your signature to make it easier for us to help you, click HERE.
User avatar
by shocktech on Wed Sep 16, 2020 9:34 am
I also have the same problem after upgrading to OSX El Capitan, Studio One 4 and Universal Control. It worked perfect on Mt. Lion and S1 v3 (???). After creating a support ticket I was handed off to 4 or 5 people each time I responded. And I got the usual responses: send the .spx file, re-install my OS X, send in the device for repair, ...blah, blah, blah. I guess this device will not function as a class-compliant device as we were led to believe by Presonus. All I can say is...what poor tech support and what a waste of time!
So I took another chance with Presonus and got a Quantum 2626 from Sweetwater a week ago. I couldn’t believe it,....it’s not working with my iMac Thunderbolt 1!!! (Is it really Thunderbolt backward compatible??) Currently, Sweetwater has been very helpful in trying to resolve this issue, but still no fix to date. I created a support ticket to Presonus to see what they had to say. The usual,...send spx file, they said I didn’t have the Quantum powered on when I downloaded the file (not!), and their last response was (laughable) …send the brand new Quantum in for repair. Unbelieveable!!!

Imac 27", 3.4 GHz Intel Core Duo i7, 16gb
OS X 10.11 El Capitan
Studio One 4.6
Audiobox 1818vsl

6 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest